[MASTER] abrowser-3.0 and others do not start: :$pkglibdir/abrowser link missing

Bug #273907 reported by John Vivirito on 2008-09-24
14
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
High
Unassigned
Intrepid
High
Unassigned

Bug Description

The latest build of abrowser fails to start.
version 3.0.2+build6+nobinonly-0ubuntu1
when trying to start from terminal i get:

exec: 118: /usr/lib/firefox-3.0.2/abrowser: not found

Alexander Sack (asac) on 2008-09-24
Changed in firefox-3.0:
importance: Undecided → High
milestone: none → ubuntu-8.10-beta
status: New → Triaged
Alexander Sack (asac) wrote :

fix committed to firefox-3.0.head branch (rev 341)

Changed in firefox-3.0:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox-3.0 - 3.0.2+build6+nobinonly-0ubuntu2

---------------
firefox-3.0 (3.0.2+build6+nobinonly-0ubuntu2) intrepid; urgency=low

  * fix LP: #273907 - abrowser does not start: :$pkglibdir/abrowser link
    missing; we introduce the proper link in the firefox-3.0 package
    - update debian/rules
  * fix LP: #269795 - abrowser shouldn't display the EULA; we fix this by
    using brand.properties to determine whether we have official branding or
    not. In turn the about:rights notification only gets displayed when
    official build is running.
    - update debian/patches/lp269656_know_your_rights.patch
  * fix LP: #206191 - Firefox 3 "set as Desktop background" does not work
    properly; we cherry-pick latest upstream patch from bugzilla
    - add debian/patches/bz421977_att334578.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden> Wed, 24 Sep 2008 18:48:23 +0200

Changed in firefox-3.0:
status: Fix Committed → Fix Released
John Vivirito (gnomefreak) wrote :

this is happening all over this place now. see dups for all diff. browser links not working. including sensible-browser and x-ww-browser as well as *-3.0 firefox and abrowser. marking all as a dupe of this one.

Changed in firefox-3.0:
status: Fix Released → Confirmed
Steve Langasek (vorlon) wrote :

the other bugs are not the same as this one. This was due to the firefox wrapper looking in the wrong directory; the others are due to the wrapper assuming that $0 is a valid binary name, which breaks for a number of symlinks. Closing this bug again, retargeting the other for ubuntu-8.10 since this is too late for beta.

Changed in firefox-3.0:
status: Confirmed → Fix Released

Steve Langasek wrote:
> the other bugs are not the same as this one. This was due to the
> firefox wrapper looking in the wrong directory; the others are due to
> the wrapper assuming that $0 is a valid binary name, which breaks for a
> number of symlinks. Closing this bug again, retargeting the other for
> ubuntu-8.10 since this is too late for beta.
>
> ** Changed in: firefox-3.0 (Ubuntu Intrepid)
> Status: Confirmed => Fix Released
>
>
All these bugs are related to missing symlinks or broken symlinks. When
this bug was fixed (running abrowser/firefox working) see changelog
above. now abrowser-3.0/firefox-3.0 dont work, how do you explain this
being different? you think one fix didnt break another?

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers