Ubuntu

firefox installs unnecessary packages when installing on KDE

Reported by Anish Bhatt on 2008-09-05
This bug report is a duplicate of:  Bug #132072: Feature Request: Adept support. Edit Remove
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Dustin Widmann
Nominated for Jaunty by Dustin Widmann
firefox-3.0 (Ubuntu)
High
Unassigned
Nominated for Intrepid by Dustin Widmann
Nominated for Jaunty by Dustin Widmann

Bug Description

Binary package hint: firefox

firefox installation is hugely bloated. 123MB, and installs a lot of gnome packages on KDE 4.1. Seen in Kubuntu Intrepid Alpha 5.

ubuntu@ubuntu:~$ sudo apt-get install firefox-3.0
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  app-install-data apturl docbook-xml gksu gnome-app-install gnome-icon-theme
  launchpad-integration libcairo-perl libgksu2-0 libglib-perl
  libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgnomeui-0
  libgnomeui-common libgtk2-perl libgtkhtml2-0 libgtop2-7 libgtop2-common
  liblaunchpad-integration1 librsvg2-common libscrollkeeper0 libvte-common
  libvte9 python-cairo python-gconf python-glade2 python-gst0.10 python-gtk2
  python-gtkhtml2 python-launchpad-integration python-numeric python-pyorbit
  python-sexy python-vte scrollkeeper sgml-data software-properties-gtk
  synaptic ubufox xulrunner-1.9
Suggested packages:
  docbook docbook-dsssl docbook-xsl docbook-defguide firefox-3.0-gnome-support
  latex-xft-fonts libgtk2-perl-doc python-gconf-dbg python-gtk2-doc
  python-gst0.10-dbg python-gtk2-dbg python-gnome2-extras-doc
  python-launchpad-integration-dbg python-numeric-tutorial python-numeric-ext
  python-numeric-dbg python-pyorbit-dbg perlsgml doc-html-w3 opensp
  libxml2-utils dwww menu deborphan
The following NEW packages will be installed:
  app-install-data apturl docbook-xml firefox-3.0 gksu gnome-app-install
  gnome-icon-theme launchpad-integration libcairo-perl libgksu2-0 libglib-perl
  libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgnomeui-0
  libgnomeui-common libgtk2-perl libgtkhtml2-0 libgtop2-7 libgtop2-common
  liblaunchpad-integration1 librsvg2-common libscrollkeeper0 libvte-common
  libvte9 python-cairo python-gconf python-glade2 python-gst0.10 python-gtk2
  python-gtkhtml2 python-launchpad-integration python-numeric python-pyorbit
  python-sexy python-vte scrollkeeper sgml-data software-properties-gtk
  synaptic ubufox xulrunner-1.9
0 upgraded, 42 newly installed, 0 to remove and 56 not upgraded.
Need to get 29.7MB of archives.
After this operation, 123MB of additional disk space will be used.
Do you want to continue [Y/n]?

Jonathan Thomas (echidnaman) wrote :

I can confirm this.

Changed in firefox:
status: New → Confirmed
Wesley Velroij (velroy1) wrote :

I can confirm this to and i think the importance off this bug should be higher.

*** This is an automated response ***

Thank you for your bugreport. Since this seems to be an issue with
version 3 of the firefox browser, I'm reassigning the package. If you
feel this is an error, please don't hesitate to add a comment to your
report.

 affects ubuntu/firefox
 status invalid

 affects ubuntu/firefox-3.0
 status confirmed

Changed in firefox:
status: Confirmed → Invalid
Changed in firefox-3.0:
importance: Undecided → Medium
Changed in firefox-3.0:
importance: Medium → High

Appears to be fixed now, as ubufox is a depends.

Changed in firefox-3.0:
status: Confirmed → Fix Released
Jonathan Thomas (echidnaman) wrote :

*Recommends, not depends.

Anish Bhatt (anish7) wrote :

With Kubuntu Intrepid RC, bug still appears to be present. I can see a lot of gnome packages being installed alongwith firefox.

ubuntu@ubuntu:~$ sudo apt-get install firefox
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  apturl docbook-xml firefox-3.0 firefox-3.0-branding gamin gconf2
  gconf2-common gksu gnome-app-install gnome-icon-theme gnome-keyring
  gnome-mime-data gnome-mount libavahi-glib1 libbonobo2-0 libbonobo2-common
  libbonoboui2-0 libbonoboui2-common libcairo-perl libgamin0 libgconf2-4
  libgksu2-0 libglade2-0 libglib-perl libgnome-keyring0 libgnome2-0
  libgnome2-canvas-perl libgnome2-common libgnome2-perl libgnome2-vfs-perl
  libgnomecanvas2-0 libgnomecanvas2-common libgnomeui-0 libgnomeui-common
  libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgp11-0 libgtk2-perl
  libgtkhtml2-0 libgtop2-7 libgtop2-common libidl0 liblaunchpad-integration1
  libnotify1 liborbit2 libpam-gnome-keyring libpolkit-gnome0 librsvg2-common
  libscrollkeeper0 libsexy2 libstartup-notification0 libvte-common libvte9
  libwnck-common libwnck22 libxres1 notification-daemon policykit-gnome
  python-cairo python-gconf python-glade2 python-gst0.10 python-gtk2
  python-gtkhtml2 python-launchpad-integration python-numeric python-pyorbit
  python-sexy python-vte scrollkeeper sgml-data software-properties-gtk
  synaptic ubufox xulrunner-1.9

Tom Arnold (g0tt) wrote :

This is not fixed. It is even worse now.

Fresh Kubuntu install and it still wants to install 132 MB of mostly unnecessary bloat.

Changed in firefox-3.0:
status: Fix Released → Confirmed
John Vivirito (gnomefreak) wrote :

Marked as confirmed

Changed in firefox:
status: Invalid → Confirmed
Christoph Langner (chrissss) wrote :

If you want to install Firefox without the GNOME dependencies use

$ sudo apt-get install --no-install-recommends firefox-3.0

This will install Firefox only...

Tom Arnold (g0tt) wrote :

Yeah,

apparently you can do

sudo aptitude install firefox-3.0 ubufox= gksu=

or

sudo aptitude -s -R install firefox

but although a few people acknoledged this bug it really seems to be a wontfix ..

Alvin (alvind) wrote :

WONTFIX won't do. What about people who don't use the command line to install firefox?
(ok, they will now receive the option to use both Adept and Synaptic.)

John Vivirito (gnomefreak) wrote :

what is wrong with the depends as they are.

show firefox-3.0
Depends: fontconfig, psmisc, debianutils (>= 1.16), xulrunner-1.9 (>= 1.9.0.1), libatk1.0-0 (>= 1.20.0), libc6 (>= 2.4), libcairo2 (>= 1.2.4), libfontconfig1 (>= 2.4.0), libfreetype6 (>= 2.3.5), libgcc1 (>= 1:4.1.1), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.14.1), libnspr4-0d (>= 1.8.0.10), libpango1.0-0 (>= 1.21.6), libstdc++6 (>= 4.1.1), zlib1g (>= 1:1.1.4), firefox-3.0-branding (>= 3.0.3+nobinonly-0ubuntu1~) | abrowser-3.0-branding (>= 3.0.3+nobinonly-0ubuntu1~)

If you are using kde than you need the gtk libs if you dont want them or install without them you may see problems with firefox. I dont see anything in this package that should be removed. ubufox is in recommends and that would mean its installed by defualt when installing firefox. This is due to changes in apt to include recommends.

Alexander Sack (asac) wrote :

the firefox part is tracked in bug 271524 ... which is now fix committed

Changed in firefox-3.0:
status: Confirmed → Invalid
Alexander Sack (asac) wrote :

apturl part is a duplicate of bug 132072 (adept support of apturl)

Changed in apturl:
status: Confirmed → Triaged
Eric B (ebischoff) wrote :

I really don't see why this annoying bug has be qualified as a duplicate of bug 132072... It's at most related.

And for the command line users,
$ sudo apt-get install --no-install-recommends firefox-3.0
is certainly a good workaround, but not a "solution".

Eric B (ebischoff) wrote :

I must add that with firefox 3.0.6, there is still a lot dependancies, so the "firefox part" is certainly not solved yet :

Les NOUVEAUX paquets suivants seront installés :
  apt-xapian-index apturl firefox-3.0 firefox-3.0-branding gksu gnome-app-install gnome-icon-theme
  libcairo-perl libgksu2-0 libglib-perl libgnome2-canvas-perl libgnome2-perl libgnome2-vfs-perl libgtk2-perl
  libgtop2-7 libgtop2-common liblaunchpad-integration1 librsvg2-common libscrollkeeper0 libsexy2 libvte-common
  libvte9 python-debian python-gconf python-glade2 python-gst0.10 python-gtkhtml2 python-launchpad-integration
  python-pyorbit python-sexy python-vte python-xapian scrollkeeper software-properties-gtk synaptic ubufox

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers