After install of 8.10 alpha 4 Firefox opens with tool bar under top panel.

Bug #257947 reported by Bob on 2008-08-14
100
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Compiz
Fix Released
Unknown
compiz (Ubuntu)
Low
Michael Vogt
Intrepid
Low
Michael Vogt
firefox-3.0 (Ubuntu)
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

I just installed Ubuntu 8.10 alpha 4. When I open Firefox it opens with the top panel covering the title bar and menu. I can Auto Hide the top panel and get to the menu but not the title bar. Don't know if it's relevant but my specs are:

Toshiba Satellite A205-5000
Processor Celeron M 540 1.86ghz
2 gig RAM
Intel GMA3000 video
Screen Resolution 1280x800

Thanks,

Bob

Related branches

Bob (bobbblll) wrote :

Update:

After closing out of Firefox then coming back in, the menu bar appeared as it should below the top panel. Haven't duplicated issue since.

Bob

Michael Rooney (mrooney) wrote :

Thanks for your bug report Bob! I would be tempted to mark this as Invalid due to your comments that you can't reproduce it, but if it is a bug which causes it to act that way the first time only, then inherently it isn't reproducible except by reinstalling Alpha 4 again. Perhaps it is best to see if some duplicate reports start flowing in; I don't see anything that appears to be the same issue at the moment.

Dave Morley (davmor2) wrote :

This still happens in 20080929 daily image

Changed in firefox-3.0:
status: New → Confirmed
Dave Morley (davmor2) wrote :

Resolution is 1440X900 on an intel based machine.

When compiz is turned off the window appears correctly and as expected.

Michael Vogt (mvo) wrote :

I can reproduce this with compiz in a guest session with the 1440x900 resolution. It looks like the default window size of FF is > 900 and compiz does not tell it that it needs to be smaller (metacity seems to be getting this right).

Michael Vogt (mvo) wrote :

Hm, looks like its a problem with every resolution. I get it with 1600x1200 as well.

Changed in compiz:
status: Unknown → Confirmed
Michael Vogt (mvo) wrote :

metacity output log:
$ rm -rf .mozilla/ ;NSPR_LOG_MODULES=widget:5,widgetDraw:5 firefox

Michael Vogt (mvo) on 2008-09-29
Changed in compiz:
assignee: nobody → mvo
importance: Undecided → Low
milestone: none → ubuntu-8.10-beta
status: New → Triaged
Michael Vogt (mvo) wrote :

Upstream fixed that as:
3dd149ce5c465cf9b068aeb0bfdeb207907a836c and
633385e5e54147e750c6ca5a179f803373ab3e3e.

just needs backporting.

Changed in compiz:
status: Confirmed → Fix Released
der_vegi (m-may) wrote :

This also happens sometimes when opening a new pop-up window, see description of duplicate Bug #273333 .

It seems a long standing bug, see also bug 153739

Shall this one be marked as a duplicate of the earlier reported bug?

BTW, although 8.10-beta is set as a milestone, the bug is not fixed yet.

Intrepid beta: I observed reported behavior in live session and after install.

Chorca (chorca) wrote :

This is confirmed in the latest Intrepid Beta. It's been with Intrepid for at least two reinstalls for me, turning Desktop Effects to "none" and back to "normal" causes the titlebar to pop back up.

I've included a screenshot of the problem.

Chorca (chorca) wrote :

Reupload of previous attachment with extension this time.

Martin Pitt (pitti) on 2008-10-09
Changed in compiz:
milestone: ubuntu-8.10-beta → ubuntu-8.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.7.8-0ubuntu2

---------------
compiz (1:0.7.8-0ubuntu2) intrepid; urgency=low

  * debian/patches/048_from_git_fix_placement.patch:
    - ensure window fit into the work area when placing
      them (LP: #257947)

 -- Michael Vogt <email address hidden> Fri, 10 Oct 2008 22:46:03 +0200

Changed in compiz:
status: Triaged → Fix Released
Alexander Sack (asac) wrote :

fixed by compiz

Changed in firefox-3.0:
status: Confirmed → Invalid
Luke (lbearl) wrote :

As of the beta, on the LiveCD firefox still opens with the menubar and title bar under the top panel.

Saivann Carignan (oxmosys) wrote :

Indeed, this bug was not fixed in intrepid beta LiveCD. Would be bad if it happens with final release.

Gibby (gibsonsimswilson) wrote :

Hi - anyone fix this I have the same ... :-(

Saivann Carignan (oxmosys) wrote :

Can someone confirm if this bug is in the Release Candidate? Gibby?

Gibby (gibsonsimswilson) wrote :

I downloaded the beta and then the problems started I am hoping for a fix in the updates - will this happen ?

I am not really sure how the fixes work - Will I have to re-install everything or will I get the fix in an update ?

Thanks

Gibby

Derek Morton (derek-morton) wrote :

This issue looks to be fixed in the Release Candidate. Testing it on a machine at 1280x800 that has been updated from Alpha 5 to current by deleting the .mozilla folder in my home directory worked properly. I also tested the LiveCD in a virtual machine at 1152x768 also worked correctly.

Saivann Carignan (oxmosys) wrote :

Gibby : If you installed the Beta, you'll simply have to move the window once to avoid this problem. According to Derek Morton, this problem does not exist anymore in the Release Candidate, so that means that it has been properly fixed.

Gibby (gibsonsimswilson) wrote :

Yes I installed the beta - move the window once ? - I am sorry what do you mean ?

If this is fixed in the release candidate shouldn't I get a fix in the updates ?

Thanks

Saivann Carignan (oxmosys) wrote :

Gibby : The updates will fix compiz behavior in that case. However, if you closed Firefox while it was under gnome-panel, it might remember his last position and open at the exact same position, regardless of updates. So if you don't install using the stable Release Candidate, all you need to do is to move your firefox window to a normal position and close it and the problem won't happen again. If you need more support about this issue, please email me directly or to use ubuntuforums or answers.launchpad.net instead of launchpad bug tracker which should only be used to work on bug fixing. Thanks for your feedback!

Gibby (gibsonsimswilson) wrote :

OK - First thanks for your help and support..

BUT - I must be really dumb because I can't follow you...

Firefox opens "full screen" so I lose the top panel (I don't use the bottom panel) so now I can't use any options..

Now I have to rotate my widows and then return to my original window to see the top panel.

How do I move the Firefox window once it has opened full screen ?

Thanks

Gibby

Saivann Carignan (oxmosys) wrote :

Gibby : What you are talking about is bug 99740, which is not fixed. You can read workarounds and solutions for this problem in the bug description. As I said, please avoid asking support in launchpad bug tracker, it's not designed for this purpose. Instead, prefer help forums, answers.launchpad.net or even email me and I'll be happy to assist you more outside of this bug report. Thanks!

I have this same problem. I'm a beginner so please give me laymans terms!!
I have a macbook pro 1.1 and I'm using Ubuntu 8.10 which I downloaded following the instructions on the website. At first everything was fine but I installed google earth and used the command line:

sudo wget http://librarian.launchpad.net/7037027/libGL.so.1 -1 libGL.so.1

which was in this file: /usr/share/doc/googleearth/README.Debian (which I cant access now as ive removed google earth)

which was posted in ubuntu forums at this address: http://ubuntuforums.org/showthread.php?p=6400757#post6400757

Now I have to turn effects off in System>preferences>appearance in order to get firefox to behave properly.
I'd really like to know how to fix this if possible. Thanks, Kieran.

I was able to solve the problem by launching firefox in safe mode via the
command line:

firefox -safe-mode

After I did this, firefox ran fine. I believe it was some extensions
causing my problem.

- Cody

On Sun, Dec 21, 2008 at 7:44 AM, Reginald Von Boomsfeld <
<email address hidden>> wrote:

> I have this same problem. I'm a beginner so please give me laymans terms!!
> I have a macbook pro 1.1 and I'm using Ubuntu 8.10 which I downloaded
> following the instructions on the website. At first everything was fine but
> I installed google earth and used the command line:
>
> sudo wget http://librarian.launchpad.net/7037027/libGL.so.1 -1
> libGL.so.1
>
> which was in this file: /usr/share/doc/googleearth/README.Debian
> (which I cant access now as ive removed google earth)
>
> which was posted in ubuntu forums at this address:
> http://ubuntuforums.org/showthread.php?p=6400757#post6400757
>
> Now I have to turn effects off in System>preferences>appearance in order to
> get firefox to behave properly.
> I'd really like to know how to fix this if possible. Thanks, Kieran.
>
> --
> After install of 8.10 alpha 4 Firefox opens with tool bar under top panel.
> https://bugs.launchpad.net/bugs/257947
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Compiz: Fix Released
> Status in "compiz" source package in Ubuntu: Fix Released
> Status in "firefox-3.0" source package in Ubuntu: Invalid
> Status in compiz in Ubuntu Intrepid: Fix Released
> Status in firefox-3.0 in Ubuntu Intrepid: Invalid
>
> Bug description:
> Binary package hint: firefox-3.0
>
> I just installed Ubuntu 8.10 alpha 4. When I open Firefox it opens with the
> top panel covering the title bar and menu. I can Auto Hide the top panel and
> get to the menu but not the title bar. Don't know if it's relevant but my
> specs are:
>
> Toshiba Satellite A205-5000
> Processor Celeron M 540 1.86ghz
> 2 gig RAM
> Intel GMA3000 video
> Screen Resolution 1280x800
>
> Thanks,
>
> Bob
>

NICE
Thats sorted it, cdylws thanks

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.