firefox steals focus when opening an application

Bug #251177 reported by Damien Cassou on 2008-07-23
4
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: firefox

When I click on a pdf link in firefox, a dialog offers me to open the file or to save it. If I select "open with" and "document viewer (default)", evince opens and maximizes, but the focus is still on firefox. If I type ALT+F4 to close the window, I close Firefox ! (it should be noted that ALT+F4 in Firefox does not display the confirmation dialog).

$ lsb_release -rd
Description: Ubuntu 8.04.1
Release: 8.04

$ apt-cache policy firefox
firefox:
  Installed: 3.0+nobinonly-0ubuntu0.8.04.1
  Candidate: 3.0+nobinonly-0ubuntu0.8.04.1
  Version table:
 *** 3.0+nobinonly-0ubuntu0.8.04.1 0
        500 http://fr.archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     3.0~b5+nobinonly-0ubuntu3 0
        500 http://fr.archive.ubuntu.com hardy/main Packages

Thank you for your bugreport. Since this seems to be an issue with
version 3 of the firefox browser, I'm reassigning the package.

 affects ubuntu/firefox
 status invalid

 affects ubuntu/firefox-3.0
 status new

Changed in firefox:
status: New → Invalid
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Changed in firefox-3.0:
importance: Undecided → Low
status: New → Incomplete
Damien Cassou (cassou) wrote :

Yes it is unfortunately.

Andreas Moog (ampelbein) on 2009-03-19
Changed in firefox-3.0 (Ubuntu):
status: Incomplete → Confirmed
John Vivirito (gnomefreak) wrote :

I am still unable to reproduce this in firefox-3.0 or 3.1 i have not tested with 3.2 but at this time it wouldnt matter the code base is pretty much the same as 3.1
Does this occur in firefox-3.0.7?
Please give us a list of all your extensions and plug-ins also any themes you are using?

Damien Cassou (cassou) wrote :

I'm now on Intrepid and haven't seen the bug happen for a long time. I think you can close it, I will reopen if necessary.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers