Ubuntu

Spaces in Firefox (et al.) are too wide

Reported by wasimo on 2008-07-10
This bug report is a duplicate of:  Bug #193108: Word spacing issue in Firefox 3. Edit Remove
6
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

Pages, menus and dropdown menus don't show up correctly : spaces resemble tab characters with the width of about 3 spaces. Changing the character encoding doesn't help nor does the use of the KDE3 window manager instead of Gnome. Disabling the add-ons has no effect either. Websites are therefore hard to read and I don't know
what caused the problem. Furthermore, Firefox crashes more often than before : I had several crashes today, this had never happened with Firefox2. I'm using Ubuntu Hardy Heron with a Gnome and KDE3 Desktop.

ProblemType: Bug
Architecture: i386
Date: Wed Jul 9 22:22:06 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ath_hal
Package: firefox-3.0 3.0+nobinonly-0ubuntu0.8.04.1
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-16-generic i686

wasimo (martinjws01) wrote :
JM Williams (jmdwilliams) wrote :

What do you mean by “blancs”?

I think that you need to be more clear and specific about the problems that
you are encountering. A screenshot may be helpful.

You may find it useful to read this article:

    How to Report Bugs Effectively
    http://chiark.greenend.org.uk/~sgtatham/bugs

Thank you for taking the time to report this bug and helping to make Ubuntu
better. I am marking this bug as Incomplete until you have been able to
provide more information.

Changed in firefox-3.0:
status: New → Incomplete
wasimo (martinjws01) wrote :

I mean 'blanks' of course, I'm sorry for that. The spacing between words has changed : it's still only one character, but it has the width of 3 characters, as is the case with tabs. This is obvious in the first screenshot I've included. Screenshot 2 shows the page layout used and screenshots 3 shows the result of another character encoding. As you can see, a different character encoding doesn't change the spacing between words, and I've tried several ones. The remaining screenshots show the add-ons, themes and plugins which are installed in Firefox. The add-ons Xulrunner and Mozilla Firefox en-GB were also installed but these were incompatible with Firefox3 so I removed them from Firefox. It didn't change anything about the layout of pages and menus. Maybe these add-ons were the cause of my problems, I don't know. I didn't install Firefox3 myself, it all went automatically from Firefox2 through Firefox3RC2 to Firefox3 thanks to the Gnome Application Installer. I, therefore, don't know whether it was me who installed the incompatible packages or whether they were installed automatically before the update to Firefox3RC2 and the update to Firefox3 arrived. I also don't know when the incompatible packages were installed. As I can recall, there were no layout problems with Firefox3RC2, but I'm not sure of that. Concerning the crashes I've experienced with Firefox3, they seemed to happen when I had several applications open. My PC has 2 GByte RAM, though, with a swap space of another 2 GByte, so memory shortage will not be the reason for these crashes.

JM Williams (jmdwilliams) wrote :

(By “tabs” I thought you meant Firefox tabs rather than tab characters!)

Do you get the same problem if you run Firefox in Safe Mode?

    Safe Mode
    http://support.mozilla.com/kb/Safe+Mode

Quit Firefox entirely (Ctrl+Q) and run (Alt+F2):

    firefox -safe-mode

Changed in firefox-3.0:
status: Incomplete → New
wasimo (martinjws01) wrote :

Yes, I also get this problem in safe mode. I furthermore get the problem with other Gecko related applications like the latest release of Songbird and the various Prism Google applications.

wasimo (martinjws01) on 2008-07-12
description: updated
wasimo (martinjws01) on 2008-07-12
description: updated

Trying to localize the cause of my problems.

Today, I did a complete removal of everything related to Firefox, Mozilla and Xulrunner (Only xulrunner-1.9 couldn't be removed because ubuntu-desktop relies on it, as was pointed out in Synaptic). Thereafter, I, manually removed the Firefox, Mozilla and Xulrunner folders that were still there after the "complete remove" except, of course, the xulrunner-1.9 folders. I did a fresh install of Firefox3, of gnome support for Firefox3 and xulrunner, and of Ubufox. When I then started Firefox, I got a screen where settings could be imported. There, it was already obvious that the fresh install didn't change anything about my mixed-up layout. I checked /etc, /usr/lib and /usr/bin for virusses with avast! Antivirus, with the latest virus database (downloaded today) and in Standard mode. I also did a scan in Thorough mode of the firefox, mozilla and xulrunner folders in /usr/lib, of the /usr/share/mozilla folder and of the /root folder. Besides a corrupted Krita-KDE4 file, everything was OK. I , furthermore, did a reinstall of libxulrunner-1.9. This didn't change anything about the layout. I then removed the various xulrunner folders from /usr/lib and started Firefox. As expected, Firefox couldn' be started. I placed the xulrunner-1.9 folder back in /usr/lib and started Firefox. Now Firefox started as usual with the mixed-up layout. So the fault doesn't lie within the folders xulrunner-addons and xulrunner-devel-1.9 in /usr/lib. To conclude : Since xulrunner-1.9 is the only package related to Firefox that wasn't "completely removed", the fault will most likely lie somewhere within /usr/lib/xulrunner-1.9, /etc/gre.d or /etc/xulrunner-1.9. Because no other person has reported the same problem yet, I just can't see what went wrong with my installation of Firefox3 and other packages.

JM Williams (jmdwilliams) wrote :

“Spaces” is probably a better word than “blanks.”

Someone else has this problem (unless you are GStubbs43 at ubuntuforums.org):

    large spaces in firefox
    http://ubuntuforums.org/showthread.php?t=839221

description: updated
wasimo (martinjws01) wrote :

No that isn't me. And yes, I agree that "spaces" in the description would make it easier for other people with the same problem to find my post. I've responded to the post in Ubuntu Forums, you can read my reaction over there.

wasimo (martinjws01) wrote :

This might be important. When I start Firefox or other xulrunner-1.9 related applications from within a terminal, I get warnings : Exception in gr::RangeSegment. These warnings covers in most cases the whole of the terminal. Only with Google-Analytics and Songbird, I get a slightly different warning but here also an "Exception in gr::RangeSegment". The number before this warning changes with every call of the corresponding program. I've included these reports in the attachment. When I start Seamonkey 1.1.9, which is not the latest release, from within a terminal, I don't get any warning.

JM Williams (jmdwilliams) wrote :

That error you quoted tracks the problem down!

There is another thread in the forums about it:

    Firefox 3 text spacing issue
    http://ubuntuforums.org/showthread.php?t=699815

and there is already a bug about it here in Launchpad:

    Word spacing issue in Firefox 3
    Bug 193108

It seems that the problem is actually in pango-graphite. I shall mark this
bug as a duplicate of bug 193108. If removing pango-graphite does not solve
your problem, we can detach this bug from that one.

H5N1 (h5n1-vir) wrote :

For what I can see that removing pango-grapfite solve the problem.
I'm wondering if at this point we can say that it's not a Firefox 3.0 bug but a pango-graphite bug.

wasimo (martinjws01) wrote :

Purging pango-graphite solved the problem. Thank you very much. I'm sorry that I didn't notice the other bug report, I guess I was looking with the wrong search words.

JM Williams (jmdwilliams) wrote :

> I'm sorry that I didn't notice the other bug report

You needn’t apologise: I didn’t notice it either! Nor did I find the Mozilla
Bugzilla bug, even though I looked. :^/ It was only because you quoted that
warning that I was able to find something determinative.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers