selected radiobuttons are grayed out, so you can not see what you just selected (on/off)

Bug #240860 reported by Martijn de Nerd on 2008-06-18
4
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Medium
firefox-3.0 (Ubuntu)
Low
Unassigned

Bug Description

Summary: Selected radio buttons have a gray square over it, so you cannot see whether it's actually selected.

Steps to reproduce:
  Select a radio button on a web-page that has one.

Expected Result:
  The radio button should show that it is selected.

Actual Result:
  The radio button shows as a gray square as long as it has focus. Screenshot example in Ref. 1

Reference:
  1 http://launchpadlibrarian.net/15995921/bugbox.png / screenshot how a selected button looks like (bottom one).

Michael, does it look familiar to you? Something you could have a look on?

That's a regression from Firefox 2. We need a regression range when it starts happening.

It could be because we're drawing the focus after we draw the checkbox. I had a patch before that would change this behaviour, but Benjamin Berg told me it was not necessary and to take it out.

Regression was introduced between 2007/06/2007-06-25-04-trunk and 2007/06/2007-06-26-04-trunk.

Created an attachment (id=321373)
XHTML page with radio buttons and checkboxes

Use this XHTML to test.

Should be happen due to the check-in of the patch on bug 385686.

I'm still not able to see this issue with the default theme of Ubuntu 8.04. I used the Ubuntu version of Firefox. Kay does it even happen there?

I experienced this issue on Kubuntu 7.10 and 8.04. Not sure if Ubuntu is
unaffected. I'm not able to test Ubuntu in the next days. Maybe someone else can test on Ubuntu and Kubuntu to confirm.

Michael, this bug is QT only. I run a test with Kubuntu and the RC1 release candidate and I can confirm this issue.

This is a really annoying issue because users cannot see the checked states for check boxes and radio buttons.

Putting on the radar for the 1.9 release. Any chance to get this fixed in the final version?

Does this affect all GTK apps or just Gecko? Could it be a gtk-qt engine bug?

When I change the GTK style to e.g. Raleigh and don't use the QT one, the focused checkbox is displayed correctly.

But having the fact that it is a regression and as Kay said, it is working with 2007/06/2007 shouldn't this be an issue on our side?

Not necessarily. Can you answer comment #9?

Not a blocker. May or may not be our issue, but not severe enough to block, especially if its been broken for a year without anyone noticing until now. Can fix once we have a patch.

Kay, what other GTK applications are delivered with Kubuntu? I really don't know this distribution. Does it have Gimp? I think this should be a GTK application. Does it also have this issue?

I installed Seamonkey ( http://packages.ubuntu.com/hardy/seamonkey-browser | Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.13) Gecko/20080313 SeaMonkey/1.1.9 ) which also uses GTK 2 and it did *not* have this bug. I really think this is caused by Core.

Created an attachment (id=322089)
Focus ring of a checkbox in Gimp

I also did a further test with Gimp. Running this application I noticed that the focus is not drawn around the checkbox but the description. So this is just a different behavior on our side.

Btw. this only affects webpages. XUL seems to correctly handle this part, e.g. within the preferences dialog. There it looks like the above screenshot.

I can confirm this bug on Kubuntu hard using the latest version of FF3.0 installed from kubuntu package on 12/6/2008

This disturbs the user experience. Could we fix this with the next release?

Binary package hint: firefox-3.0

Selected radiobuttons have a gray square over it, so you cannot see whether it's actually selected... and it's very ugly of course.

Running kubuntu 8.4 (upgraded since 6.10).

I'm seeing this on a Linux/Kubuntu machine. I've seen it both using the Default theme as well as PitchDark 3.0.2.

As a temporary work around, I've found clicking somewhere else on the page (i.e., removing focus) will show the radio button or checkbox appropriately.

Linux kubuntu 2.6.24-19-generic #1 SMP Wed Jun 18 14:43:41 UTC 2008 i686 GNU/Linux
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9) Gecko/2008061015 Firefox/3.0

Confirmed here, on Kubuntu 8.04.1, upgraded from 6.06 LTS.

As a workaround, you have to click away from the checkbox to see if it is checked or not, OR set focus to another window.

As long as the checkbox is the last thing clicked in Firefox, AND focus is on the Firefox window, the checkbox is grey. Attaching a screenshot.

Changed in firefox-3.0:
status: New → Confirmed
kko (kko) wrote :

Not wanted for 1.9.0.x, but it'd be good to get fixed in 1.9.1.

Let me tell you... not being able to see if a checkbox or radio button is checked
is a horrible user experience. I use FF 3.0.1 on Kubuntu (KDE). Things worked fine on FF 2.1.16 and earlier, but quit working atfer I installed 3.0.1.

Instead of worrying about how and where the problem originates, whether it's a bug fix or a work-around for a bug elsewhere, could we please just get a fix for it so we can actually use checkboxes and radio buttons again?

(In reply to comment #9)
> Does this affect all GTK apps or just Gecko? Could it be a gtk-qt engine bug?

Roc, does my comment 15 answers your questino?

Henrik: I guess so.

Michael, Ian, Teune, any of you guys up to take a look at this?

I believe comment 3 hit the nail on the head. The focus just needs to be painted first. For some reason the focus was designed to have a background color, and since we are painting the focus over the checkbox, we are hiding it. I just worry that a fix like this is just going to flip the issue, and we'll have widgets that are painting with backgrounds and completely covering the focus indicator.

I'd like to second comment #20. I'm also finding this extremely annoying.

Just put in a vote for making this a priority. Since the focus was covering the vote box, I couldn't see whether or not it was checked, but it looks like my vote went in. Ah, the irony.

description: updated
Changed in firefox:
status: Unknown → Confirmed
C de-Avillez (hggdh2) on 2008-10-10
Changed in firefox-3.0:
importance: Undecided → Low
status: Confirmed → Triaged
Paul Gevers (paul-climbing) wrote :

I found that my Firefox does not behave anymore in the way described by this bug. Could you confirm that this is fixed for you as well?

I don't remember if I did an upgrade, but currently I am running: firefox_3.0.3+build1+nobinonly-0ubuntu1

kko (kko) wrote :

Looks fixed in Hardy / Firefox 3.0.3.

Paul Gevers (paul-climbing) wrote :

This bug report is being closed due to the last comments regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status . Thank you again for taking the time to report this bug and helping to make Ubuntu better. Feel free to submit any future bugs you may find.

Changed in firefox-3.0:
status: Triaged → Invalid
kko (kko) wrote :

Thanks, changing status appropriately.

Changed in firefox-3.0:
status: Invalid → Fix Released

Both Firefox bug 432050 and Firefox bug 424367 seem to be related/duplicates.

Changed in firefox:
importance: Unknown → Medium

patches in bug 521582 seem to fix this

I cannot see this described issue anymore with Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20130720 Firefox/24.0 ID:20130720004002 CSet: 73c4cb1518bb on Ubuntu 13.04.

If you are still facing it please reopen the bug.

Changed in firefox:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.