"This print job requires a PostScript Language Level 2 printer" error message

Bug #240285 reported by Mike Cebula on 2008-06-16
8
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0, Anything using CUPS seems to fail.

Printer is a Level 1 PostScript printer (IBM 4216-031) and works fine with other apps. The summary contains the error message that prints any time I attempt to use it from Firefox 3.0. Running Ubuntu 8.04 (just installed).

Mike

ProblemType: Bug
Architecture: i386
Date: Sun Jun 15 14:24:19 2008
DistroRelease: Ubuntu 8.04
Package: firefox-3.0 3.0~rc1+nobinonly-0ubuntu0.8.04.1
PackageArchitecture: i386
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-18-generic i686

Mike Cebula (cebula-altazip) wrote :
Mike Cebula (cebula-altazip) wrote :

Update:
The only application that does work to this printer is OpenOffice. I chose to print its output to a .ps file and saw that it correctly identified the language as level 1 and created the postscript file itself. First few lines of the file follow:

%!PS-Adobe-3.0
%%BoundingBox: (atend)
%%Creator: (OpenOffice.org 2.4)
%%For: (mike)
%%CreationDate: (Wed Jun 25 22:29:14 2008)
%%Title: (Page243)
%%LanguageLevel: 1
%%DocumentData: Clean7Bit
%%Pages: (atend)
%%PageOrder: Ascend
%%EndComments
%%BeginProlog
%%BeginResource: procset PSPrint-Prolog 1.0 0
/ISO1252Encoding [

I then printed to file from Firefox and discovered that Cairo did the formatting and incorrectly identified the language as level 2. First few lines of the file follow below:

%!PS-Adobe-3.0
%%Creator: cairo 1.6.0 (http://cairographics.org)
%%CreationDate: Wed Jun 25 22:36:27 2008
%%Pages: 1
%%BoundingBox: 0 0 612 792
%%DocumentData: Clean7Bit
%%LanguageLevel: 2
%%EndComments
%%BeginProlog
/languagelevel where
{ pop languagelevel } { 1 } ifelse
2 lt { /Helvetica findfont 12 scalefont setfont 50 500 moveto
  (This print job requires a PostScript Language Level 2 printer.) show
  showpage quit } if
/q { gsave } bind def
/Q { grestore } bind def

I got the same failures with printing pdf files or files from a text editor. In each case Cairo was identified as the creator of the failing postscript formated file.

One further point:

I can print to this printer over my home lan using Windows XP from a laptop. Everything works fine from it no matter what source remotely selects the printer.

Hope this helps with identifying a solution.

Mike Cebula

Mike Cebula (cebula) on 2008-07-02
description: updated

 Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering if this is still an issue for you. Can you try with the latest Ubuntu release? Thanks in advance.

Changed in firefox-3.0:
status: New → Incomplete
Mike Cebula (cebula) wrote :

No longer a problem. After trying multiple versions of Linux, switched back to Windows XP.

Mike

Thank you, Mike. So I am closing this bug.

Changed in firefox-3.0:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers