ubufox is not suggested or recommended by firefox-3.0

Bug #218865 reported by Brian Murray on 2008-04-17
6
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Low
Alexander Sack
Hardy
Low
Alexander Sack
Intrepid
Low
Alexander Sack

Bug Description

Binary package hint: firefox-3.0

1) Hardy Heron
2) 3.0~b5+nobinonly-0ubuntu2

ubufox is included in the tasks for ubuntu-desktop, edubuntu-desktop and xubuntu-desktop but not for kubuntu-desktop (since Firefox isn't installed by default). Additionally, Firefox 3.0 does not suggest or recommend ubufox which can result in bug 199460 - Firefox trying to use Adobe's installer for Flash which is broken. This could result in more bug reports which would be nice to avoid.

Looking at firefox-2, it recommends ubufox.

Changed in firefox-3.0:
milestone: none → ubuntu-8.04
Daniel Hahler (blueyed) on 2008-04-17
Changed in firefox-3.0:
importance: Undecided → Medium
status: New → Triaged
Steve Langasek (vorlon) on 2008-05-01
Changed in firefox-3.0:
milestone: ubuntu-8.04 → ubuntu-8.04.1
Alexander Sack (asac) on 2008-05-09
Changed in firefox-3.0:
assignee: nobody → asac
importance: Undecided → Low
status: New → In Progress
importance: Medium → Low
milestone: none → ubuntu-8.04.1
milestone: ubuntu-8.04.1 → ubuntu-8.10-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox-3.0 - 3.0~rc1+nobinonly-0ubuntu1

---------------
firefox-3.0 (3.0~rc1+nobinonly-0ubuntu1) intrepid; urgency=low

  * new upstream release 3.0 RC1 (LP: #233922)

  [ Fabien Tassin <email address hidden> ]
  * Bump xulrunner-1.9 dependencies to ~rc
    - update debian/control
  * Bump EM_TRANSLATION_VERSION and EM_TRANSLATION_{MIN,MAX}_VERSION to 3.0
    and clean-up the code to avoid unnecessary complexity
    - update debian/rules
  * Refresh diverged patches
    - update debian/patches/bzXXX_reload_new_plugins.patch
  * Fix 'Categories' field in desktop file by changing GTK into Application
    to make KDE happy (LP: #220325)
    - update debian/firefox-3.0-final.desktop
  * Build with default gcc (hardy: 4.2, intrepid: 4.3)
    - update debian/rules
    - update debian/control
  * Prevent EULA dialog to popup on first run by setting the browser.EULA.override
    key to true
    - update debian/firefox.js
  * Drop LDFLAGS workaround now that jemalloc is no longer a static lib
    - udate debian/rules
  * Workaround multiple crashes in Intrepid caused by Intrepid shipping gcc 4.3
    with -D_FORTIFY_SOURCE=2 by default
    - udate debian/rules

  [ Alexander Sack <email address hidden> ]
  * Fix LP: #218865 - "ubufox is not suggested or recommended by firefox-3.0";
    we add ubufox to recommends of firefox-3.0 package.
    - update debian/control
  * Fix apport hook to properly detect global gre extensions
    - update debian/apport/firefox-3.0.py
  * disable app.update feature in code so the auto app update feature will
    never be enabled (independent from the pref setting)
    - add debian/patches/ubuntu_no_app_updates.patch
    - update debian/patches/series
  * install firefox.cfg as an example using dh_installdocs rather than
    dh_install as it wasn't used at all
    - update debian/rules

 -- Fabien Tassin <email address hidden> Wed, 21 May 2008 16:25:00 +0200

Changed in firefox-3.0:
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in firefox-3.0:
milestone: ubuntu-8.04.1 → none
status: In Progress → Fix Committed
Steve Langasek (vorlon) on 2008-05-30
Changed in firefox-3.0:
milestone: none → ubuntu-8.04.1
Martin Pitt (pitti) wrote :

Current hardy-proposed package recommends ubufox.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in firefox-3.0:
status: Fix Committed → Fix Released
Alexander Sack (asac) on 2008-09-17
Changed in firefox-3.0:
assignee: nobody → asac
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers