Firefox is VERY slow rendering low opacity values from CSS files

Bug #207454 reported by Ricardo Pérez López on 2008-03-26
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Medium
firefox (Ubuntu)
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox

Steps to reproduce:

1. Open Firefox 3 Beta 4
2. Go to http://www.pragprog.com

Firefox becomes VERY slow and almost unusable.

Neither Opera nor Konqueror has this issue.

I have a very similar problem using Mozilla Firefox 1.0.4 (Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4). Although I
can't check the page the original poster referenced, so I can't judge how
similar it is.

When using tables and giving different cells different opacities (based on
:hover in my case, but I'm not sure that's a requisite) drawing becomes very
slow (and somehow different when using borders) when some cells have an opacity
< 1 and some (one?) cell(s) have opacity 1. When all cells have opacity < 1 or
opacity 1 nothing seems to be wrong.

I have attached a test document (opacitytest.html) to illustrate the problem.
Opacitytest2.html is the same document but with all non-hover cells using the
"default" style (so probably opacity 1), please note the difference (compared to
opacitytest.html) in speed as well as the difference in handling the size of
cells with borders.

Created an attachment (id=189041)
Test file with lots of cells with opacity < 1

Created an attachment (id=189042)
Test file with nearly all cells having opacity 1

This demonstrates the difference in speed and handling of sizes of cells with a
border (when compared to opacitytest.html).

Yep I've seen this problem too.

Specifically when accessing the forums on www.asp.net

e.g. one of my posts on there http://forums.asp.net/thread/1431418.aspx

If you try to access the above in Firefox it slows to a grinding halt, becomes very unresponsive and I have to force Firefox to quit.

In , maio (maio) wrote :

same problem with lightbox/thickbox like scripts

http://www.huddletogether.com/projects/lightbox/
http://jquery.com/demo/thickbox/#

this makes them unusable on FF. (could be Linux only problem, I doesn't remember to have this issue on WinXP box)

This continues to be a problem in Firefox 2 on Linux today. I'm using FF 2.0.0.4 on Ubuntu Feisty.

Binary package hint: firefox

Steps to reproduce:

1. Open Firefox 3 Beta 4
2. Go to http://www.pragprog.com

Firefox becomes VERY slow and almost unusable.

Neither Opera nor Konqueror has this issue.

Brian Curtis (bcurtiswx) wrote :

I can not reproduce this issue. Some more information about the problem, including computer specifications may help us help you with your problem. Marking as incomplete for the time being.

Changed in firefox:
status: New → Incomplete
Ricardo Pérez López (ricardo) wrote :

Hi, Brian, thanks for the reply. Try to navigate a bit inside the pragprog.com website, clicking and moving the mouse cursor here and there... It seems that Firefox was suffering trying to execute all the javascript code inside.

My computer:

- ASUS Vintage V2-PE2 barebone & motherboard
- Intel Core 2 Duo 6400 @ 2.13 GHz
- 1 GB RAM DDR2
- 300 GB SATA HDD @ 7500 rpm
- nVIDIA GeForce 7300 LE graphics card

Brian Curtis (bcurtiswx) wrote :

Ok, I can see your problem as of now. Its up to the devs now to see how important this is to them.

Changed in firefox:
status: Incomplete → Confirmed
Alexandre Anoutchine (xirius) wrote :

Hi, i experience the same problem. Firefox becomes unusable, it freezes for 10 seconds after each action i do (scroling, etc ...)

My hardware :

Dell XPS
 - Intel Core 2 Duo T9300 (2,50 GHz)
 - 3 GB RAM DDR2
 - nVidia GeForce Go 8600M GT

I have also a desktop PC
 - AMD Athlon 64 3500
 - NVidia GeForce 6600 GT
 - 1 GB RAM DDR2

and firefox renders much better, it doesn't freeze. So i think that it might be a driver issue. (I'm not really sure since i'm new to Linux world)

Confirmed in Firefox 3 final release, too.

ViaToR (alvivi) wrote :

same problem.

Mikael B (mikaelbje) wrote :

I have the same problem on a Dell XPS M1530 with:

* Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz
* 2 GB ram

spinkham (steve-pinkham) wrote :

I have the same problem with Firefox 3.0.1, 64 bit on 64 bit Ubuntu 8.04.
Problem exists with all extensions disabled, and also with noscript enabled, so I don't believe it's a javascript problem.
I am running the restricted nvidia driver, I will later try and see if it improves by switching to the open source nv driver.
Note that the site renders quickly for me in FF 3.0.1 on a seperate vista machine with very similar specs.

Hardware:
AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
3 Gig ram
nVidia GeForce 8600 GT

Software:
Ubuntu 8.04 64 bit
Firefox 3.0.1+build1+nobinonly-0ubuntu0.8.04.3
linux-generic 2.6.24.19.21
linux-restricted-modules-generic 2.6.24.19.21

spinkham (steve-pinkham) wrote :

I must correct my above software list.
I forgot that due to other problems with the latest nvidia driver, I was really running:
Software:
Ubuntu 8.04 64 bit
Firefox 3.0.1+build1+nobinonly-0ubuntu0.8.04.3
linux-generic 2.6.24.18.41
linux-restricted-modules-generic 2.6.24.18.41
nvidia restricted driver

When I switched to the free nv driver under the latest kernel, the problem went away.
Software:
Ubuntu 8.04 64 bit
Firefox 3.0.1+build1+nobinonly-0ubuntu0.8.04.3
linux-generic 2.6.24.19.21
linux-restricted-modules-generic 2.6.24.19.21
nv free driver

spinkham (steve-pinkham) wrote :

I can confirm that under the same kernel, linux-generic 2.6.24.18.41, "restricted" nvidia driver has the 10 second or so screen freezing delay, and the free nv driver has no delay.

I am unable to get linux-generic 2.6.24.19.21 working with the restricted driver at the moment, so I can't report on the latest kernel under the restricted driver, but the nv driver on latest kernel works fine.

Dave Thomas (dave-pragprog) wrote :

If there's anything we can do to help diagnose this, or is anyone identifies the component of our HTML that's causing the problem, please let me know.

Dave Thomas

Dave Thomas (dave-pragprog) wrote :

(at dave at pragprog.com)

PeterKolloch (pkolloch) wrote :

I can confirm what spinkham wrote. I got the problem only with the restricted nvidia driver. No problems with the free one.

Ubuntu 8.04 64 bit

Dell M1530

01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600M GT (rev a1)
(prog-if 00 [VGA controller])
        Subsystem: Dell Unknown device 022e

2.6.24-19-generic

Same firefox version as spinkham.

Dan Farmer (dfarmernv) wrote :

I tested the site with Midori (webkit backend) using nvidia restricted driver and it runs perfectly... in Firefox 3.01 I experience the bogged down effect also.

CPU usage (as measured with gnome system monitor) spikes on the pragprog site using firefox, but stays relatively flat in MIdori.

Robb Kidd (ubuntu-thekidds) wrote :

I see the same, but top shows the spike in Xorg, not in Firefox.

Disabling the screen (and therefore the shared and high) stylesheet makes things snappy again.

Dell Precision 670 (dual Xeon 3.0)
Ubuntu 8.10
2.6.24-19-generic
Firefox 3.0.1
nVidia NV45GL also using the restricted "nvidia" driver

Robb Kidd (ubuntu-thekidds) wrote :

Correction: I'm running Ubuntu 8.04. (Got Ibex on my mind.)

Robb Kidd (ubuntu-thekidds) wrote :

According to my browser history, I visited PragProg.com on 7-9-08 and I recall *not* seeing this problem then. Dave Thomas said in an email yesterday that PragProg has made no code changes to the site since then. Looking in my problem host's APT log, I see that the following suspect packages (nvidia restricted and firefox) have changed since then:

7-2: nvidia-glx-new 169.12+2.6.24.13-19.42 -> nvidia-glx-new_169.12+2.6.24.13-19.44
7-14: nvidia-glx-new 169.12+2.6.24.13-19.44 -> 169.12+2.6.24.13-19.45
7-25: xulrunner 1.9+nobinonly-0ubuntu0.8.04.1 -> 1.9_1.9.0.1+build1+nobinonly-0ubuntu0.8.04.2
7-25: firefox 3.0+nobinonly-0ubuntu0.8.04.1 -> 3.0.1+build1+nobinonly-0ubuntu0.8.04.2
7-29: xulrunner 1.9.0.1+build1+nobinonly-0ubuntu0.8.04.2 -> 1.9.0.1+build1+nobinonly-0ubuntu0.8.04.3
7-29: firefox 3.0+nobinonly-0ubuntu0.8.04.2 -> 3.0.1+build1+nobinonly-0ubuntu0.8.04.3

Rolled back firefox and the problem still exists:
+ nvidia-glx-new 169.12+2.6.24.13-19.45
- firefox 3.0+nobinonly-0ubuntu0.8.04.1
- xulrunner 1.9+nobinonly-0ubuntu0.8.04.1

Brought firefox up-to-date and rolled back nvidia-glx-new, problem still exists:
- nvidia-glx-new 169.12+2.6.24.13-19.42
+ firefox 3.0.1+build1+nobinonly-0ubuntu0.8.04.3
+ xulrunner 1.9.0.1+build1+nobinonly-0ubuntu0.8.04.3

So, color me confused.

JinYoung (classpath) wrote :

I think the problem is in css file of http://www.pragprog.com/, especially, high.css file.

I downloaded main html file and css files from the site to my local machine (xubuntu 8.10, restricted nvidia driver, FF 3.0.1) and tested with some combination of them. Finally I think I found the root of trouble.

You can see below code in high.css file.

body {
  background-color: #858072;
  color: white;
  padding: 0;
  margin: 0;
  -moz-opacity: .99; /* Firefox bug fix */
}

The last line "-moz-opacity: .99; /* Firefox bug fix */" is today's main guest. It's a kind of trick for solving FF 2.x bugs.
However, in FF 3.x, it makes our headache. :-)

I hope The pragmatic bookshelf removes the line or changes value from .99 to 1 or Firefox team makes patch to around this kind of crash.

Or... you can use alternative way to solve this crash with stylish plugin. I'll explain how to do it in my blog (http://classpath.egloos.com/4622029). It's Korean blog, but I'll try write it in English.

Dave Thomas (dave-pragprog) wrote :

I've removed the -moz-opacity line from our CSS. Could anyone confirm the problem has now gone away?

Dave

Works like a charm! Good job, JinYoung! Thank you very much, JinYoung and Dave!

*** This is an automated response ***

Thank you for your bugreport. Since this seems to be an issue with
version 3 of the firefox browser, I'm reassigning the package. If you
feel this is an error, please don't hesitate to add a comment to your
report.

 affects ubuntu/firefox
 status invalid

 affects ubuntu/firefox-3.0
 status confirmed

Changed in firefox:
status: Confirmed → Invalid
JinYoung (classpath) wrote :

The pragmatic programmer site team has removed a line that raises this problem. And it works very well, now.

Changed in firefox-3.0:
status: Confirmed → Fix Released
status: Fix Released → Confirmed

This bug is still present in firefox 3.0.4 (Linux Ubuntu 8.04), as well as epiphany, but not seamonkey 1.1.12

I also noticed css rendering is pretty slow when I use a table (40 rows, 9 columns), but with opacity set at 0.82 in the css file, it's just unusable:
total CPU skyrockets to 50% (dualcore... that's 100% on a single core actually), whole system is seems unresponsive for about 5 seconds.

The html file with the table is about 13kb, loads instantly when no css is applied, notably slower with css, and incredibly slow using the opacity.

I have a similar problem with opacity.

I just set the opacity of my main DIV to 85% , then the page is very very slow to render.

I have interpid ibex with ;
 - Intel Core 2 Duo
 - 2 GB RAM DDR2
 - nVidia GeForce Go 8600M GT with non free drivers.

It does not happen with other configurations I test .

I am not sure the 2 others bugs are realy duplicated of this one because I do not have other problem of slow rendering. It is only with the opacity atribute in the css ...

In FF 3.1 beta 2, it's still slow on my P4 computer, though it's "ok" speed on my dual core computer in office.

HOWEVER, the main point is, when I feel it's slow on my P4, on the same machine, both IE and Google Chrome load the same page very quickly.

May want to fix this bug. I am seeing more sites utilizing opacity now than before. And should be increasing in the future, especially in personalized blogs, which we all like to go to.

Sorry to spam... I missed one point. It's slightly slow on "loading", but it's very slow when you're scrolling.

I have found a bug in mozilla with this same problem. I have linked it to this bug for those who want to stay involved to get this fixed.

Thanks everyone for participating in this bug report and making Ubuntu a better OS

Changed in firefox:
status: Unknown → New

This bug bit me last week. I have put up a page which reproduces the issue, i.e causes Firefox 3.6 to crash on Ubuntu 9.10 (64bit) on my laptop (2GHz Core2 Duo, 2GB RAM):
http://www.bitvolution.com/demo/firefox36opacitybugtest.html

The page works fine in Chrome and IE and Firefox 3.6 on Windows.

I have also blogged about the issue:
http://www.bitvolution.com/blog

It appears to be fixed for me on a 32 bit system, running Debian Lenny.
Tried your page in both Firefox 3.6 (downloaded Linux binary from firefox.com) and Swiftfox 3.6 (recompiled firefox for specific CPU's).
None of these crash, or even slow down when opening the test page provided by Tom.
It's a desktop system running a quadcore Q9550 running at 2.83 Ghz and 4GB ram.

Changed in firefox:
importance: Unknown → Medium

This is fast for me with Mozilla/5.0 (Windows NT 6.1; rv:13.0a1) Gecko/20120215 Firefox/13.0a1 SeaMonkey/2.10a1

Changed in firefox:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.