[hardy beta] firefox3b4 does not recognize apturls (apt://)

Bug #207281 reported by Christer Edwards on 2008-03-26
This bug report is a duplicate of:  Bug #203538: Don't work with Firefox3 beta5. Edit Remove
4
Affects Status Importance Assigned to Milestone
apturl (Ubuntu)
High
Unassigned
firefox-3.0 (Ubuntu)
Undecided
Unassigned
xulrunner-1.9 (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: firefox-3.0

Trying to install a package via apturl (via an apt://packagename) link and firefox3 asks what type of application this should be opened in.

This is on a fresh install of Ubuntu hardy + updates & reboot.

ProblemType: Bug
Architecture: i386
Date: Wed Mar 26 14:03:47 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ath_hal
Package: firefox 3.0~b4+nobinonly-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-12-generic i686

Fabien Tassin (fta) wrote :

Confirmed. This is half in apturl and half in xulrunner-1.9 so closing for firefox-3.0 as there's no change required there.
Assigning to me.

Changed in apturl:
assignee: nobody → fta
importance: Undecided → High
status: New → In Progress
Changed in firefox-3.0:
status: New → Invalid
Changed in xulrunner-1.9:
assignee: nobody → fta
importance: Undecided → High
status: New → Fix Committed
Fabien Tassin (fta) wrote :

Here is a debdiff for apturl.
I've also linked my branch if you want to merge from it.

Changed in apturl:
assignee: fta → nobody
Fabien Tassin (fta) wrote :

Un-assigning me. Both fixes are available.
This will be fixed once both apturl and xulrunner-1.9 beta 5 will be released to hardy.

Changed in xulrunner-1.9:
assignee: fta → nobody
Fabien Tassin (fta) on 2008-03-28
Changed in apturl:
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (3.2 KiB)

This bug was fixed in the package xulrunner-1.9 - 1.9~b5+nobinonly-0ubuntu1

---------------
xulrunner-1.9 (1.9~b5+nobinonly-0ubuntu1) hardy; urgency=low

  [ Fabien Tassin <email address hidden> ]
  * Drop patch applied upstream
    - drop debian/patches/bz333308_attXXXX_make_clean_cleaner.patch
    - update debian/patches/series
  * Set LDFLAGS so dpkg-buildpackage doesn't use -Wl,-Bsymbolic-functions
    - update debian/rules
  * Add support for a defaults/syspref directory containing system wide
    preferences that will not be silently overwritten at each upgrade
    (LP: #207281, #203538).
    It works for both libxul apps such as firefox 3 and xulrunner
    applications such as prism
    - add debian/patches/add_syspref_dir.patch
    - update debian/patches/series
  * Fix broken RSS subscription
    - add debian/patches/bz423060_att312807_fix_rss_subscription.patch
    - update debian/patches/series
  * Bump depends to libnspr4-dev >= 4.7.1~beta2 and libnss3-dev >= 3.12.0~beta3
    - update update debian/control
  * Hook up mozilla-devscript's compare module to binary-post-install
    - update debian/rules

  [ Alexander Sack <email address hidden> ]
  * switch to in-source jpeg to fix rendering issues at zoom levels
    (LP: #182038); this measure should give us some performance
    improvements.
    - update debian/rules
  * make pref extensions read defaults/autoconfig from NS_GRE_DIR instead
    of NS_APP_DEFAULTS_50_DIR. If it turns out to be a bad decision, we should
    reconsider this patch.
    - add debian/patches/bzXXX_autoconfig_in_gre.patch
    - update debian/patches/series
  * install system-greprefs in /etc/xulrunner-1.9/ and create the proper
    link in $pkglibdir/greprefs to it (LP: #139543)
    - add debian/system-greprefs.js
    - update debian/rules
  * ship versioned link libsqlite3.so.0 => libsqlite3.so in $pkglibdir to
    allow liferea workaround for LP: #203413 - "Liferea creates many corrupt
    copies of places.sqlite in" by setting LD_LIBRARY_PATH properly
    - update debian/rules
  * ship .autoreg file in pkglibdir to allow autoreg touches by
    plugins/extensions et al.
    - update debian/rules
  * touch .autoreg in xulrunner-1.9.postinst and
    xulrunner-1.9-gnome-support.postinst
    - update debian/xulrunner-1.9.postinst
    - add debian/xulrunner-1.9-gnome-support.postinst
  * hook in lp-export-xpi.mk from mozilla-devscript to export en-US
    translation templates to debian/lp-export-xpis/; in turn, make
    mozilla-devscripts a hard build-depends
    - update debian/rules
    - update debian/control
  * consider NS_GRE_DIR/.autoreg to trigger component registry upgrades.
    - add debian/patches/bzXXX_gre_autoreg.patch
    - update debian/control/series
  * Fix "Dom Inspector not compatible" by bumping maxVersion field in
    extension install.rdf
    - add debian/patches/inspector_maxversion_bump.patch
    - update debian/patches/series
  * Fix xulrunner side for bug "firefox needs restart after plugin install to
    detect and activate them"; we scan for new plugins in GRE at startup runtime
    - update debian/patches/bzXXX_gre_extension_plugin_support.patch

 -- Fabien Tassin <email address hidden> ...

Read more...

Changed in xulrunner-1.9:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apturl - 0.2.1ubuntu1

---------------
apturl (0.2.1ubuntu1) hardy; urgency=low

  [ Michael Vogt ]
  * apturl:
    - fix broken enable of components
  * debian/control:
    - add missing python-apt dependency

  [ Fabien Tassin ]
  * setup.py:
    - add support for firefox-3.0 (LP: #207281)

 -- Michael Vogt <email address hidden> Thu, 10 Apr 2008 16:36:48 +0200

Changed in apturl:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers