Ubuntu

gzip'ed text files don't display inline

Reported by Rolf Leggewie on 2008-03-07
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Firefox
New
Undecided
Unassigned
firefox-3.0 (Ubuntu)
Undecided
Unassigned
firefox-3.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: mozilla-firefox

Hi,

this used to work, but it does not anymore. Text files that have been compressed with gzip don't display inline anymore but launch an external application.

Examples:
file:///usr/share/doc/TODO.gz
http://rfc.net/rfc70.txt.gz

I also think that normal text files aren't opened in firefox anymore under a lot of circumstances when they previously were displayed fine.

http://oz.leggewie.org/wip/scim.patch

Maybe I just misconfigured something, but I tried a second user on this system with a clean ~/.mozilla folder and experienced the same problems.

Regards

Rolf

version info:
* ubuntu gutsy
* Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12

LAST VERSION TESTED:
Firefox 3.0 3.0.10+nobinonly-0ubuntu0.9.04.1
Firefox 3.5 3.5~b5~hg20090508r25128+nobinonly-0ubuntu1~umd1

On Thu, May 29, 2008 at 03:17:38PM -0000, Launchpad Bug Tracker wrote:
>
> version info:
> * ubuntu gutsy
> * Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 (gutsy) Firefox/2.0.0.12

When did this behaviour start for you? In which version did it work as
"expected?

 status incomplete

 - Alexander

Changed in firefox-3.0:
status: New → Incomplete

I think the behaviour changed around the beginning of the year, but I cannot say for sure. It certainly was a FF2 version that was working fine, I can't say more. I looked through /var/log/aptitude*, but that does not go very far back (actually, this bug is older than the last relevant entry)

still present for FF3 in hardy

Rolf Leggewie wrote:
> I think the behaviour changed around the beginning of the year, but I
> cannot say for sure. It certainly was a FF2 version that was working
> fine, I can't say more. I looked through /var/log/aptitude*, but that
> does not go very far back (actually, this bug is older than the last
> relevant entry)
>
> still present for FF3 in hardy
>
>
Please test with RC2 once it hits proposed or updates repos

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in firefox-3.0:
status: Incomplete → Invalid
Rolf Leggewie (r0lf) wrote :

I'm using 3.0.5 now and it's still the same.

Changed in firefox-3.0:
status: Invalid → New

Confirmed this is still an issue in FF 3.0.10

description: updated
summary: - gzip'ed files don't display
+ Firefox no default plugin/app set for gzip file type
Changed in firefox-3.0 (Ubuntu):
status: New → Confirmed
Rolf Leggewie (r0lf) on 2009-05-10
summary: - Firefox no default plugin/app set for gzip file type
+ gzip'ed text files don't display inline
John Vivirito (gnomefreak) wrote :

Can someone please look for/file this bug upstream.

I do not expect this to get fixed in 3.0 or 3.5 since they are both stable releases now

Changed in firefox-3.5 (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers