Java Plug-In is not available in Firefox-3.0

Bug #196067 reported by Thomas Perl on 2008-02-27
10
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: firefox-3.0

A "dpkg -l" on firefox-3.0 shows that its plug-ins are stored in "/usr/lib/firefox-3.0b3/plugins"

ll /usr/lib/firefox-3.0b3/plugins
lrwxrwxrwx 1 root root 25 2008-02-16 20:53 /usr/lib/firefox-3.0b3/plugins -> ../firefox-addons/plugins/

ll /usr/lib/firefox-addons/plugins/
total 0

ll /usr/lib/firefox/plugins/
total 0
lrwxrwxrwx 1 root root 37 2008-01-31 15:37 flashplugin-alternative.so -> /etc/alternatives/firefox-flashplugin
lrwxrwxrwx 1 root root 39 2008-02-27 10:52 libjavaplugin.so -> /etc/alternatives/firefox-javaplugin.so

The Java Plug-In is therefore not available in Firefox-3.0, even though the package sun-java6-plugin is installed.

Workaround: sudo ln -s /usr/lib/firefox/plugins/libjavaplugin.so /usr/lib/firefox-addons/plugins/

Solution: The libjavaplugin.so file has to be installed/linked in /usr/lib/firefox-addons/plugins/ or the symlink in the firefox-3.0 package has to be changed so plugins are searched in /usr/lib/firefox/plugins/ instead of /usr/lib/firefox-addons/plugins/

ProblemType: Bug
Architecture: i386
Date: Wed Feb 27 10:58:10 2008
DistroRelease: 'import site' failed; use -v for traceback Ubuntu 8.04
NonfreeKernelModules: ath_hal
Package: firefox 3.0~b3+nobinonly-0ubuntu4
PackageArchitecture: all
SourcePackage: firefox-3.0
Uname: Linux 2.6.24-7-generic i686

Thomas Perl (thp) wrote :
vidd (vidd) wrote :

I can confirm this bug.
However, I also needed to type sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so (as found in http://ubuntuforums.org/showthread.php?t=621864) to actually get the now-found plugin to actually load java content.

Vincent (vinnl) wrote :

Confirmed by vidd.

Changed in firefox-3.0:
status: New → Confirmed
brotherJohn (jens-ritter-gmail) wrote :

i added "export LIBXCB_ALLOW_SLOPPY_LOCK=1" instead of the sed'ing.
( There will be error-messages from the jvm, but the plugin / java will work )

Alex (jelly) wrote :

Photosig.com use Java for posting comments and stuffs. Thanks to:

"sudo ln -s /usr/lib/firefox/plugins/libjavaplugin.so /usr/lib/firefox-addons/plugins/"

I could see the posting box, and type a message. But if I try to post it, Firefox crashes saying segmentation fault.

Same if I try to play a java game for example.

"sudo sed -i 's/XINERAMA/FAKEEXTN/g' /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so" didn't help.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers