Firefox Packages Search Bar Uses Old URL

Bug #194681 reported by David Futcher on 2008-02-23
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
ubufox (Ubuntu)

Bug Description

When you search for a package using the Package search bar (included by default in Hardy) (Sorry, dont know the package name, ubufox maybe?) the search results show this text:

"You reached this site over an old URL. Depending on the exact parameters your search might work or not."

Related branches

David Futcher (bobbo) wrote :

This should fix it, I don't know how to make it a deb though.
Replace the existing /usr/lib/firefox-addons/searchplugins/debsearch.src with this one.

David Futcher (bobbo) wrote :

Thanks Niklas but that didnt fix it. Tried to hack it in myself and came up with this. Seems to work perfectly. Will attempt to create a debdiff

David Futcher (bobbo) wrote :

Forgot to add the attachment, here it is.

David Futcher (bobbo) wrote :

Here is the debdiff

Changed in firefox-3.0:
status: Confirmed → In Progress

The debdiff worked for me as well.

Fabien Tassin (fta) wrote :

Thank you for the fix.

We're already very close to Firefox 3.0 beta 4 so I've committed your fix in the firefox-3.0.head bzr branch.
It will be uploaded with the other fixes and improvements as soon as 3.0 beta 4 is out (code freeze planed for Feb 26th).

Changed in firefox-3.0:
importance: Undecided → Low
milestone: none → ubuntu-8.04-beta
status: In Progress → Fix Committed
Alexander Sack (asac) wrote :

the searchplugin is shipped by ubufox iirc.

Changed in firefox-3.0:
status: Fix Committed → Invalid
Changed in ubufox:
importance: Undecided → Low
milestone: none → ubuntu-8.04-beta
status: New → Triaged
David Futcher (bobbo) wrote :

Alexander Sack wrote: "the searchplugin is shipped by ubufox iirc."

Im pretty sure its not (although, i have never worked with (ubu|fire)fox in Ubuntu before but the debsearch file is debian/debsearch.src, which i patched in the debdiff i posted above.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firefox-3.0 - 3.0~b4+nobinonly-0ubuntu1

firefox-3.0 (3.0~b4+nobinonly-0ubuntu1) hardy; urgency=low

  [ Fabien Tassin <email address hidden> ]
  * Bump xulrunner-1.9 dependencies to b4
    - update debian/control
  * Refresh diverged patches:
    - update debian/patches/dont_depend_on_nspr_sources.patch
    - update debian/patches/force_safebrowsing_off.patch
  * Drop extension from desktop launchers icons (LP: #190688)
    - update debian/firefox-3.0-*.desktop
  * Install new
    - update debian/firefox-3.0.install
  * Add optional support for system sqlite3 (we need >= 3.5 not in hardy)
    - update debian/rules
  * Fix debsearch.src to work with new codebase (LP: #194681)
    Contributed by David Futcher <email address hidden>
    - update debian/debsearch.src
  * Bump gtk+ requirement to 2.10 because of the new Print Dialog
    - update debian/control
  * Add Polish translation to deskstop launcher (LP: #196953)
    Contributed by Tomasz Dominikowski <email address hidden>
    - update debian/firefox-3.0-final.desktop
  * Change $(shell) into $(wildcard) for XUL SDK detection
    - update debian/rules
  * Drop DEB_AUTO_UPDATE_DEBIAN_CONTROL cdbs variable completely. It was
    wrongly set to zero
    - update debian/rules
  * Stop build-tree/mozilla/README to be shipped as a doc by setting
    - update debian/rules

  [ Alexander Sack <email address hidden> ]
  * reuse apport hook from firefox 2 package initially developed by Hilario J.
    Montoliu <email address hidden> (LP: #199666)
    - add debian/apport/
    - update debian/firefox-3.0.install

 -- Alexander Sack <email address hidden> Thu, 13 Mar 2008 16:52:36 +0100

Changed in firefox-3.0:
status: Invalid → Fix Released
David Futcher (bobbo) on 2008-03-15
Changed in ubufox:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers