Firefox 3 doesn't act as the default browser

Bug #185622 reported by thomasn80
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firefox-3.0 (Ubuntu)
Fix Released
High
Alexander Sack

Bug Description

I have today upgraded from Gutsy to Hardy. After that, I could not open links in Evolution for example and opened bug http://bugzilla.gnome.org/show_bug.cgi?id=511761 about that.

I got a question in that bug about my default browser and I can't see that FF3 is the default browser (checked in /desktop/gnome/applications/browser).

I have FF 3 to check on startup if it's the default browser and previously I had FF 3 alpha installed on Gutsy and had chosen to make it as default browser there which worked fine. If I do a check now nothing happens which should indicate that FF 3 thinks it's the default.

Looking at the relevant links in /etc/alternatives I can there see that FF 2 is the default.

lrwxrwxrwx 1 root root 16 2007-12-05 08:15 gnome-www-browser -> /usr/bin/firefox
lrwxrwxrwx 1 root root 16 2008-01-24 10:24 x-www-browser -> /usr/bin/firefox

If I try to open a web page in deskbar applet nothing happens at all, neither 2.0 or 3.0 b3 opens.

Revision history for this message
thomasn80 (thomasn80) wrote :

The Bugzilla Evo bug is now closed and that reply also solves this problem however I think it's now confirmed that FF 3.0 b3 is unable to recognize that it's not the default browser. I was lookin at the wrong gconf-key, the one I should have looked at was probably these:

/desktop/gnome/url-handlers/http
/desktop/gnome/url-handlers/https
/desktop/gnome/url-handlers/ftp

(and maybe more)

I can see in the http key that it has command = /usr/lib/firefox-3.0/firefox-3.0 "%s" and this is what's the previous alpha (a8) did set.

I opened FF 2 and did a check there, it discovered that it was not default and was also able to change these values. Restarting FF 3 b3, it could still not see that it was not the default browser.

The bug is clearly in FF 3 b3..?

Revision history for this message
Alexander Sack (asac) wrote :

firefox-3.0 isn't the default browser in ubuntu yet - which should happen really soon though.

Changed in firefox-3.0:
status: New → In Progress
importance: Undecided → Medium
milestone: none → hardy-alpha-5
Revision history for this message
thomasn80 (thomasn80) wrote :

Yes I know but if you in FF set it as default browser when you are asked it should be able to do that, right?

After manually changing in gconf I have been able to use FF 3 as default browser for all programs except for apport which still starts FF 2.

Revision history for this message
Alexander Sack (asac) wrote :
Download full text (3.8 KiB)

this was fixed in a recent upload ...

firefox-3.0 (3.0~b3+nobinonly-0ubuntu1) hardy; urgency=low

  * Firefox 3 Beta 3 release (FIREFOX_3_0b3_RELEASE)
  [ Alexander Sack ]
  * use default upstream gcc tweaks for improved performance - especially of
    the javascript engine
    - update debian/rules
  * add gtk based profile migrator dialog, build it during |pre-build| and clean
    it in |clean| target of debian/rules; finally, install the binary in firefox
    pkglibdir.
    - add debian/migrator/main.c
    - update debian/rules
  * drop version suffix from MOZ_APP and application.ini (going back to
    upstreams plain |firefox|) and drop patches accordingly
    - drop debian/patches/firefox-fsh
    - drop debian/patches/firefox-profilename
    - update debian/patches/series
  * install firefox binary instead of firefox-3.0 (after MOZ_APP_NAME
    tweakage was dropped in on of the previous commits
    - update debian/firefox-3.0.install
  * reuse firefox.sh.in script to determine on whether the user was a beta
    user and if thats the case ask the user (by running the profile migrator
    added above) which profile to use in future
    - update debian/firefox.sh.in
  * fix DEBIAN_FF3_DIR, which diverged from install dir after dropping
    special application name and profile dir tweaks
    - update debian/rules
  * drop development version disclaimer from package description and improve
    the package description by stripping technical details and referrals to
    other browser applications that are less known than firefox and thus don't
    provide any valuable info to normal users.
    - update debian/control
  * bump build dependency for xulrunner-1.9-dev to >= 1.9~b3
    - update debian/control
  * bump bin dependency on xulrunner-1.9 and on xulrunner-1.9-gnome-support
    to >= 1.9~b3
    - update debian/control
  * introduce (empty) firefox meta package that automatically upgrades users
    to latest major releases of firefox; firefox 2 will be reuploaded as
    firefox-2 and then be demoted to universe
    - update debian/control
  * make firefox-3.0 conflict/replace old firefox 2 package to force upgrade
    - update debian/control
  * remove "Development Version" disclaimer from package short descriptions
    - update debian/control
  * introduce empty meta packages for firefox, firefox-dom-inspector,
    firefox-gnome-support and firefox-dev to provide a seamingless upgrade path
    from previous firefox versions. Add Conficts/Replaces accordingly and make
    firefox-3.0 Conflicts/Replaces/Provides firefox-libthai which is now fully
    integrated in the core as pango line breaking feature is used.
    - update debian/control
  * provide link /usr/bin/firefox => /usr/bin/firefox-4.0
    - add debian/firefox-3.0.links

  [ Fabien Tassin ]
  * Add support for mozilla-devscripts and clean-up rules file accordingly
    - update debian/rules
  * Clean-up rules file to make more use of $(EXTRA_SYSTEM_CONFIGURE_FLAGS)
    - update debian/rules
  * Update diverged patch:
    - update debian/patches/ftbfs-with-branding-dir
  * Add #DEBHELPER# token to prerm script
    - up...

Read more...

Changed in firefox-3.0:
status: In Progress → Fix Released
Revision history for this message
Arthur Furlan (afurlan) wrote :

The last update of the Ubuntu Hardy set the Firefox 3.0 as the default browser, but i think that it isn't fully integrated.
When I click in a link on Thunderbird, or X-Chat, or Pidgin, [or any other program, ...] the link doesn't open on Firefox 3.0

The gnome default browser seems to be correctly configured because the below command works right.

afurlan@einstein:~$ gnome-www-browser

Changed in firefox-3.0:
status: Fix Released → Incomplete
Revision history for this message
Jurjen Stellingwerff (jurjen-stwerff) wrote :

Firefox 3.0 build seems to be missing a file called /var/lib/firefox-3.0b3/libgtkembedmoz.so
The old firefox package contained /var/lib/firefox/libgtkembedmoz.so and a lot of external packages use that library to open firefox windows.

Revision history for this message
Matthew Tighe (tighem) wrote :

This is working for me under Hardy Alpha-4 (almost alpha 5). I don't think I ever had a folder called /var/lib/firefox but I know I don't have anything now. I also searched for libgtkembedmoz.so under /var/lib and /usr/lib and found it in /usr/lib/thunderbird but not under /usr/lib/firefox.

I don't use pidgin so I can't comment on that but Thunderbird and Evolution seem to be opening links just fine for me.

Revision history for this message
Alexander Sack (asac) wrote :

if you still see this bug, please be sure that you have firefox + firefox-3.0 3.0~b3+nobinonly-0ubuntu1 or later on your system before claiming that you still see this. if you have that version, but still see this certainly want to know about it.

Alexander Sack (asac)
Changed in firefox-3.0:
importance: Medium → High
Revision history for this message
thomasn80 (thomasn80) wrote :

After doing a clean install with Alpha4 and applying all upgrades this is a non-issue for me.

To reproduce the problem I had you could probably set FF 2 as default browser and then switch to FF 3 by answering the question you get when you start it up (if you want to make it the default). That step did not work before but I don't have FF 2 any more so I cannot test.

Revision history for this message
Kenneth Loafman (kenneth-loafman) wrote :

This is probably a transitional issue. In my case the problem happened with dist-upgrade from Gutsy to Hardy, then a week or so later the dist-upgrade of Firefox 2 to Firefox 3b3 appeared and I did that. After that Firefox 2 was no longer on the system, so it was not a question of selecting the defaults, it was the fact that the dist-upgrade set my Preferred Applications setting for Web Browser to 'Custom', pointing to a file that did not exist. Swapping back to Firefox as the preferred browser solved my problem. I may not be able to reproduce the sequence since there have been hundreds of updates since my upgrade from Gutsy to Hardy.

Revision history for this message
Kenneth Loafman (kenneth-loafman) wrote : Re: [Bug 185622] Re: Firefox 3 doesn't act as the default browser

I just performed a dist-upgrade from Gutsy to Hardy and it did the
upgrade to Firefox 3 as part of the initial dist-upgrade, plus it setup
the Preferred Applications / Web Browser settings correctly. URLs
launch correctly form the apps I have tested.

The dist-upgrade I did a couple of weeks ago did not include Firefox 3,
so I'm guessing the problem has been fixed since then. I would mark
this problem closed unless someone else can replicate it.

Revision history for this message
Alexander Sack (asac) wrote :

ok. If you are struck by this, you most likely told firefox at some point to make itself the default browser.

Can you confirm that you have /usr/lib/firefox/firefox{-bin} set as the Custom Preferred browser if you see this?

Thanks,

 - Alexander

Changed in firefox-3.0:
milestone: hardy-alpha-5 → ubuntu-8.04-beta
importance: High → Medium
Revision history for this message
Arthur Furlan (afurlan) wrote :

Yes... I had the "firefox" set as the Custom Preferred browser and it wasn't working then I changed it to "sensible browser" and the problem was solved.

Before the broken update my Custom Preferred browser was set as "firefox" with the "open in new tab" (or something like these) enabled.

I really think it's a transitional issue.

Revision history for this message
Alexander Sack (asac) wrote :

you used the /usr/lib/firefox/... path to setup your custom preferred browser? if you'd just used /usr/bin/firefox it should "just work (TM)".

Can you confirm?

Revision history for this message
Arthur Furlan (afurlan) wrote :

On Mon, Mar 10, 2008 at 10:56 AM, Alexander Sack <email address hidden> wrote:

> you used the /usr/lib/firefox/... path to setup your custom preferred
> browser? if you'd just used /usr/bin/firefox it should "just work (TM)".

I just used the "firefox option" existent on the GUI.

--
Atenciosamente,

Arthur Furlan
<email address hidden>

> Can you confirm?
>
> --
> Firefox 3 doesn't act as the default browser
> https://bugs.launchpad.net/bugs/185622
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Revision history for this message
Alexander Sack (asac) wrote :

will not be fixed in hardy beta.

Changed in firefox-3.0:
milestone: ubuntu-8.04-beta → ubuntu-8.04
Revision history for this message
Alexander Sack (asac) wrote :

the problem here is that firefox sets the binary that lives in pkglibdir as the "default browser" path. this works as long as pkglibdir doesn't change its location. once that happens (like in b3 -> b4 update), the path is wrong and the custom browser configured in gconf points to nowhere.

The fix should just force firefox to use /usr/bin/firefox as the "custom browser path".

Changed in firefox-3.0:
status: Incomplete → Triaged
Revision history for this message
Alexander Sack (asac) wrote :

this is a bug of at least high importance.

Changed in firefox-3.0:
importance: Medium → High
Alexander Sack (asac)
Changed in firefox-3.0:
assignee: nobody → asac
Revision history for this message
Alexander Sack (asac) wrote :

committed on firefox.head branch.

Changed in firefox-3.0:
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package firefox-3.0 - 3.0~b5+nobinonly-0ubuntu1

---------------
firefox-3.0 (3.0~b5+nobinonly-0ubuntu1) hardy; urgency=low

  * Firefox 3.0 Beta 5 package - "ready for prime-time"!

  * Multiple fixes and improvements to debian/rules: "rewrite substitution
    rules", "bad .autoreg install path makes package ftbfs", "Firefox must not
    ship reporter extension; its shipped in xulrunner-1.9", "enable
    mozilla-devscript's in binary-post-install", "--disable-debug passed twice
    in configure"
    - update debian/rules

       * Alexander Sack <email address hidden>
       * Fabien Tassin <email address hidden>

  * Multiple fixes to the apport hook: "remove .pyc file garbage during prerm",
    "bad install path", "bad extension directories used to gather data"
    - update debian/apport/firefox-3.0.py
    - update debian/firefox-3.0.prerm
    - update debian/firefox-3.0.install

       * Alexander Sack <email address hidden>
       * Fabien Tassin <email address hidden>

  * Multiple fixes required by libxul linkage with jemalloc: "libjemalloc.so
    cannot be installed - doesn't exist", "-Wl,-Bsymbolic-functions in LDFLAGS
    cause crashes at startup"
    - update debian/firefox-3.0.install
    - update debian/rules

       * Fabien Tassin <email address hidden>

  * Fix multiple misc bugs: "migration creates double dots for abandoned
    profiles", "Wikipedia search plugin shipped upstream", "blocklist.xml not
    installed", "use LIBDIR when touching .autoreg in postinst", "Fix restart
    notification misbehaviour", "Improve package description (LP: #207199)"
    - update debian/firefox.sh.in
    - drop debian/wikipedia.*
    - update debian/firefox-3.0.install
    - update debian/rules
    - update debian/firefox-3.0.postinst.in
    - update debian/firefox-3.0-restart-required.update-notifier

       * Alexander Sack <email address hidden>
       * Fabien Tassin <email address hidden>

  * Misc package housekeeping changes: "Bump xulrunner-1.9
    dependencies to b5", "Adjust patches", "desktop files not valid
    (LP: #194970)", "relax dependencies on xulrunner. no upper bounds":
    - update debian/control
    - update debian/patches/dont_depend_on_nspr_sources.patch
    - update debian/patches/nspr_flags_by_pkg_config_hack.patch

       * Fabien Tassin <email address hidden>

  * Multiple Translation related fixes and improvements: "Reuse translations
    from firefox 2 .desktop file", "include lp-export-xpi.mk from
    mozilla-devscripts and export en-US.xpi to debian/lp-export-xpis/
    directory"
    - update debian/firefox-final.desktop
    - update debian/rules
    - update debian/control

       * Alexander Sack <email address hidden>
       * Fabien Tassin <email address hidden>

  * Fixing chrome registration issues by properly shipping
    $(DEBIAN_FF3_DIR)/.autoreg and touching it in postinst maintainer scripts
    - update debian/rules
    - update debian/firefox-3.0.postinst.in
    - add debian/firefox-3.0-gnome-support.postinst

       * Alexander Sack <email address hidden>
       * Fabien Tassin <email address hidden>

  * fix LP: #185622 - "Firefox 3 doesn't act as the default browser"; we
    always check for and use /usr/bin/firef...

Read more...

Changed in firefox-3.0:
status: Fix Committed → Fix Released
Revision history for this message
Chuck Renner (chuckrenner) wrote :
Download full text (3.4 KiB)

After installing a bunch of packages today (sorry, I cannot remember what), my default browser changed to Epiphany, and every time I tried to launch firefox, I would get an error, "Couldn't load XRE functions".

After seeing this, and similar issues, I decided to check the x-www-browser and gnome-www-browser files in /var/lib/dpkg/alternatives to see which browser gets automatic preference. I was shocked to see that Epiphany was set to 85, and firefox was only set to 40 for the default x browser and firefox wasn't listed at all for the gnome browser. Why? Why? Why?

Contents of /var/lib/dpkg/alternatives/gnome-www-browser:[Code]auto
/usr/bin/gnome-www-browser
gnome-www-browser.1.gz
/usr/share/man/man1/gnome-www-browser.1.gz

/usr/bin/epiphany-gecko
85
/usr/share/man/man1/epiphany-gecko.1.gz
[/Code]
Contents of /var/lib/dpkg/alternatives/x-www-browser:[Code]/usr/share/man/man1/x-www-browser.1.gz

/usr/bin/firefox-3.0
40

/usr/bin/epiphany-gecko
85
/usr/share/man/man1/epiphany-gecko.1.gz
[/Code]
I noticed that these values were the same on another computer where firefox is still working. These values make NO sense to me at all.
Here is my suggestion to at least fix the alternatives (adjust as needed - this is someone dynamic, but not perfect):
[Code]
# Use ALTADMINDIR to hold the name of the alternatives admin directory
ALTADMINDIR=/var/lib/dpkg/alternatives
echo ALTADMINDIR=$ALTADMINDIR
# Use ALTnNAME to hold the name of the nth alternative we are changing
ALT1NAME=gnome-www-browser
echo ALT1NAME=$ALT1NAME
ALT2NAME=x-www-browser
echo ALT2NAME=$ALT2NAME
# By using pushd, we can easily go back to our original directory
pushd $ALTADMINDIR
# This alias is uses sed to process an ISO-8601 date to remove the hyphens and colons for easier file name compatibility (but it's still ISO-8601 compliant)
alias bak_time="sed -e 's/\([0-9]\{4,\}\)-\([0-9]\{2\}\)-\([0-9]\{2\}\)T/\1\2\3T/' -e 's/\([0-9]\):/\1/' -e 's/\([0-9]\):/\1/'"
# Copy the original alternatives definitions to backups, each with an ISO-8601 compliant date and time on the end of their backup file names
sudo cp -a $ALT1NAME $ALT1NAME.`date -Iseconds | bak_time`
sudo cp -a $ALT2NAME $ALT2NAME.`date -Iseconds | bak_time`
# Set the paths of the executable links that will call the /etc/alternatives links
ALT1LINK=`which $ALT1NAME`
echo ALT1LINK=$ALT1LINK
ALT2LINK=`which $ALT2NAME`
echo ALT2LINK=$ALT2LINK
# Set the path of a symlink (that is not and does not resolve to an alternative) that calls the shell script that launches firefox.
LAUNCHFF=`which \`readlink \\\`which firefox\\\`\``
echo LAUNCHFF=$LAUNCHFF
# Set a priority for firefox in the alternative definition that is HIGHER than the one assigned to any other browser in the definition
ALTPRIORITY=100
echo ALTPRIORITY=$ALTPRIORITY
# Create/update the alternatives definitions, giving firefox highest priority
sudo update-alternatives --install $ALT1LINK $ALT1NAME $LAUNCHFF $ALTPRIORITY
sudo update-alternatives --install $ALT2LINK $ALT2NAME $LAUNCHFF $ALTPRIORITY
# Update the alternatives to automatically use the highest priority entries
sudo update-alternatives --auto $ALT1NAME
sudo update-alternatives --auto $ALT2NAME
# go back to our ori...

Read more...

Revision history for this message
Kevin Havens (bootloop-deactivatedaccount) wrote :

This may be an old bug but it still happens happens on Firefox 43.

I have no other browser installed.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers