Firebird 2.5: COLLATION UNICODE for CHARACTER SET UTF8 is not installed

Bug #778386 reported by Steffen on 2011-05-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firebird2.5 (Ubuntu)
Undecided
Popa Adrian Marius

Bug Description

Binary package hint: libicu44

After an upgrade to Ubuntu 11.04 I haven't been able to use my Firebird DB.
When accessing tables that have a collation I get errors indicating the collation not installed.

I found a similar bug reported for fedora 14: https://bugzilla.redhat.com/show_bug.cgi?id=697313
The fedora bug says it is a libicu42 issue.

How to reproduce:
open isql-fb and connect to db

SQL> show system collations;
...
UNICODE, CHARACTER SET UTF8, PAD SPACE, 'COLL-VERSION=49.192.5.41', SYSTEM
UNICODE_CI, CHARACTER SET UTF8, FROM EXTERNAL ('UNICODE'), PAD SPACE, CASE INSENSITIVE, 'COLL-VERSION=49.192.5.41', SYSTEM
UNICODE_FSS, CHARACTER SET UNICODE_FSS, PAD SPACE, SYSTEM
UTF8, CHARACTER SET UTF8, PAD SPACE, SYSTEM
...

SQL> create table xxx (name varchar(32) character set UTF8 collate UNICODE);
Statement failed, SQLSTATE = 22021
unsuccessful metadata update
-XXX
-COLLATION UNICODE for CHARACTER SET UTF8 is not installed

Restoring a db with gbak gives similar result.

I also use Firebird2.5 on Ubuntu 10.10, where it works, thats why I believe its in libicu44.

Installed versions:
$ lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

$ apt-cache policy firebird2.5-superclassic libicu44
libicu44:
  Installeret: 4.4.2-2
  Kandidat: 4.4.2-2
  Versionstabel:
 *** 4.4.2-2 0
        500 http://dk.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
firebird2.5-superclassic:
  Installeret: 2.5.0.26074-0.ds4-4
  Kandidat: 2.5.0.26074-0.ds4-4
  Versionstabel:
 *** 2.5.0.26074-0.ds4-4 0
        500 http://dk.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

$ ldd /usr/sbin/fb_smp_server |grep icu
 libicuuc.so.44 => /usr/lib/libicuuc.so.44 (0x00ab5000)
 libicudata.so.44 => /usr/lib/libicudata.so.44 (0xb6a40000)

Root cause seems to be similar as the issue raised in #675946 will follow up with the upstream. (Steven, ICU developer)

Steffen (steffen-kernelguy) wrote :

If I understand #675946 correctly, it is Firebird and all its tools that is linked with symbols prefixed with 4.2.
Is there a workaround I can use, to make Firebird work again?

Steffen (steffen-kernelguy) wrote :

It seems like the problem was fixed in Firebird 2.5 svn a few weeks ago:
http://tracker.firebirdsql.org/browse/CORE-3447?page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel

So I guess this bug should be changed to affect firebird 2.5 instead of icu.

affects: icu (Ubuntu) → firebird2.5 (Ubuntu)
Changed in firebird2.5 (Ubuntu):
assignee: nobody → Mariuz (mapopa)
Popa Adrian Marius (mapopa) wrote :

To do add a SRU https://wiki.ubuntu.com/StableReleaseUpdates
Package is not functional with Unicode charsets (I consider an important bug is fixed with this patch)

Damyan Ivanov (dmn-debian) wrote :

This is fixed in Debian since 2.5.1~svn+52789.ds4-1 in experimental. Sid includes the fix at version 2.5.1.26349-0~rc1.ds4-1

Steffen (steffen-kernelguy) wrote :

Just for information:
I upgraded my workstation from Ubuntu 11.10 to 12.04 I got the same error message again.
I restored from a backup made on our production server and everything worked again.

Production server:
Ubuntu 11.10, firebird2.5-super ver. LI-V2.5.1.26351

Workstation:
Ubuntu 12.04, firebird2.5-superclassic ver. LI-V2.5.1.26351

I believe the 11.10 version I had on my workstation matched the production server, so the fdb format should be the same, but I somehow needed the restore for it to work.

Steffen (steffen-kernelguy) wrote :

Just update one of one of our servers from 11.04 to 12.04 and got the collation error again.
After a restore my DB worked again.

So this problem is still there, at least for me.

Popa Adrian Marius (mapopa) wrote :

You need to do a backup restore to fix this bug if you are upgrading from 11.10 to 12.04 where the bug is fixed

Popa Adrian Marius (mapopa) wrote :

Please upgrade to 12.04 also the backup restore is required

Changed in firebird2.5 (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers