Sync firebird2.5 2.5.0.26074-0.ds4-4 (universe) from Debian unstable (main)

Bug #717182 reported by Popa Adrian Marius on 2011-02-11
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
firebird2.5 (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync firebird2.5 2.5.0.26074-0.ds4-3 (universe) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
Final version of Firebird 2.5 is now in debian repository , fixes many bugs with
firebird 2.5 install , package is considered stable both in debian stable, upstream
and it was tested from ppa too (for many mohts)

Changelog entries since current natty version 2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu1:

firebird2.5 (2.5.0.26074-0.ds4-3) unstable; urgency=low

  * upload to unstable

 -- Damyan Ivanov <email address hidden> Wed, 09 Feb 2011 22:42:59 +0200

firebird2.5 (2.5.0.26074-0.ds4-2) experimental; urgency=low

  * update and activate port-hppa-alpha.patch
    Closes: #565762, #565861

 -- Damyan Ivanov <email address hidden> Fri, 15 Oct 2010 16:54:39 +0300

firebird2.5 (2.5.0.26074-0.ds4-1) experimental; urgency=low

  * New upstream release
    no source changes since 2.5.0.26074~unofficial

  * debian/repack.sh:
    + restore removal of source-less PDF files in doc/
    + restore removal of generated autotools files
    + bump dsX version
  * debian/watch: avoid mangling official releases
  * README.Debian: add a note about missing PDF documentation

 -- Damyan Ivanov <email address hidden> Mon, 04 Oct 2010 17:15:16 +0300

firebird2.5 (2.5.0.26074~unofficial.ds3-3) experimental; urgency=low

  * add firebird2.5-{super,classic}-dbg packages
  * rules: make parallel-buildable

 -- Damyan Ivanov <email address hidden> Wed, 29 Sep 2010 14:55:13 +0300

firebird2.5 (2.5.0.26074~unofficial.ds3-2) experimental; urgency=low

  * add sparc-no-m32.patch

 -- Damyan Ivanov <email address hidden> Sat, 25 Sep 2010 15:29:12 +0300

firebird2.5 (2.5.0.26074~unofficial.ds3-1) experimental; urgency=low

  * New upstream snapshot from the R2_5_0 tag at revision 51557
    + copyright: drop one file removed upstream

  * *.init: do not fail when no command is given on the command line
    since we run under 'set -u', the check for "$1" should be protected
    with "${1:-}". Closes: #578471
  * repack: adapt to unofficial 2.5.0 release
  * adopt '3.0 (quilt)' source format; set some local-options

 -- Damyan Ivanov <email address hidden> Fri, 17 Sep 2010 17:07:38 +0300

Bhavani Shankar (bhavi) on 2011-02-11
Changed in firebird2.5 (Ubuntu):
importance: Undecided → Wishlist
Angel Abad (angelabad) wrote :

This Debian package ftbfs in Natty:

/usr/bin/ld: ../temp/std/common/classes/PublicHandle.o: undefined reference to symbol 'pthread_rwlock_wrlock@@GLIBC_2.2.5'
/usr/bin/ld: note: 'pthread_rwlock_wrlock@@GLIBC_2.2.5' is defined in DSO /lib64/libpthread.so.0 so try adding it to the linker command line
/lib64/libpthread.so.0: could not read symbols: Invalid operation
collect2: ld returned 1 exit status
make[4]: *** [../gen/firebird/bin/gfix] Error 1
rm ../temp/std/alice/alice_meta.cpp
make[4]: Leaving directory `/tmp/buildd/firebird2.5-2.5.0.26074-0.ds4/gen'
make[3]: *** [client_gfix] Error 2

This should be a merge instead of sync

Unsubscribing sponsors for the moment.

Thanks!

Changed in firebird2.5 (Ubuntu):
assignee: nobody → Mariuz (mapopa)
status: New → Incomplete

On Sat, Feb 12, 2011 at 2:09 PM, Angel Abad <email address hidden> wrote:
> This Debian package ftbfs in Natty:
>
> /usr/bin/ld: ../temp/std/common/classes/PublicHandle.o: undefined reference to symbol 'pthread_rwlock_wrlock@@GLIBC_2.2.5'
> /usr/bin/ld: note: 'pthread_rwlock_wrlock@@GLIBC_2.2.5' is defined in DSO /lib64/libpthread.so.0 so try adding it to the linker command line
> /lib64/libpthread.so.0: could not read symbols: Invalid operation
> collect2: ld returned 1 exit status
> make[4]: *** [../gen/firebird/bin/gfix] Error 1
> rm ../temp/std/alice/alice_meta.cpp
> make[4]: Leaving directory `/tmp/buildd/firebird2.5-2.5.0.26074-0.ds4/gen'
> make[3]: *** [client_gfix] Error 2
>
> This should be a merge instead of sync
>
> Unsubscribing sponsors for the moment.
seems that the only thing that needs to be added is lpthread in rules

+++ firebird2.5-2.5.0.26054~ReleaseCandidate3.ds2/debian/rules
@@ -1,5 +1,7 @@
 #!/usr/bin/make -f

+LDFLAGS+=-lpthread
+

http://launchpadlibrarian.net/58726571/firebird2.5_2.5.0.26054~ReleaseCandidate3.ds2-1_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu1.diff.gz

> ** Changed in: firebird2.5 (Ubuntu)
>       Status: New => Incomplete
>
> ** Changed in: firebird2.5 (Ubuntu)
>     Assignee: (unassigned) => Mariuz (mapopa)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/717182
>
> Title:
>  Sync firebird2.5 2.5.0.26074-0.ds4-3 (universe) from Debian unstable
>  (main)
>

Sorry Mariuz, but I think this isnt the best solution for this ftbfs, we shouldnt modify debian/rules, we should modify upstream build system. If it dont bother you I can make a merge modifying upstream Makefiles rules and report changes to Debian Developer.

Are you agree?

Popa Adrian Marius (mapopa) wrote :

I have contacted damyan

the difference seems to be that Ubuntu vs Debian adds these LDFLAGS

g++ -Wl,-Bsymbolic-functions
and that cause a problem

Angel Abad (angelabad) wrote :

Sorry, but I tried to solve this FTBFS but I couldnt. It has a complicated Makefiles system. And in this version, add LDFLAGS in debain/rules doesn't work.

Regards,

Mahyuddin Susanto (udienz) wrote :

No you can't add LDFLAGS in d/rules, Angel Albad in #5 is true. in Armel it caused FTBFS, It's better to investigating configure.in

tags: added: upgrade-software-version
Popa Adrian Marius (mapopa) wrote :

New package is uploaded in debian firebird2.5_2.5.0.26074-0.ds4-4 please sync when it finished uploading
http://packages.qa.debian.org/f/firebird2.5/news/20110315T090715Z.html

* no-spurious-linkage.patch: link all executables with pthreads.
     yes, this introduces a couple of warnings about needless linking, but
     is the easiest way to fix the missing pthreads linkage in most of the
     executables (closes: #618104)

Angel Abad (angelabad) wrote :

New package builds well in natty chroot, stnc request ACKd

summary: - Sync firebird2.5 2.5.0.26074-0.ds4-3 (universe) from Debian unstable
+ Sync firebird2.5 2.5.0.26074-0.ds4-4 (universe) from Debian unstable
(main)
Changed in firebird2.5 (Ubuntu):
assignee: Mariuz (mapopa) → nobody
status: Incomplete → Confirmed
Colin Watson (cjwatson) wrote :

[Updating] firebird2.5 (2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [Ubuntu] < 2.5.0.26074-0.ds4-4 [Debian])
 * Trying to add firebird2.5...
2011-03-22 10:58:01 INFO - <firebird2.5_2.5.0.26074-0.ds4-4.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2011-03-22 10:58:01 INFO - <firebird2.5_2.5.0.26074-0.ds4-4.dsc: downloading from http://ftp.debian.org/debian/>
2011-03-22 10:58:01 INFO - <firebird2.5_2.5.0.26074-0.ds4.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: firebird2.5 [universe] -> firebird2.5-super_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-classic_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-superclassic_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> libfbclient2_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> libfbembed2.5_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> libib-util_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-common_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-server-common_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-classic-common_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-dev_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-examples_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-doc_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].
I: firebird2.5 [universe] -> firebird2.5-common-doc_2.5.0.26054~ReleaseCandidate3.ds2-1ubuntu2 [universe].

Changed in firebird2.5 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers