xargs: xargs.c:443: main: Assertion `bc_ctl.arg_max <= (131072-2048)' failed.

Bug #234345 reported by Andrew Pollock on 2008-05-23
132
This bug affects 2 people
Affects Status Importance Assigned to Milestone
findutils (Debian)
Fix Released
Unknown
findutils (Ubuntu)
Critical
Michael Vogt

Bug Description

Binary package hint: findutils

I'm trying to do a dist-upgrade from hardy to intrepid, and the upgrade itself fell over because xargs was crashing.

Anything involving xargs seems to break:

(intrepid-source)root@frobnitz:~# ls | xargs echo
xargs: xargs.c:443: main: Assertion `bc_ctl.arg_max <= (131072-2048)' failed.
Aborted

Andrew Pollock (apollock) wrote :

and now I'm no longer able to reproduce this problem in an intrepid chroot...

Changed in findutils:
status: New → Invalid
Reinhard Tartler (siretart) wrote :

this always happens if xargs from hardy is used with the libc from intrepid. So you should be able to reproduce it by upgrading glibc only on an hardy system.

This hits every upgrade from hardy to intrepid.

Changed in findutils:
importance: Undecided → Critical
status: Invalid → Confirmed
Michael Vogt (mvo) wrote :

A additional depends in libc6 on the fixed version of findutils should be enough:

Depends: libgcc1, findutils (>= 4.4.0-2ubuntu2)

Because findutils is essential it will get unpacked/configured immediately and because libc6 depends on the new version we can ensure that a new xargs is available before the new libc6 gets unpacked.

ally86127 (guy86127) wrote :

I had met this problem yesterday,and I have solved it now,The way is :
use "update-manager "order in terminal,then you can upgrade,It is so easy to deal with it!ahhhh.......

heartsmagic (heartsmagic) wrote :

Yes, update-manager way solved the problem. Now, it passed the xargs step and upgrading.

Gabriel Ruiz (anakron) wrote :

Hi!

        I had the same problem, but i build dependencies of findutils, then i install it and then i install debconf without any problem that i had ;-)

See you!

Gabriel Ruiz (anakron) wrote :

if you do it, you solve the problem :)

Changed in findutils:
assignee: nobody → anakron
Kjell Braden (afflux) wrote :

Please don't assign yourself to bugs, unless you are working on fixing them in ubuntu.

Changed in findutils:
assignee: anakron → nobody
Michael Vogt (mvo) on 2008-06-20
Changed in findutils:
assignee: nobody → mvo
status: Confirmed → In Progress
Christophe Dumez (hydr0g3n) wrote :

I just upgraded from hardy to intreprid and I confirm that this bug is still present:

Preconfiguring packages ...
Hotway already configured to use inetd. Leave alone.
(Reading database ... 236351 files and directories currently installed.)
Preparing to replace debconf 1.5.20 (using .../debconf_1.5.22_all.deb) ...
xargs: xargs.c:443: main: Assertion `bc_ctl.arg_max <= (131072-2048)' failed.
Aborted
dpkg: warning - old pre-removal script returned error exit status 134
dpkg - trying script from the new package instead ...
xargs: xargs.c:443: main: Assertion `bc_ctl.arg_max <= (131072-2048)' failed.
Aborted
dpkg: error processing /var/cache/apt/archives/debconf_1.5.22_all.deb (--unpack):
 subprocess new pre-removal script returned error exit status 134
Errors were encountered while processing:
 /var/cache/apt/archives/debconf_1.5.22_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'll try using update-manager.

Michael Vogt (mvo) wrote :

This got fixed with the upload on 20.06.08 of glibc. I did some test upgrades succesfully with the fix.

Thanks,
 mIchael

Changed in findutils:
status: In Progress → Fix Released
Changed in findutils (Debian):
status: Unknown → New
Diana C (chincesdiana) wrote :

This is still happening in 11.04

Changed in findutils (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.