Ubuntu

filezilla crashes on drag'n'drop

Reported by Robert Hollencamp on 2009-11-02
204
This bug affects 64 people
Affects Status Importance Assigned to Milestone
filezilla (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: filezilla

Filezilla crashes with a segmentation fault when I try to download a file from an FTP server. If I right-click a file on the remote machine and choose 'download', the file downloads as expected. If I drag the file from the remote machine to the local machine, however, it crashes with a segfault. I captured what I could using GDB, but I do not know how to debug threaded apps ( and was never that good with gdb anyway :P ).

Starting program: /usr/bin/filezilla
[Thread debugging using libthread_db enabled]
[New Thread 0xb7eaeb70 (LWP 5054)]
[New Thread 0xb7654b70 (LWP 5055)]
[New Thread 0xb6d6db70 (LWP 5056)]
[New Thread 0xb656cb70 (LWP 5057)]
[Thread 0xb656cb70 (LWP 5057) exited]
[New Thread 0xb656cb70 (LWP 5058)]
[New Thread 0xb5bffb70 (LWP 5059)]
[New Thread 0xb53feb70 (LWP 5060)]
[Thread 0xb5bffb70 (LWP 5059) exited]
[Thread 0xb53feb70 (LWP 5060) exited]
[New Thread 0xb53feb70 (LWP 5066)]
[New Thread 0xb5bffb70 (LWP 5067)]
[Thread 0xb53feb70 (LWP 5066) exited]
[Thread 0xb5bffb70 (LWP 5067) exited]
[New Thread 0xb5bffb70 (LWP 5070)]
[New Thread 0xb53feb70 (LWP 5071)]
[Thread 0xb5bffb70 (LWP 5070) exited]
[Thread 0xb53feb70 (LWP 5071) exited]
[New Thread 0xb53feb70 (LWP 5074)]
[New Thread 0xb5bffb70 (LWP 5075)]
[Thread 0xb53feb70 (LWP 5074) exited]
[Thread 0xb5bffb70 (LWP 5075) exited]
[New Thread 0xb5bffb70 (LWP 5078)]

Program received signal SIGSEGV, Segmentation fault.
0x00308d2c in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
(gdb) where
#0 0x00308d2c in ?? () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#1 0x01109474 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#2 0x00e87072 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#3 0x00e9c7a8 in ?? () from /usr/lib/libgobject-2.0.so.0
#4 0x00e9d9b8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#5 0x00e9dfb6 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#6 0x0122596e in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#7 0x0110307c in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#8 0x007df62a in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#9 0x05447e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#10 0x0544b720 in ?? () from /lib/libglib-2.0.so.0
#11 0x0544bb8f in g_main_loop_run () from /lib/libglib-2.0.so.0
#12 0x01103419 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x0030ac78 in wxEventLoop::Run() () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#14 0x0039de3e in wxAppBase::MainLoop() ()
   from /usr/lib/libwx_gtk2u_core-2.8.so.0
#15 0x0039da31 in wxAppBase::OnRun() () from /usr/lib/libwx_gtk2u_core-2.8.so.0
#16 0x008d27aa in wxEntry(int&, wchar_t**) ()
   from /usr/lib/libwx_baseu-2.8.so.0
#17 0x008d2987 in wxEntry(int&, char**) () from /usr/lib/libwx_baseu-2.8.so.0
#18 0x080c1fdf in ?? ()
#19 0x00c7fb56 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#20 0x0806f711 in ?? ()

ProblemType: Bug
Architecture: i386
Date: Mon Nov 2 08:55:31 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: fglrx
Package: filezilla 3.2.7.2-0ubuntu3
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: filezilla
Uname: Linux 2.6.31-14-generic i686

Robert Hollencamp (rhollencamp) wrote :
Tim Kosse (tim-kosse) wrote :

Do either the filename, the remote path or the remote path contain any non-ASCII characters?

Adrien Cunin (adri2000) on 2010-02-09
Changed in filezilla (Ubuntu):
status: New → Incomplete
Adrien Cunin (adri2000) wrote :

Closing due to lack of answer from the reporter. Please reopen if you have any useful information about this.

Changed in filezilla (Ubuntu):
status: Incomplete → Invalid
PDPCosta (pdpcosta) wrote :

Answerig the question:"Do either the filename, the remote path or the remote path contain any non-ASCII characters?"
NO, it does not.

Changed in filezilla (Ubuntu):
status: Invalid → New

you can find a fix here :

http://easylinuxguide.com/blog/2011/06/16/filezilla-drag-and-drop-crash-fix-ubuntu-natty/

seems to be an old bug between wxWidget/Filezilla

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in filezilla (Ubuntu):
status: New → Confirmed

In Oneiric Ocelot, the bug seems to appear only with Gnome-Shell (see duplicate Bug #858146)

summary: - filezilla segfault drag
+ filezilla crashes on drag'n'drop with Gnome Shell

Also seen with version 3.5.0 in Ubuntu 12.04 pre-alpha.

I first reported this as an occasional bug (#752673) but the crash seems to happen all the time now.

tags: added: oneiric precise
summary: - filezilla crashes on drag'n'drop with Gnome Shell
+ filezilla crashes on drag'n'drop
Matthew Bender (quartarian) wrote :

Just a clarification to Christophe Braud's post, I was able to fix the bug by using the instructions provided here: http://wiki.wxpython.org/InstallingOnUbuntuOrDebian, however I had used Natty as the distribution code even though im on oneiric.

Paul White (paulw2u) wrote :

I've just installed the following packages in Precise:

libwxbase2.8-0_2.8.12.1-6ubuntu1_i386.deb
libwxgtk2.8-0_2.8.12.1-6ubuntu1_i386.deb

and the problem now seems to be fixed when using Gnome Shell.

fasoi (miquel6) wrote :

I'm still getting the segmentation fault after followng the installation commented on http://wiki.wxpython.org/InstallingOnUbuntuOrDebian
I've installed the oneiric and natty packages, on Ubuntu 11.10 64 bits (with gnome 3), and still doesn't work

fasoi (miquel6) wrote :

I've downloaded the latest development version of xwPython (2.9.3.1) and I'm still facing the same issue

Tim Kosse (tim-kosse) wrote :

wxWidgets 2.8 and 2.9 are incompatible, the latter being the development version of what will eventually become wxWidgets 3.0

You need to update to the most recent 2.8.x version, 2.8.12 or higher.

Richard Ayotte (rich-ayotte) wrote :

Old habbits die hard. I was so used to firing up Fillezilla that I forgot how good Nautilus was at accomplishing the task. Thanks Nautilus, one less app to install and learn.

Mauro (jasmines) wrote :

It depends on wxwidgets version. You should install 2.8.12, instead of 2.8.11 provided in Oneiric official repos.
Find the source on http://wxwidgets.org/ (you'll have to compile it by yourself) or type the following in a terminal:

sudo add-apt-repository ppa:n-muench/programs-ppa
sudo apt-get update
sudo apt-get upgrade

Enjoy!

Paul White (paulw2u) on 2012-03-12
tags: removed: precise
Adrien Cunin (adri2000) wrote :

Marking as fixed as FileZilla is built against wxWidgets 2.8.12 in Precise.

Changed in filezilla (Ubuntu):
status: Confirmed → Fix Released
importance: Undecided → Medium
Emeric Vigier (emeric-vigier) wrote :

There is no oneiric folder in http://apt.wxwidgets.org/dists/ then instructions from http://wiki.wxpython.org/InstallingOnUbuntuOrDebian are not useful for Ubuntu-11.10 oneiric.
The bug was tagged "oneiric". Why then has it been turned to "fixed released"? I know oneiric is not LTS...
So what is the status of this bug on oneiric (apart from https://bugs.launchpad.net/ubuntu/+source/filezilla/+bug/470799/comments/15)? Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers