Ubuntu

file-roller crashed with SIGABRT in __libc_message()

Reported by Hewerson Alves Freitas on 2012-04-11
306
This bug affects 47 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
High
Unassigned
Quantal
High
Unassigned

Bug Description

Impact:
It's not possible to extract archives in a specific location, the code segfaults

Test Case:
- wget http://ftp.acc.umu.se/pub/GNOME/sources/gedit/3.6/gedit-3.6.2.tar.xz
- run "file-roller --extract-to /tmp/debug gedit-3.6.2.tar.xz"
- ls /tmp/debug

the archive should be properly unpacked in the destination dir

Regression potential:
Check that archives get correct unpacked still, from nautilus and from the command line

StacktraceTop:
 __libc_message (do_abort=2, fmt=0x7f16e8822050 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=3, str=0x7f16e881f001 "free(): invalid pointer", ptr=<optimized out>) at malloc.c:5007
 gtk_file_system_model_finalize (object=0x23b88f0) at /build/buildd/gtk+3.0-3.4.0/./gtk/gtkfilesystemmodel.c:1008
 g_object_unref (_object=0x23b88f0) at /build/buildd/glib2.0-2.32.0/./gobject/gobject.c:3018
 stop_loading_and_clear_list_model (impl=0x235e290, remove_from_treeview=0) at /build/buildd/gtk+3.0-3.4.0/./gtk/gtkfilechooserdefault.c:6654

Changed in file-roller (Ubuntu):
importance: Undecided → Medium
summary: - file-roller crashed with SIGABRT in raise()
+ file-roller crashed with SIGABRT in __libc_message()
tags: removed: need-amd64-retrace
tags: added: quantal running-unity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
visibility: private → public
affects: file-roller (Ubuntu) → gtk+3.0 (Ubuntu)
tags: added: bugpattern-needed

Occurs when using the "Extract Here" option in thunar on my xubuntu 12.10 install
the files are not extracted
If i use "Extract To" it works then crashes
100% reproduction rate

  ~$ file-roller -v;echo ------;cat /etc/lsb-release
  file-roller 3.6.0, Copyright © 2001-2012 Free Software Foundation, Inc.
  ------
  DISTRIB_ID=Ubuntu
  DISTRIB_RELEASE=12.10
  DISTRIB_CODENAME=quantal
  DISTRIB_DESCRIPTION="Ubuntu 12.10"

Julien Lavergne (gilir) wrote :

Also confirmed using pcmanfm with the command "Extract here" too.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gtk+3.0 (Ubuntu):
importance: Medium → High
affects: gtk+3.0 (Ubuntu) → ubuntu
Sebastien Bacher (seb128) wrote :

in fact it looks similar to bug #958382

affects: ubuntu → gtk+3.0 (Ubuntu)
bwat47 (bwat47) wrote :

Same problem here with a fresh install of xubuntu 12.10.

Geert Jan Alsem (gj-alsem) wrote :

I also have this problem in Xubuntu 12.10. Installing file-roller 3.6.1.1-0ubuntu1 from the "proposed" repository does not fix this bug.

Geert Jan Alsem (gj-alsem) wrote :

For those that just want to have a working "Extract Here" option in Thunar, I posted a manual fix in bug 1038336.

another workaround is to downgrade file-roller
http://packages.ubuntu.com/precise/file-roller#pdownload
just don't forget to lock the package in synaptic and in dpkg
echo "file-roller hold" | sudo dpkg --set-selections

downgrading fixed all the file roller issues for me (crashes and over sized .tar.bz2 files)

Maarten Baert (maarten-baert) wrote :

The bug appears to be caused by calling g_free instead of _g_object_unref. Just changing that one line fixed it for me. It only happens when 'extract-to' is set, because otherwise the pointer is simply NULL.

The attachment "patch for src/main.c" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

@Maarten: thanks for the patch, that's one for file-roller and not gtk right? Do you have a testcase to reproduce the issue and confirm the fix then?

affects: gtk+3.0 (Ubuntu) → ubuntu
Maarten Baert (maarten-baert) wrote :

Yes, it's for file-roller. I don't think there's anything wrong with gtk itself. The test I used was simply:

file-roller --extract-to=/tmp archive.zip

The zip file can be anything, it doesn't even have to exist to trigger the crash.

bwat47 (bwat47) wrote :

Maarten, yeah does seem to be a file-roller bug. Upstream reports it fixed in a dev version: https://bugzilla.gnome.org/show_bug.cgi?id=686321

Changed in file-roller:
importance: Unknown → Medium
status: Unknown → Fix Released
affects: ubuntu → file-roller (Ubuntu)
Changed in file-roller (Ubuntu Quantal):
importance: Undecided → High
status: New → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.6.2-0ubuntu2

---------------
file-roller (3.6.2-0ubuntu2) raring; urgency=low

  * debian/patches/git_extract_segfault.patch: don't segfault when
    using --extract-to, thanks Maarten Baert (lp: #978789)
  * debian/patches/git_extract_progress_fix.patch:
    - backport another patch to complete the previous commit
 -- Sebastien Bacher <email address hidden> Fri, 16 Nov 2012 15:57:49 +0100

Changed in file-roller (Ubuntu):
status: Confirmed → Fix Released

Hello Hewerson, or anyone else affected,

Accepted file-roller into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/file-roller/3.6.1.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in file-roller (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Sami Jaktholm (sjakthol) wrote :

Package in proposed fixes this problem.

tags: added: verification-done
removed: verification-needed

I can also confirm what sampo555 just said

Ioannis Vranos (cppdeveloper) wrote :

Work around that works:

Install the package xarchiver.

Then go to File Manager's (PCManFM) Preferences->Advanced->Archiver integration, and select "xarchiver".

Travis Knight (dick-swift00) wrote :

file-roller into quantal-proposed: confirmed working. Thanks!

bwat47 (bwat47) wrote :

Build in proposed working fine here as well.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.6.1.1-0ubuntu1.1

---------------
file-roller (3.6.1.1-0ubuntu1.1) quantal-proposed; urgency=low

  * debian/patches/git_extract_segfault.patch: don't segfault when
    using --extract-to, thanks Maarten Baert (lp: #978789)
  * debian/patches/git_extract_progress_fix.patch:
    - backport another patch to complete the previous commit
 -- Sebastien Bacher <email address hidden> Fri, 16 Nov 2012 15:57:49 +0100

Changed in file-roller (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.