File-Roller should suggest or recommend p7zip-full package for WIM, SWM and other archive formats support and add ".wim, .swm" to package description

Bug #918107 reported by Mantas Kriaučiūnas on 2012-01-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Baltix
Medium
Mantas Kriaučiūnas
file-roller (Ubuntu)
Wishlist
Unassigned

Bug Description

p7zip-full package has the ability to extract Windows Imaging Format (.wim, .swm) files and other archive formats, which are unsupported by other utilities (see const char *sevenz_mime_type from http://git.gnome.org/browse/file-roller/tree/src/fr-command-7z.c file).
File-Roller package should suggest or recommend p7zip-full package for WIM, SWM and other archive formats support.

Also it would be nice if file-roller package description would mention WIM, SWM and CBR support - please add a lines
* Windows Imaging Format (.wim, .swm)
* ZIP Archived Comic Book (.cbz)
 into Description field of debian/control.in file (rpm packages already has this line, see http://git.gnome.org/browse/file-roller/tree/file-roller.spec.in )

Related branches

Mantas Kriaučiūnas (mantas) wrote :

Also it would be nice if file-roller could automatically install p7zip-full package when user tries to open Windows Imaging Format (.wim, .swm) files - then Ubuntu users will not be forced to ask such questions or search answers:
http://askubuntu.com/questions/34474/how-do-i-handle-wim-image-files

Sebastien Bacher (seb128) wrote :

The oneiric and precise versions of file-roller are supposed to install softwares required to open formats when those are not installed but maybe it's buggy in that case...

Changed in file-roller (Ubuntu):
importance: Undecided → Wishlist
summary: File-Roller should suggest or recommend p7zip-full package for WIM, SWM
- and other archive formats support and add
+ and other archive formats support and add ".wim, .swm" to package
+ description
Changed in baltix:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Mantas Kriaučiūnas (mantas)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.9.90-0ubuntu1

---------------
file-roller (3.9.90-0ubuntu1) saucy; urgency=low

  * Sync with Debian. Remaining changes:
    - Depend on zip and unzip instead of p7zip which is in universe
    - Suggest p7zip-full (LP: #918107)
    - Recommend sessioninstaller
  * Dropped change:
    - Use the Ubuntu epoch for the Nautilus depends (Ubuntu 11.10
      and newer include Nautilus 3.0 or higher)
  * New upstream release
    - Restore directory modification time when extracting (LP: #1076716)
    - Allow viewing the password when creating an encrypted archive
      (LP: #772556)
    - Avoid unnecessary word break when wrapping text to new lines
      (LP: #1193921)
  * debian/patches/revert_gtk_3-9.patch:
    - Revert commit that requires GTK 3.9 since GTK 3.9 won't be in Saucy
  * debian/control.in, debian/rules:
    - Run dh-autoreconf for above patch

file-roller (3.8.4-1) unstable; urgency=low

  * New upstream release.
  * Bump Standards-Version to 3.9.4. No further changes.

file-roller (3.8.3-1) unstable; urgency=low

  * New upstream release.

file-roller (3.8.2-1) unstable; urgency=low

  * New upstream release.
  * Upload to unstable.

file-roller (3.8.0-1) experimental; urgency=low

  [ Thomas Bechtold ]
  * New upstream release.

file-roller (3.7.92-1) experimental; urgency=low

  * New upstream release.
  * Drop debian/patches/git_handle_cab.patch, from upstream now in release.
  * Bump libgtk-3-dev build-dependency to (>= 3.6.0)
    - source uses GtkMenuButton which is new in 3.6
 -- Jeremy Bicha <email address hidden> Mon, 26 Aug 2013 10:16:27 -0400

Changed in file-roller (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers