Unable to open xpi files

Bug #899881 reported by Antoine Turmel on 2011-12-04
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Low
Unassigned
Oneiric
Low
Unassigned

Bug Description

Since Ubuntu 11.10 Oneiric, I can't open xpi files with file-roller.

I have an error that the file is not recognized. One way around is to rename the filename and change .xpi by .zip

I think this could be a mimetype issue, since it could be resolved adding .xpi extension to zip mimetype.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, why should .xpi files open in file-rollers? shouldn't they be send to firefox by default?
could you add an example to the bug?

Changed in file-roller (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Antoine Turmel (antoineturmel) wrote :

@seb128
Because xpi are basically zip archives and some developers/translators use file-roller to extract/modify files inside.
Also xpi files are not used only by Firefox, but by many Mozilla-based product like Thunderbird, Instantbird, Songbird...

Sebastien Bacher (seb128) wrote :

the issue seems a bit similar to bug #877256

Changed in file-roller (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Mauro (jasmines) wrote :

sudo apt-get install assogiate

run assogiate, find application/zip and add *.xpi in filenames.

Changed in file-roller (Ubuntu):
status: Confirmed → Fix Committed
Changed in file-roller:
importance: Undecided → Unknown
status: New → Unknown
Changed in file-roller (Ubuntu Oneiric):
importance: Undecided → Low
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.3.3-0ubuntu2

---------------
file-roller (3.3.3-0ubuntu2) precise; urgency=low

  * debian/patches/git_mime_type.patch: get the correct mime type values,
    should fix .apk, .war, .xpi opening (lp: #868581, #877256, #899881)
 -- Sebastien Bacher <email address hidden> Wed, 08 Feb 2012 19:09:35 +0100

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Changed in file-roller:
importance: Unknown → Medium
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

I've uploaded a stable updated for oneiric as well, it should be available for testing in the next days, the bug will be updated when that happens

Vadim Rutkovsky (roignac) wrote :

Fix confirmed in precise 3.3.3-0ubuntu2

Hello Antoine, or anyone else affected,

Accepted file-roller into oneiric-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.2.1-0ubuntu2

---------------
file-roller (3.2.1-0ubuntu2) oneiric-proposed; urgency=low

  * debian/patches/git_mime_type.patch: get the correct mime type values,
    should fix .apk, .war, .xpi opening (lp: #868581, #877256, #899881)
 -- Sebastien Bacher <email address hidden> Wed, 08 Feb 2012 19:28:18 +0100

Changed in file-roller (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.