Archive Manager fails to handle password-protected ZIP files

Bug #885146 reported by Stuart Shelton on 2011-11-02
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
Low
Unassigned

Bug Description

Upon trying to open a password-protect ZIP file in Archive Manager/file-roller, I'm correctly prompted for a password. However, on pressing enter/clicking "OK", I then get an error dialog stating:

An error occurred while extracting files.
> Command Line Output
error: must give decryption password with -P option

... on trying again without quitting file-roller, I'm not prompted for a password - it simply shows the same dialog. If I deliberately enter the *wrong* password, then the "Password required" dialog immediately re-opens - so it's not a mis-typed password issue.

$ lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

$ apt-cache policy file-roller
file-roller:
  Installed: 3.2.1-0ubuntu1
  Candidate: 3.2.1-0ubuntu1
  Version table:
 *** 3.2.1-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     3.2.0-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

Stuart Shelton (srcshelton) wrote :

Other files succeed, though. Two thoughts about the password for the problematic file:

* It started with a hypen;
* It contained a "<" character.

... so is this a case of insufficient quoting/guarding?

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, it could be a quoting issue yes, does "unzip" on a command line deal with that file correctly? Could you add an example to the bug?

Changed in file-roller (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Krzysztof Kosinski (tweenk) wrote :

I encountered this bug on Ubuntu 15.10. It can be solved by installing the package p7zip-full. It occurred when I tried to extract a password-protected file which I created on another computer with Ubuntu 14.04 LTS.

The messages from command-line 'unzip' are:

skipping: (file name) need PK compat. v5.1 (can do v4.6)
skipping: (file name) need PK compat. v5.1 (can do v4.6)
skipping: (file name) need PK compat. v5.1 (can do v4.6)
etc.

The main problem here is that the error message returned by Archive Manager is not helpful at all.

Tero Gusto (tero-gusto) wrote :

I can confirm that installing p7zip-full fixes this problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers