Ubuntu

x.org lockup after dragging archived file to desktop (lxde)

Reported by Serdar on 2011-10-20
196
This bug affects 39 people
Affects Status Importance Assigned to Milestone
PCManFM
Unknown
Unknown
file-roller (Ubuntu)
High
Unassigned
Precise
High
Unassigned
libfm (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Impact:
dnd files can drop the pointer in drag mode and block the user out of the running session

Test Case:
- start a lubuntu session
- open an archive in file-roller
- try to extract a file with a drag and drop to the dektop.
- Whole system freezes every single time.

Regression potential:
drag and drop could be broken

Serdar (bluebasstrb) wrote :
baltasarq (baltasarq) wrote :

I confirm this bug, which is probably a duplicate of bug #884503. This bug is extremely annoying, since not only file-roller gets frozen, but the entire desktop.

The only workaround that I found was to press alt-f1 in order to get tty1, login, type "ps aux | grep file-roller" and kill the process (kill -9 pid_of_file_roller).

It it curious that anyway file-roller id not killed, but anyway, everything comes responsive again.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, does it happen with any file? what do you dnd exactly? to where? I can't confirm the issue there...

Changed in file-roller (Ubuntu):
importance: Undecided → High
Walter Lapchynski (wxl23) wrote :

Ok, just for grins, I loaded up Firefox, clicked on http://archive.ubuntu.com/ubuntu/pool/main/f/file-roller/file-roller_3.2.1.orig.tar.bz2 and let it open in file-roller. When it did, I clicked on and dragged the contents and dragged it to the desktop and this was the result.

Pedro Villavicencio (pedro) wrote :

Walter and you get the system hang after that? I cannot seem to reproduce the issue here. If you don't get any hang then that's not the same issue you're commenting on.

Walter Lapchynski (wxl23) wrote :

Yep, that's the point, Pedro. I've done it time and time again. I put in my two cents because this was brought to my attention by others with the same problem in #lubuntu on Freenode.

Edward Jiang (edwardrf) wrote :

I would like to confirm this bug too.

Thinkpad X200, lubuntu 11.10

Whole X desktop freezed after DnD is done from file roller with an error message complaining about the permission:

'You do not have the right permissions to extract archives in the folder "" '

Serdar (bluebasstrb) wrote :

Thanks Edward for your comment , I forgot to mention that error message.

"You do not have the right permissions to extract archives in the folder ".

baltasarq (baltasarq) wrote :

I decided to experiment a little, since this error is annoying.

I downloaded the last version of file-roller, 3.3.2, in source code form, unzipped it and build it.

$ cd file-roller-3.3.2
$ ./configure
$ make

Then I copied the executables in src to the following locations:

$ cd src
$ sudo cp file-roller /usr/bin
$ sudo cp file-roller-server /usr/lib/file-roller/

And now everything works as a charm. Drag & Drop is fully functional again. I know I should not install binaries this way, though this error is so annyoing, and has been unattended for so long as well, that I think that yes, it is justified.

So, the fix to the problem is to pack and the distribute the last file-roller.

Sebastien Bacher (seb128) wrote :

is anyone getting the issue under GNOME or Unity or is the issue specific to lubuntu?

I have not tried this on my Ubuntu but I can also confirm that this is an issue on Lubuntu. I'll test this later on Unity.

LittleHorror (littlehorror) wrote :

Similar thing happens with file-roller/pcmanfm combination (XFCE). As soon as mouse enters pcmanfm boundaries — error message appears and desktop stops responding (however, all applications continue to work, although nothing can be pressed/closed etc).

Corentin SCHREIBER (cschreib) wrote :

I tried baltasarq's solution and compiled file-roller 3.3.3 from source as well, but it didn't solve the problem for me.
Why is it that you install your binaries this way instead of using 'sudo make install' ? Is it supposed to change anything (I used sudo make intall) ?

kjoe (kjoe) wrote :

I also confirm this bug.

In lubuntu 11.10 my workaround to "fix" it was to install nautilus. Then I could drag files from an archive (opened with file-roller) to a nautilus window. But it still crashed, if I dragged the file to the lubuntu desktop (which means pcmanfm, right?). So the reason for the bug seams to be related to nautilus dependencies. Maybe this information is helpful.

And this bug is still present in the latest daily build of Lubuntu 12.04 Precise Pangolin (as of Feb 17th 2012) tested as live CD in virtualbox.

Sebastien Bacher (seb128) wrote :

So the comment suggest the issue is mostly hitting lubuntu users and pcmanfm, the bug doesn't happen with nautilus which let to think that pcmanfm handles dnd targets in a buggy way...

Changed in pcmanfm (Ubuntu):
importance: Undecided → High
status: New → Confirmed
summary: - When I try to extract file by just drag and drop by mouse, everything
- freezes
+ extracting file by dnd leads to freeze for non nautilus users
Changed in file-roller (Ubuntu):
status: Confirmed → Incomplete

Hey I have same problem with Lubuntu 11.10

I try drag n drop files in the archive to a folder in pcmanfm and I get and error about not having right permission to extract to folder, and the desktop freezes up. The extract button works fine. Also installed Thunar file manager and the drag and drop works fine.

kjoe (kjoe) wrote :

As expected, the bug is still present in Lubuntu 12.04 beta1 (desktop i386). I tested it today in live-cd mode using virtualbox.

But there is another thing that may be helpful to decide, whether pcmanfm or file-roller are causing the problem:
when I installed Xarchiver and dragged a file from an archive to the desktop, sometimes the programme also crashes right in the moment when crossing the border of the Xarchivers window. But this is not freezing the whole system (like in the case when using file-roller).

So Sebastien, you're probably right the "bad guy" may be pcmanfm.

karl anliot (kanliot) on 2012-03-03
summary: - extracting file by dnd leads to freeze for non nautilus users
+ x.org lockup after dragging archived file to desktop

looking at the stack trace, it's obvious that this is another GTK+ 3 bug.
sorry again.

karl anliot (kanliot) wrote :

right now there's no clear way to see if the problem is with file roller or pcmanfm. In fact, on systems, x.org doesn't crash.

kjoe (kjoe) wrote :

Is it just about permissions?

Can anyone of you guys confirm the following successful dnd action?

1) Place an archive on your desktop (i.e. named as 'archive.tar.gz')
2) Open a terminal and cd right to the desktop
3) Type: sudo file-roller archive.tar.gz
4) Then drag and drop to the desktop

This worked in my case.
But it did not work, when I only started file-roller as root and opened the archive.tar.gz from within the programs user interface.

karl anliot (kanliot) wrote :

i've tested kjoes workaround. does not work.

kjoe (kjoe) wrote :

You are right, karl. I have also tested it using lubuntu-12.04-beta2-desktop-i386.iso in virtualbox and I did not succeed.
Then I kept on trying and found another weired 'solution' that worked:

1) Start Lubuntu-12.04-beta2.iso using virtualbox (I did not test it yet on real hardware)
2) Place an archive on your desktop (i.e. named as 'archive.tar.gz')
3) Open a terminal
4) Type: sudo file-roller ~/Desktop/archive.tar.gz
5) Try drag&drop
6) --> crash ! But no problem
7) Press Alt+F2 to get the "Run application" window
8) Type: killall file-roller
9) Do 4) and 5) again
10) --> success
11) Do it again --> crash
12) Do it again --> success

Also if you keep the archive open after the first successful dnd action, it crashes when you retry dnd.

Isn't that weired?
I don't know what this means, but at least we maybe have something pointing (anyone of us) to the solution of this problem.

kjoe (kjoe) wrote :

Ok. Could repoduce this on my test system which is running a lubuntu-11.10.iso from the harddisk.

The only difference is in step 7) and 8) to regain a functional desktop:

7) Press Ctrl+Alt+F2
8a) Type: killall file-roller
8b) Press Alt+F7

kjoe (kjoe) wrote :

I think that file-roller is not the main problem. And here is the reason why:

I tried to reproduce the bug on a different test system. Downloaded linuxmint-12-lxde-cd-32bit.iso and started it in virtualbox.
Linux Mint LXDE uses a combination of pcmanfm and ( instead of file-roller) the xarchiver as its default archive manager.

When I first dragged a file from within an archive to the desktop, xarchiver crashed (without freezing the system). Then I reopened the archive and this time the dnd action was successful.
Then next time --> crash. Next time --> success. Next time --> crash. Next time --> success. ....

So, every other time, the dnd action crashes the archiver program.

This behaviour is reproducable by file-roller as well as the xarchiver, which IMHO rules out file-roller as the cause for the bug.

Stefan Goldmann (ingo-knietow) wrote :

I'd like to confirm the weird behavior reported by kjoe in posts #23 and #25.

In fact, kjoe, this weird "every second time" behavior seems to happen on a "per target" basis. Try dnd-extracting to target1 (e.g., desktop), target 2 (some folder), target 1, target 2, and so on, without striving the other target with the mouse in between the individual trials (place your windows accordingly).

When I did that, using file-roller, I got "Crash (on target 1), Crash ( on target 2), Success (t1), Success (t2), Crash (t1), Crash (t2)" and so forth.

Can this be confirmed?

Side note: The bug has been reported at pcmanfm bugtracker already (http://sourceforge.net/tracker/?func=detail&aid=3496591&group_id=156956&atid=801864). They indicate that the actual bug is originated within pcmanfm, whereas the X-blocking is due to the way file-roller is handling the error situation. Since there is no X-block when using xarchiver instead of file-roller, this sounds logical to me.

Luigi Calderone (lugligino) wrote :

I tried to reproduce procedure on #23 post but it was impossible do step 8 because space bar doesn't work.
I can go ahead using alf+f4 to quit non functioning processes.

Stefan Goldmann (ingo-knietow) wrote :

Hi Luigi.

Yes, you are right.

Use CTRL+ALT+F2, as described in post #24. Then you should be able to reproduce the bug.

Cristiano Nunes (cfgnunes) wrote :

I have same problem here with Lubuntu 12.04 i386

Cristiano Nunes (cfgnunes) wrote :

Same problem:

Lubuntu 12.04

file-roller:
  Installed: 3.4.1-0ubuntu1

pcmanfm:
  Installed: 0.9.11~bzr523+201205240448~precise1

Stefan Goldmann (ingo-knietow) wrote :

Good news, everyone.

The bug is in fact located within pcmanfm (more precisely, within the GTK library part of, libfm-gtk1), and has been fixed by the author within the git repository of this project 9 days ago.

Since I have not read any further discussion about this bug any more and since I don't know the procedure in such cases, I simply attach a diff that fixed the bug on my computer. The patch needs to be applied against file "src/gtk/fm-dnd-dest.c" in the current source package of libfm-gtk1 of distribution Lubuntu 12.04. Whether the patch works against older versions of Lubuntu I don't know.

Could anyone please try it or let me know the official procedure of providing patches? Perhapse the Lubuntu team is already aware about the bug being fixed and this whole commit is obsolete ... ;-)

Best wishes,
-- Stefan

The attachment "fm-dnd-dest.c.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

Great. The bug seems to be fixed!

I tested the following (using a live CD of Lubuntu 12.04):

1) ctrl + alt + F2
2) sudo service lightdm stop
3) sudo add-apt-repository ppa:lubuntu-dev/lubuntu-daily
4) sudo apt-get update
5) sudo apt-get install pcmanfm
6) sudo service lightdm start

Then I dragged a file from an archive to the desktop. --> No freezing anymore !!

Note: I did not change the file-roller version

Thanks a lot to the developer(s), who fixed this annoing bug.

Paul Miles (w-paul-miles) wrote :

Will this fix be added to Ubuntu 12.04.1?

Changed in file-roller (Ubuntu):
status: Incomplete → Invalid
adam (cohndadam) wrote :

This bug is present in Lubuntu 12.04 and I believe Ubuntu as well hopefully it will be fixed in 12.10.

Changed in pcmanfm (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
importance: Undecided → High
status: New → Triaged
Changed in file-roller (Ubuntu Precise):
status: New → Invalid
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

The issue should be fixed in precise yes, upstream commit to backport:
http://pcmanfm.git.sourceforge.net/git/gitweb.cgi?p=pcmanfm/libfm;a=patch;h=97df3cb809a7398fd99eafcca9dae57b5615a470

Is anyone in the lubuntu team wanting to SRU that fix?

affects: pcmanfm (Ubuntu) → libfm (Ubuntu)
summary: - x.org lockup after dragging archived file to desktop
+ x.org lockup after dragging archived file to desktop (lxde)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libfm - 0.1.17-0ubuntu4

---------------
libfm (0.1.17-0ubuntu4) quantal; urgency=low

  * debian/patches/git_dnd_lock.patch: upstream patch adapated to the current
    version, should fix pointer locks on dnd issues (lp: #878993)
 -- Sebastien Bacher <email address hidden> Thu, 05 Jul 2012 18:02:44 +0200

Changed in libfm (Ubuntu):
status: Confirmed → Fix Released
Changed in libfm (Ubuntu):
status: Fix Released → In Progress
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

uploaded to precise-proposed as well

description: updated
Changed in libfm (Ubuntu Precise):
status: Triaged → In Progress

Hello Serdar, or anyone else affected,

Accepted libfm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libfm/0.1.17-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libfm (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

could somebody using lubuntu or who ran into that issue before confirm the SRU to it can move to precise-updates?

Corentin SCHREIBER (cschreib) wrote :

I tried installing all the .deb packages from https://launchpad.net/ubuntu/+source/libfm/0.1.17-0ubuntu3.1 that have the ubuntu3.1 version (download it all, then sudo dpkg --install *.deb).
Now it works randomly, but still blocks in the very same way most of the time.
Is there something else I should have done ?

Also, I cant seem to be able to downgrade to ubuntu3, as it asks for removal of many important packages such as lubuntu-core, pcmanfm, etc.

Luigi Calderone (lugligino) wrote :

(lubuntu 12.04 precise) I upgraded libfm to 0.1.17-0ubuntu3.1 and, after reboot it worked. Now I can drag & drop zipped files to desktop.

Marco Chiappetta (mardurhack) wrote :

Upgraded all the libfm packages hierarchy to version 0.1.17-0ubuntu3.1. Now it's possible to drag and drop files outside the archive manager window but only if we don't drag the file back inside and outside again.

Test case:
1) Open an archive and drag the file you want to extract outside the archive manager window
2) Drag the file back inside the window
3) Drag again the file outside...
3) Same message appears

Sebastien Bacher (seb128) wrote :

setting to verification-done, the main issue is fixed and if there is no regression there is no reason to block the SRU

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libfm - 0.1.17-0ubuntu3.1

---------------
libfm (0.1.17-0ubuntu3.1) precise-proposed; urgency=low

  * debian/patches/git_dnd_lock.patch: upstream patch adapated to the current
    version, should fix pointer locks on dnd issues (lp: #878993)
 -- Sebastien Bacher <email address hidden> Thu, 05 Jul 2012 18:02:44 +0200

Changed in libfm (Ubuntu Precise):
status: Fix Committed → Fix Released
Corentin SCHREIBER (cschreib) wrote :

I confirm the fix works after reboot. I do not have the issue described by Marco Chiapetta.
However, if you try to drop the files on another file (and not a folder or empty space), then you get the same message but without the mouse block. Expected behavior is to extract the files in the current folder, as if they were dropped on empty space (this is particularly annoying in detailed view, where you have no empty space to drag files to). Maybe this is a pcmanfm problem now ?

Marco Chiappetta (mardurhack) wrote :

Sorry guys I didn't realize I installed i386 packages on a x86_64 installation of Lubuntu. Anyway I've just reinstalled them on a 32bit system and now everything works fine. I'm not experiencing any kind of errors and I'm free to move the dragged file wherever I want without causing anything "weird" (even on files, of course without dropping it, otherwise a simple "Extraction not performed" error appears but I can close it and drag the file again).

Thank you very much :) Sorry for the initial mistake!

Cristiano Nunes (cfgnunes) wrote :

This bug is back on lubuntu 13.04.

Sebastien Bacher (seb128) wrote :

> This bug is back on lubuntu 13.04.

open a new bug rather than commenting on a bug closed for almost a year

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.