file-roller problems when extracting rar files within windows-1256 encoded arabic files

Bug #769488 reported by ha el rai on 2011-04-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
File Roller
Unknown
Unknown
file-roller (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: file-roller

Here my problem

i have a rar file within I've many Arabic titled files "look picture below" this file is created under windows

now I'm using Ubuntu 10.10 for x64 arch the software used is file roller 2.32.0 for Gnome

and my files' titles look like this
http://img38.imageshack.us/img38/9226/encoding.png

when i use the unrar command in terminal to extract files i got arabic titled files but when i use file roller i still have a bad file names
and i need a gui application to do this i dont want go to terminal each time i want to extract arabic files encoded under windows thank you very much

ref. this subject on ubuntuforums really helped me to understand the problem
http://ubuntuforums.org/showthread.php?p=10710105#post10710105

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: file-roller 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Apr 23 14:51:44 2011
ExecutablePath: /usr/bin/file-roller
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007.1)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: file-roller

ha el rai (haelrai) wrote :
wijit (awijit) wrote :

Hi,
This may help identification of the problem. My problem is that file-roller on DELL cannot display Windows based CTL (Windows-874) filenames of files that reside in an archive correctly. unrar works fine in terminal on both computers. Also file-roller on ACER shows all filenames inside an archive correctly. Both computers run on and take most use of Lucid where their configurations are controlled to be the same as much as possible. Followings are known differences that a non-technical like me can analyse.
1. While OS version is the same but a 64bit version was installed on DELL while a 32bit was on ACER. All software on both computers are updated to the latest patches.
2. Apart from Ubuntu, there is a partition of Windows XP on ACER but DELL relies purely on Ubuntu.
3. Both computers run the same version of file-roller.
4. ACER has unrar 1:3.9.3-1 (non-free) installed while DELL has unrar-free 1:0.0.1+cvs20071127-1 installed but was already removed and replaced by the same version as ACER.
5. Both computers have msttcorefonts installed.
Please tell me how to get it if you want more technical information.
I sent this issue to the bugmaster of bugzilla.gnome.org but they suggested me to find the bug fixs on the website. There is one bug report, Bug 629202, seems to be similar to mine but providing no solution except suggestion to send the bug to Launchpad. That's why I'm here.
Thanks for attention.
Yours
Wijit.

wijit (awijit) wrote :

I just came here to follow up my co-report and found that the link underneath the bug number 629202 points to within launchpad which is not correct. The number belongs to bugzilla.gnome.org. In case this may interest you:
https://bugzilla.gnome.org/show_bug.cgi?id=629202 is the url and tag to take you to the report.

Ma Hsiao-chun (mahsiaochun) wrote :

What's your version of "rar" and "unrar"?

"rar" in Ubuntu repo is broken for recent versions.
Not sure about 10.10, though.

File-roller is just a frontend.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Mathew Hodson (mathew-hodson) wrote :

Reported fixed upstream.

Changed in file-roller:
importance: Undecided → Unknown
status: New → Unknown
Changed in file-roller (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.