Zip compression fails if there is a file with a specific file name

Bug #671691 reported by mateamargo on 2010-11-06
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Low
file-roller (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: zip

Ubuntu version: 10.04 32 bits
package: zip (3.0-3)

Problem:

Zip compression fails with the mesasge "zip error: Invalid command arguments (short option '_' not supported)" if there is a file with the following name:

-_file.txt

The key is the slash and the underscore together in the beginning of the file name.

This happens with the command line utility and using File Roller too.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: evince 2.32.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.35-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Fri Nov 5 21:49:43 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: evince

Related branches

mateamargo (mateamargo) wrote :
Dmitri Bachtin (damg) wrote :

Try
zip file.zip -- -_file.txt
-- tells zip to stop parsing further options and take the values as they come. Unfortunately, the name of the target archive must come before --.

Dmitri Bachtin (damg) wrote :

Additionally you can escape the filenames (including the target archive name) with a ./ .

That's not a bug in zip, but ambiguity between commmand-line options and file names. As of File Roller -- it should probably avoid the ambiguities by escaping the file names as said before.

Dmitri Bachtin (damg) wrote :

To be verified whether file-roller is affected. As for zip, there are workarounds.

affects: zip (Ubuntu) → file-roller (Ubuntu)
Dmitri Bachtin (damg) on 2011-01-11
Changed in file-roller (Ubuntu):
status: New → Confirmed
Dmitri Bachtin (damg) wrote :

Please find attached an one-liner patch which fixes this bug. I will commit the patch to upstream in the next few days.

Changed in file-roller (Ubuntu):
status: Confirmed → In Progress
tags: added: patch
Julien Lavergne (gilir) wrote :

Thank you for your bug report and your patch. Did you report the patch upstream yet ? It will be interesting to have upstream opinion on this patch.

Dmitri Bachtin (damg) wrote :

I've submitted a short bug report to gnome with a back-link to this report now.

Bug watch added.

https://bugzilla.gnome.org/show_bug.cgi?id=639664

Julien Lavergne (gilir) wrote :

Thanks, I'll set this bug report as "Triaged", waiting for upstream feedback.

Changed in file-roller (Ubuntu):
status: In Progress → Triaged
importance: Undecided → Low
Changed in file-roller:
importance: Unknown → Low
status: Unknown → New
Changed in file-roller:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 2.32.1-0ubuntu2

---------------
file-roller (2.32.1-0ubuntu2) natty; urgency=low

  * debian/rules:
   - Enable packagekit support (LP: #148084)
  * debian/control
   - Recommends sessioninstaller | packagekit.
   - Depends on genisoimage to fix support for iso archive by default
     (LP: #689317)
  * debian/patches/90_hyphen_archive_creation.patch
   - From upstream, fix archive creation with an hyphen in the name
     (LP: #671691)
 -- Julien Lavergne <email address hidden> Fri, 14 Jan 2011 22:46:35 +0100

Changed in file-roller (Ubuntu):
status: Triaged → Fix Released

It seems the patch introduced a regression: unzipping archives in Natty with file-roller fails with "caution: filename not matched: --" (bug #705698).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.