Editing files in file-roller causes data loss

Bug #61878 reported by kuhi on 2006-09-22
4
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: file-roller

When editing files in file-roller changes can be lost.

How to reproduce:

1. Double click zip file in nautilus (create one text file and archive it if needed)
2. Double click file in file-roller to open it up in an editor
3. Make some changes in file
4. Save changes (do not save in another folder)
5. Close editor and file-roller

Now changes will be effectively lost and cannot be retrieved back anymore.

Fix proposal:
Remove user write access on temporary directory created by file-roller (in /tmp directory)

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That is known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=109767, I've forwarded your comment

Changed in file-roller:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in fileroller:
status: Unknown → Confirmed
Changed in file-roller:
status: Confirmed → Triaged
Pedro Fragoso (ember) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Hardy Heron in the package file-roller 2.21.1-0ubuntu1.

Changed in file-roller:
status: Triaged → Fix Released
Changed in fileroller:
status: Confirmed → Fix Released
Changed in file-roller:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.