ZIP archives with non-ASCII filenames cannot survive a round-trip in File Roller (when p7zip is not installed)

Bug #592109 reported by Santi on 2010-06-10
176
This bug affects 38 people
Affects Status Importance Assigned to Milestone
File Roller
Unknown
Critical
file-roller (Ubuntu)
Critical
Unassigned

Bug Description

If you have any accented characters in file names inside a compressed file, you'll get invalid encoding errors when you're decompressing the file

Oleg Koptev (koptev-oleg) wrote :

That's the bug in file-roller itself.

Changed in ubuntu-translations:
status: New → Invalid
Changed in file-roller:
status: Unknown → Confirmed
Pedro Villavicencio (pedro) wrote :

opening a task for the ubuntu package since it affects that as well.

Changed in file-roller (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in file-roller:
importance: Unknown → Critical
Mahendra Tallur (mahen) wrote :

This issue still occurs as of Maverick Beta (09/22/2010) + File Roller 2.31.92

Changed in file-roller:
status: Confirmed → Unknown
Xavier Guillot (valeryan-24) wrote :

Hello,

Bug still present in Ubuntu Natty 11.04.3 with File-Roller 2.32.2

Problem with accents on letters like é (very used in french).

Compressing works well, but opening the file zipped does not work and I get error message, example for file Intérim.pdf :

caution: filename not matched: Int\?\?rim.pdf

Tested also on Oneiric alpha with File-Roller 3, it works fine, so bug seems corrected In Gnome 3, but for LTS users of Natty, could be great to patch it.

Hello . i've got that bug in Precise 12.04 am64 all updates/upgrades done ... the bug occurs when I try to use unzip in CLI too : Other Bug report found correponding to my situation I think : https://bugzilla.gnome.org/show_bug.cgi?id=619116

summary: - File-roller invalid encoding errors filenames when you're decompressing
+ ZIP archives with non-ASCII filenames cannot survive a round-trip in
+ File Roller (when p7zip is not installed)
Ma Hsiao-chun (mahsiaochun) wrote :

As I mardek quite a few bugs as duplicate of this one. I'd mention that there is a simple workaround, install p7zip.

The bug is caused by zip/unzip stack provided by Info-Zip. In particular, zip(1) seems to have no problem creating a ZIP archive with non-ASCII file name; the encoding used is UTF-8. However, unzip(1) just refuse to list any non-ASCII printable character in filenames.

As FIle Roller use zip/unzip as one of its backend for ZIP, the same issue can be seen in File Roller.

When p7zip is installed, File Roller would use it as backend for ZIP instead. Therefore, to hide the problem from end users, we may let file-roller depends on p7zip so that we can guarantee that we have a working ZIP stack.

Adolfo Jayme (fitojb) on 2013-04-14
no longer affects: ubuntu-translations
Changed in file-roller (Ubuntu):
importance: Low → Critical
Pilot6 (hanipouspilot) wrote :

It is not that simple as it seems in post#6.

For a couple of years there is a workaround for Cyrillic languages a patched unzip. But the problem is that if p7zip-full is installed, file-roller always uses it as a backend and there is no way to switch it to unzip. This cuses that Russian users can't install p7zip-full to work normally with archives.

Ma Hsiao-chun (mahsiaochun) wrote :

Hi, Pilot6.

The problem you described is bug 495880.

Ma Hsiao-chun (mahsiaochun) wrote :

This should be fixed for 12.04+ now, please refer to bug 1199239

Changed in file-roller (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.