"Split in volumes" option is grayed out

Bug #513244 reported by Pétur Ingi Egilsson on 2010-01-27
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
File Roller
Invalid
Medium
file-roller (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: file-roller

Open up file-roller
File -> new
Expand |> Other Options
Change the Archive Type from Automatic to any value.

Other Options is now grayed out, unable to change the settings.
I tried settingthe Archive Type back to Automatic, no luck.

ProblemType: Bug
Architecture: i386
Date: Wed Jan 27 14:16:54 2010
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/file-roller
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
NonfreeKernelModules: nvidia
Package: file-roller 2.28.1-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_DK.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: file-roller
Uname: Linux 2.6.31-17-generic i686

Pétur Ingi Egilsson (petur) wrote :
Pedro Villavicencio (pedro) wrote :

with which kind of compress utility? rar, zip, 7z, etc? Thanks.

Changed in file-roller (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Pétur Ingi Egilsson (petur) wrote :

Follow the steps:

Open up file-roller
File -> new
Expand |> Other Options
Change the Archive Type from Automatic to any value.
Other Options is now grayed out, unable to change the settings.

Pedro Villavicencio (pedro) wrote :

works fine here, not confirming.

Pétur Ingi Egilsson (petur) wrote :

I tried this on another Ubuntu 9.10 workstation, i have the same problem over there...

Pétur Ingi Egilsson (petur) wrote :

Attached is a .ogv video showing the bug.
Notice how the "split" option gets disabled once i change the file format.

Pedro Villavicencio (pedro) wrote :

not confirming it works fine here. setting it back to new.

Changed in file-roller (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME . Thanks in advance!

Pedro Villavicencio (pedro) wrote :

Still an issue on Lucid?

Changed in file-roller (Ubuntu):
status: New → Incomplete
Pétur Ingi Egilsson (petur) wrote :

No, works ok on Lucid.

BUT! there's a new problem.

Right click on any file -> compress
click >Other Options
[]Split into volumes.. is greyed out no matter what kind of a compress i choose.

Pedro Villavicencio (pedro) wrote :

That also works fine here, may you please send this upstream since you're experiencing the problem? You can do that following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME . Thanks in advance!

paoletto (paoletto) wrote :

Here it's greyed out too

paoletto (paoletto) wrote :

update: it works with rar and 7z , after i installed them

Launchpad Janitor (janitor) wrote :

[Expired for file-roller (Ubuntu) because there has been no activity for 60 days.]

Changed in file-roller (Ubuntu):
status: Incomplete → Expired
Colan Schwartz (colan) wrote :

I'll look into reporting this upstream.

summary: - Split in volumes - option gets grayed out.
+ "Split in volumes" option is grayed out
Changed in file-roller (Ubuntu):
status: Expired → Confirmed
Changed in file-roller:
importance: Unknown → Medium
status: Unknown → New
Neill_R (neill-rutherford) wrote :

I still have this problem in 12.04. 18-08-2012 (Pétur Ingi Egilsson (petur) wrote on 2010-01-27: )

Please give workaround until you can have it fixed. Why is this considered a low priority? Surely Low priority does not mean NO priority. NAUTILUS 3.4.2

Dario Corsi (dareios) wrote :

Same problem, but seeing this report:
https://bugs.launchpad.net/ubuntu/+source/file-roller/+bug/276496

I added the missing p7zip package and now for .7z compression the splitting works.
Right now I don't know if this feature is supported only by p7zip backend and for .7z compression. Please explain more details. Thanks.

Changed in file-roller:
status: New → Invalid
Sasa Paporovic (melchiaros) wrote :

Imported from dublicate:

https://bugs.launchpad.net/ubuntu/+source/file-roller/+bug/1235917

"
files -rooler is in saucy not able to slit files during compression in any available format. The other option for splitting keeps greyed out.

Speps to reproduce:
1.Open nautilus and navigate to an LibreOffice .odt document(There will be one attached: Impacting the bioscience progress...)
2.Right click on the .odt
3.Compress here
4.Choose format for the compression(on every format the same problem)
5.Use the drop down "Other Options)
6.See that the splitting option always keeps greyed out.

Expeted:

file-roller is and should be able to do spitting during compression.

Additional: This is a regression in respect to Ubuntu 13.04 Raring

Additional: The .odt file will be attached. A screenshot will be attached.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: file-roller 3.10.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
Uname: Linux 3.11.0-11-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Sun Oct 6 12:23:18 2013
ExecutablePath: /usr/bin/file-roller
InstallationDate: Installed on 2013-05-03 (155 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
SourcePackage: file-roller
UpgradeStatus: Upgraded to saucy on 2013-10-05 (0 days ago)
"

tags: added: karmic lucid precise
tags: added: amd64
tags: added: regression-release saucy
Sebastien Bacher (seb128) wrote :

upstream says that's not a bug, the option is only there for formats that support it

@Sasa: your bug seems a different issues and not a duplicate

tags: removed: regression-release
jvh (xtrajoris) wrote :

This is still an issue on Ubuntu 18.04 with archive manager / file-roller 3.16.5

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.