double click on .cpio.gz file says "there is no application installed for this file type"

Bug #385927 reported by marco.pallotta on 2009-06-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

If I double click on a file .cpio.gz file-roller says
"there is no application installed for this file type".

Then if you gunzip the file and try again to double-click on it (now the file is become .cpio) all works ok and the .cpio file was browsed.

Tested with Hardy and file-roller 2.22.3-0

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Could you add a file example to the bug?

 This will help us to find and resolve the problem.

Changed in file-roller (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in file-roller (Ubuntu):
status: Incomplete → Invalid
marco.pallotta (marco-pallotta) wrote :

You can simply create an empty file .cpio.gz (for example test.cpio.gz) and try to double click on it.
You can make another test with an empty file .gz (for example test.gz) and try to double click on it.
You will see that with the .cpio.gz file you will obtain the error while with the .gz file all works ok.

If you want a real test you can download every .cpio.gz file from the web (for example try the following http://www.openmamba.org/pub/openmamba/devel/media/bootusb/it/openmamba-bootusb-it-snapshot-20090801.i586.cpio.gz )

Changed in file-roller (Ubuntu):
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

confirming a dialog is displayed with the error: There is no application installed for CPIO archive (gzip-compressed) files

Changed in file-roller (Ubuntu):
status: New → Confirmed
marco.pallotta (marco-pallotta) wrote :

Pedro, I think the problem is not that there is no application installed for CPIO archive files. The app should be just file-roller. In fact if you gunzip the archive from cli you will obtain a simpe .cpio file that file-roller can manage with no errors.

Pedro Villavicencio (pedro) wrote :

Marco and i'm not saying anything. just writing the error you got from that dialog on file-roller and yes file-roller should handle those.

marco.pallotta (marco-pallotta) wrote :

Ah! Ok Pedro. I misunderstood what you wrote.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers