Archive Mounter fails to hide hidden files

Bug #384178 reported by lw on 2009-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

1. I'm running Ubuntu 9.04
2. nautilus 1:2.26.2-0ubuntu2
3. I archived my home directory as a .tar.gz file (also using nautilus) and opened it with Archive Mounter. When I browse the mounted archive, I expected to be able to hide hidden dot files and directories by toggling the Show Hidden Files menu item.

4. The dot files (e.g. .aptitude, .cache, .config) show up regardless of whether Show Hidden Files is checked.

I've tried it using the home directories of two different users with the same result. Thanks for reading this bug report.

lw (lw-lavabit) on 2009-06-06
tags: added: archive files hidden mounter
Jeff Enns (cyberpenguinks) wrote :

Thank you for sending in your bug report. Actually, when you open an archive (tarball in this case) Nautilus actually runs another application called file-roller. If you look in file-roller's menu there is no option to show/hide hidden files. This may be the intended behaviour by the original developer. Would you like to request this feature be added? Thank you.

affects: nautilus (Ubuntu) → file-roller (Ubuntu)
Changed in file-roller (Ubuntu):
status: New → Incomplete
lw (lw-lavabit) wrote :

Thanks for the quick reply. Yes, I think it would be a useful feature to add. When you're browsing a compressed directory with dozens of dot folders, it is helpful to be able to hide them.

Jeff Enns (cyberpenguinks) wrote :

Thank you for the feature request.

Changed in file-roller (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in file-roller (Ubuntu):
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=589157

Changed in file-roller (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Confirmed → Triaged
Changed in file-roller:
importance: Undecided → Unknown
status: New → Unknown
Changed in file-roller:
status: Unknown → New
Changed in file-roller:
importance: Unknown → Medium
Changed in file-roller:
status: New → Fix Released
Changed in file-roller (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.