file-roller kills entire session when a process cannot be executed

Bug #369603 reported by Joel Goguen on 2009-04-30
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Critical
file-roller (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: file-roller

Whenever file-roller can't execute a process (such as mv, gzip, etc.) it crashes the entire session. This seems to be because it sends SIGTERM to PID 0 in src/fr-process.c. Line 984 might need a check for process->priv->command_pid > 0?

[jgoguen@hermes:~/Code/file-roller-2.26.1]$ lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04
[jgoguen@hermes:~/Code/file-roller-2.26.1]$ apt-cache policy file-roller
file-roller:
  Installed: 2.26.1-0ubuntu1
  Candidate: 2.26.1-0ubuntu1
  Version table:
 *** 2.26.1-0ubuntu1 0
        500 http://gulus.usherbrooke.ca jaunty/main Packages
        100 /var/lib/dpkg/status

Expected behaviour: At worst, file-roller itself closes

Actual behaviour: The entire GNOME login session was closed and I had to log back in.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: file-roller 2.26.1-0ubuntu1
SourcePackage: file-roller
Uname: Linux 2.6.28-11-generic x86_64

Related branches

Joel Goguen (jgoguen) wrote :
Changed in fileroller:
status: Unknown → Confirmed
Joel Goguen (jgoguen) wrote :

This patch prevents file-roller from taking down the session when it dies like this. Only problem is, if file-roller remains open it's essentially useless anyway. If file-roller is kissed or closed in the middle of an operation this won't be an issue, but if AppArmor is the cause, file-roller will need to be restarted to get functionality. Not sure if this is acceptable or not, and I don't know where to look to further fix this, so here's my debdiff applying the patch provided in the upstream bug.

Joel Goguen (jgoguen) wrote :

This is the AppArmor profile in force that caused this issue. To reproduce, apply this profile, open an archive with file-roller, and try to either use the Extract button, or drag files from file-roller to a Nautilus window. /bin/mv will be denied, and the entire login session will crash. With the previous debdiff applied, file-roller won't crash but will be mostly useless until closed and re-opened.

Joel Goguen (jgoguen) wrote :

Marking this as a Medium importance because although file-roller is typically not restricted by AppArmor, the upstream report says that if a user were to close file-roller in the middle of an operation this would also be an issue.

Changed in file-roller (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

The debdiff has some config.log noise

Changed in file-roller (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
Joel Goguen (jgoguen) wrote :

Sorry about that, I've regenerated the debdiff, it doesn't have anything from config.log this time.

Changed in fileroller:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in file-roller (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 2.27.1-0ubuntu1

---------------
file-roller (2.27.1-0ubuntu1) karmic; urgency=low

  * debian/control.in:
    - updated gtk requirement

  [ Robert Ancell ]
  * New upstream version (LP: #387706)
    - New features and user visible changes
      - Added support for lzip compressed archives (#579467)
      - Added support for xz compressed archives (#582237)
    - Bugs fixed:
      - #582712: Opening multipart encrypted .7z files does not work (file-roller-created .7z)
      - #584675: Untracked files on fresh clone
      - #580070: Garbage is displayed when adding a folder
      - #583863: Wrong explanation for the command 'extract-here'.
      - #584810: File-roller uses libsexy
      - #584718: File-roller crashes when opening certain archives with wierd characters in filename (LP: #282179)
      - #581102: build error in copy-n-paste/
      - #578467: Should not use deprecated gtk symbols
      - #503240: File-roller kills the entire session when aborted (LP: #369603)
  * debian/patches: 30_fix_local_include.patch: Fix local include file in distributed file
  * debian/control.in:
  * debian/control:
  * debian/file-roller.mime:
    - Support lzip and xz

 -- Sebastien Bacher <email address hidden> Tue, 16 Jun 2009 12:41:19 +0200

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Changed in file-roller:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.