Cant extract directories containing [ and ] in File Roller

Bug #312253 reported by Fred on 2008-12-29
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
File Roller
Invalid
Medium
file-roller (Ubuntu)
Medium
Unassigned

Bug Description

I have a .zip file.

When I try to extract a directory called "moo[AB]", it fails and I get an error.

"An error occurred while extracting files.
(null)
caution: filename not matched: #1/moo[AB]/
caution: filename not matched: #1/moo[AB]/01.jpg
caution: filename not matched: #1/moo[AB]/02.jpg"

Directories without the characters [ and ] works fine extracting.
The archive works fine extracting in other software such as 7-Zip in Wine.

Nicolas Quenouille (nicoz) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better, but I can't reproduce it; please tell me what version you use. Can you also give us an archive as example ?
This will help us to find and resolve the problem.

Changed in file-roller:
status: New → Incomplete
Fred (eldmannen+launchpad) wrote :

File Roller 2.24.1

Fred (eldmannen+launchpad) wrote :
Nicolas Quenouille (nicoz) wrote :

Ok, I can confirm it; thank you for your report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=566066

Changed in file-roller:
status: Incomplete → Confirmed
Connor Imes (ckimes) on 2008-12-31
Changed in file-roller:
importance: Undecided → Medium
Nicolas Quenouille (nicoz) wrote :

After reading the Paolo Bacchilega comment on bugzilla, I mark this bug as "Fix Commited".

Changed in file-roller:
status: Confirmed → Fix Committed
Changed in fileroller:
status: Unknown → Invalid
Pedro Villavicencio (pedro) wrote :

fixed on jaunty, thanks for reporting.

Changed in file-roller:
status: Fix Committed → Fix Released
Changed in file-roller:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in file-roller:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.