Unziping an archive from nautilus fails with certain characters

Bug #298195 reported by Xavier Marchegay on 2008-11-14
8
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Ubuntu version : 8.10
Gnome version : 2.24.1
Language : french

Steps to reproduce the crash :

1. Open nautilus
2. Create an archive with the # character in the name.
3. Right-click on the archive and select "Extraire Ici" ("Extract Here" in french).
4. Nautilus fails at unzipping the archive.

Error message :

Une erreur s'est produite lors de l'extraction des fichiers.
Opération non prise en charge

An error occured while the extraction
Operation not included
(not a perfect translation sorry but I do not know the English error message).

However, you can unzip the archive by opening the archive with the archive manager then extract.

I contact several people and they have the same problem.

This is my first bug submission so I miss some pieces of information please let me know. I tried to look for a similar bug submission unsuccessfully.

Xavier

Related branches

Chris Coulson (chrisccoulson) wrote :

Assigning to file-roller

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a '.crash' file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

 If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

 If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

 If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.
 I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in file-roller:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Invalid
Xavier Marchegay (valinor4) wrote :

I enabled apport but there is no crash file in the /var/crash directory.

I think that it is because I do not know if it is a problem with nautilus or with the archive manager. Furthermore, nautilus doesn't crash, it just displays an error message.

I have attached a screenshot of the problem.

Sebastien Bacher (seb128) wrote :

could you add an example to the bug?

Chris Coulson (chrisccoulson) wrote :

That's because you're not actually experiencing a crash (it's just an error message). I've edited your bug title to reflect this.

Anyway, I can confirm that if you right click on any archive in Nautilus that has a "#" in the filename, then select "Extract here", it fails with the error message you quoted.

I'll send this upstream when I get home from work later.

Changed in file-roller:
status: Invalid → Confirmed

Forwarded the bug upstream.

Changed in fileroller:
importance: Undecided → Unknown
status: New → Unknown
Chris Coulson (chrisccoulson) wrote :

Thank you Martin - I honestly forgot to do it

Changed in file-roller:
status: Confirmed → Triaged
Changed in fileroller:
status: Unknown → New

This is now fixed upstream. Thanks for reporting.

Changed in file-roller:
status: Triaged → Fix Committed
Changed in fileroller:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 2.25.2-0ubuntu1

---------------
file-roller (2.25.2-0ubuntu1) jaunty; urgency=low

  * New upstream release (LP: #319086)
    - #567554: An error occurred while adding files to the archive after
      encrypt the zip archive.
    - #566591: File roller cannot create splitted archives with pieces
      smaller than 1 Mb
    - #560647: file-roller wakes up the CPU 2 times per second.
    - #563208: file-roller can't extract to an ftp mounted directory.
      Patch by Gerard Lommerse.
    - #564029: Unziping an archive from nautilus fails with certain
      characters. (LP: #298195)
    - #565879: isoinfo.sh has shebang but is installed -x Patch by Loïc
      Minier.
    - #567901: renaming directory in tarball creates duplicate files
    - #568260: file-roller installs static libraries by default (for
      nautilus extension)
    - #566683: remove redundant figures
  * debian/patches/70_autotools.patch:
    - Refresh for new upstream release

 -- Pedro Fragoso <email address hidden> Tue, 20 Jan 2009 03:35:52 +0000

Changed in file-roller:
status: Fix Committed → Fix Released
Changed in file-roller:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.