file-roller crashes when modifying archive, data destroyed

Bug #229517 reported by O-P Lamminen on 2008-05-12
2
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Critical
file-roller (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: file-roller

$ lsb_release -rd
Description: Ubuntu 7.10
Release: 7.10
$ apt-cache policy file-roller
file-roller:
  Installed: 2.20.1-0ubuntu1
  Candidate: 2.20.1-0ubuntu1
  Version table:
 *** 2.20.1-0ubuntu1 0
        500 ftp://ftp.funet.fi gutsy-updates/main Packages
        100 /var/lib/dpkg/status
     2.20.0-0ubuntu1 0
        500 ftp://ftp.funet.fi gutsy/main Packages

I opened a large (500MB+) tar.gz archive from Nautilus. I then tried to remove some files from the archive. File-roller started processing the archive but after a while it crashed without any error notification. The archive itself was destroyed in the process.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instuctions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in file-roller:
importance: Undecided → Medium
status: New → Invalid
O-P Lamminen (op-lamminen) wrote :

I can reproduce the bug but I cannot get a crash dump in /var/crash (apport is enabled).
Reproduction steps are as follows:
1) Create a tar.gz archive with some large files (100M +) and some smaller text files (preferably in different subdirectories)
2) Select some of the large files and delete them
3) While file-roller is processing the archive (deleting files) browse to the subdirectory with the smaller text files
4) Double-click on a text file to view it
5) File-roller exits (crash?) without notification. The original archive is gone.
The unzipped (and unmodified) tar-file can be found from .fr-XXXXX temp directory, so the data is still (luckily) intact.

Sebastien Bacher (seb128) wrote :

could you get a stacktrace as described on http://wiki.ubuntu.com/DebuggingProgramCrash?

Pedro Villavicencio (pedro) wrote :

confirming based on your comments, will get a backtrace of it.

Changed in file-roller:
assignee: nobody → desktop-bugs
status: Invalid → Confirmed
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=532789

Changed in file-roller:
status: Confirmed → Triaged
Changed in fileroller:
status: Unknown → New
Changed in fileroller:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting!.

Changed in file-roller:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :

the new version is in intrepid

Changed in file-roller:
status: Fix Committed → Fix Released
Changed in file-roller:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.