Ubuntu

file-roller will not open 256 AES zip files

Reported by DanB on 2008-04-22
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: file-roller

Winzip and many other zip programs can now produce zip files that are protected by 256 AES encryption. FIle-roller in ubuntu cannot handle these zips. The files within the zips are shown fine but when you try and extract the following error occurs:

skipping: Test.txt unsupported compression method 99

I believe this is because "unzip" is used to extract the archive. This is the output from "unzip":
dbrewer@HCC122J:~/Desktop$ unzip Test.zip
Archive: Test.zip
   skipping: Test.txt unsupported compression method 99

If "7z" is used it works fine:
dbrewer@HCC122J:~/Desktop$ 7z x Test.zip

7-Zip 4.51 beta Copyright (c) 1999-2007 Igor Pavlov 2007-07-25
p7zip Version 4.51 (locale=en_GB.UTF-8,Utf16=on,HugeFiles=on,2 CPUs)

Processing archive: Test.zip

Extracting Test.txt
Enter password (will not be echoed) :

Everything is Ok

So I propose that file-roller uses "7z" instead of "unzip".

I attach an example of this kind of file. The password is "monkey" (no quotes).

Note peazip also can handle this. Maybe a replacement for file-roller?

DanB (dan-signup) wrote :
Pedro Villavicencio (pedro) wrote :

That's a unzip limitation not an file-roller one. The other part of the report (use 7z instead) is a known issue, thanks.

Changed in file-roller:
status: New → Invalid
DanB (dan-signup) wrote :

File-roller should open these files, hence it is a file-roller problem in my opinion. File-roller is a frontend to these various other utilities so I do not see why it can't be changed to use 7z instead of unzip, seeing as it uses 7z anyway for 7z files. This would solve the problem. 256 AES zips are being increasingly used in a corporate environment including mine, so I feel this issue is important.

As unzip hasn't been updated since 2005 (according to the changelog) it looks like this facility will not be included anytime soon, so an alternative approach needs to be taken.

Phil Wiggins (phil-wiggins) wrote :

Installation of p7zip-full and p7zip-rar packages in Ubuntu8.10 resolves this issue.

Recommend closure.

Cheers,

-Phil

James Lewis (james-fsck) wrote :

I would say that any normal user would just /assume/ that these files were not support and revert to Windows for this task... I found this bug after doing just that in Oneiric. I don't think it's reasonable to close it just becuase you can install a different backend and have it work... it may not be a bug in file-roller (other than that it does not advise the user of options), but perhaps in the distribution planning etc.

Clearly closing this bug without addressing it has lead to the problem being present for 2 full cycles of LTS, and AES zip files are now much more common.

Perhaps this can be moved to papercuts?

Changed in file-roller (Ubuntu):
status: Invalid → Confirmed

AES-256 encrypted zip files are the only reason I use 7z from the command line instead of File Roller. File roller should at least tell you what encryption it is using. The original .zip encryption is a joke by today's standards. I had to install 7z just to figure out what encryption file-roller/zip was actually using (AES-128 on Ubuntu 12.04).

Here is a short script for running 7z with AES-256 without typing your password on the command line (and thus entering it into the history):

read -s -p "Please enter a password: " backup_pass
backup_pass="'"$backup_pass"'"

7z a -tzip -p$password -mem=AES256 destFile.zip folderOrFileName

unset backup_pass

Oops. $password should be $backup_pass in that example. I did test it and it otherwise works as far as I can tell. Hope that helps.

Olivier Febwin (febcrash) wrote :

up!

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in file-roller (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers