Asking for password with missing archive volume

Bug #186921 reported by Sparhawk on 2008-01-29
4
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: file-roller

Ubuntu 7.10 Gutsy
file-roller 2.20.1-0ubuntu1

When extracting a volume set of rar archives and file-roller encounters a missing archive volume, it erroneously asks for a password and displays only a password entry box.
It does not report -which- volume is missing and upon adding that volume and hitting enter, it exits instead of continuing the extraction process.

Comparing this behaviour to WinRAR which will prompt you for the missing volume and continue the extraction process when you've entered a path to that volume (desired behaviour).

Also, the progress reporting bar in file-roller erroneously just rolls back and forth instead of reporting the current progress and volume being processed.
(There's a bug report on this behaviour here and on bugzilla with a couple of suggested patches but that hasn't been updated since 2006-xx-xx)

I've found I've become more prone to using the rar command rather than file-roller because of this behaviour.

Regards,
Sparhawk

Sparhawk (theastrochild) wrote :

Also, the application does not report -which- volume is missing, only prompts for a password for the first volume in the archive set.

Sparhawk (theastrochild) wrote :

It won't let you see any error messages output from the RAR command either, so there's no idea of knowing why the file-roller suddenly stops and doesn't want to unpack the archive I just replaced which file-roller apparently thought was missing.
Bleh.
It goes halfway throught the process before it realizes a file is missing, prompts for a password, deletes its progress so far and exits.
Instead of doing what WinRAR does; "Excuse me Sir, there's a file missing, mind giving me a path and file name for it so I can continue this tedious process of unarchiving over a slow network connection?"

Humbug.
Will someone be looking into this?
I posted this last week and so far it looks like no one's even looked at it...

Sebastien Bacher (seb128) wrote :

Thank you for your bug. Could you attach a small example and describe easy steps to trigger the issue?

Changed in file-roller:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

Closing this bug report as no further information has been provided. Please feel free to reopen this bug if you can provide the information asked for. Thanks!.

Changed in file-roller:
status: Incomplete → Invalid
Sparhawk (theastrochild) wrote :

Eh?
Why close, and why ask for information which is clearly in the description I gave when I reported the bug?

Steps to reproduce:
1) Extract a multi-volume archive with one volume in the set "missing" (ie not in the directory where the other volumes are).
2) Watch what happens when the file-roller encounters the missing archive.

What more do you need to know in order to reproduce this bug/undesired behaviour?

//Sparhawk

Sparhawk (theastrochild) on 2008-03-22
Changed in file-roller:
status: Invalid → In Progress
Sebastien Bacher (seb128) wrote :

don't set the bug to in progress if you are not working on fixing it, could you attach an example as requested before?

Changed in file-roller:
status: In Progress → Incomplete
Sparhawk (theastrochild) wrote :

Uh, OK?
Sorry, didn't see the "incomplete" option or I would have used that instead as it makes more sense.

I did "attach an example", what more do you want, screenshots?
You're going to have to be a little more detailed in your request for "more information", I don't know what more to give you!

What I did was:
Extract a multi-volumed archive with one archive missing and see the prompt for "missing password" pop up when file-roller encounters the missing archive.
There's no way to just supply a path to the missing archive or add it to the folder with the other volumes and continue the operation since
A) file-roller does not include information about -which- volume is missing and
B) when you hit "ENTER" to "continue" the entire operation fails and you have to manually figure out which volume was missing and restart from the beginning.

What else do you need to know?
What other information could I possibly give you that would offer the "example" you've requested?

Pedro Villavicencio (pedro) wrote :

You didn't attached any example file to see if we can reproduce your problem with it, unless there's no example file i'm setting this as invalid and please read and follow the code of conduct - http://www.ubuntu.com/community/conduct/ . Thanks you in advance.

Changed in file-roller:
status: Incomplete → Invalid
Åskar (olskar) wrote :

I attach the needed examplefiles.

Steps to reproduce:
Download and extract the attached examplefile.
In there is splitted rar files, remove one of these
Rightclick one of the splitted rarfiles and hit extract.
You get a prompt telling you to put in a password (this is the bug)

If you on the other hand try to unrar it from terminal with unrar you get a message telling you that a volume could not be find and also tells you what file is missing.

I hope you understand!

Åskar (olskar) on 2008-06-07
Changed in file-roller:
status: Invalid → New
Åskar (olskar) wrote :

Do you need any more info on this bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments