Remove patch to remove headerbar

Bug #1719322 reported by Daniel Fore on 2017-09-25
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eog (Ubuntu)
Wishlist
Unassigned
epiphany-browser (Ubuntu)
Wishlist
Unassigned
evince (Ubuntu)
Wishlist
Unassigned
file-roller (Ubuntu)
Wishlist
Unassigned
gedit (Ubuntu)
Undecided
Unassigned
gnome-calculator (Ubuntu)
Undecided
Unassigned
gnome-contacts (Ubuntu)
Wishlist
Unassigned
gnome-screenshot (Ubuntu)
Undecided
Unassigned
totem (Ubuntu)
Low
Daniel van Vugt

Bug Description

This was discussed in more detail at the Ubuntu Community Hub:

https://community.ubuntu.com/t/removal-of-headerbar-patches-and-impact-on-unity/1456

Original Bug Report
===================
As of Artful, it seems that there are still patches against various apps that remove/replace the Gtk.HeaderBar with a Gtk.Toolbar.

Now that GNOME Shell is default in Ubuntu and there is better support for client-side decorations, these patches can probably go away

Sebastien Bacher (seb128) wrote :

evince is in sync with Debian so the patch should probably be removed there rather than in an Ubuntu specific delta which is creating more work for us.
Do you have any issue with the patch or what's the motivation for the request?

Changed in evince (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
Changed in epiphany-browser (Ubuntu):
importance: Undecided → Wishlist
Changed in file-roller (Ubuntu):
importance: Undecided → Wishlist
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

It could also we that xfce or some other desktop still want to stay away from CSD

Jeremy Bicha (jbicha) wrote :

The Debian GNOME team are fine with us removing the headerbar patches for eog and evince. (In fact, the Debian GNOME team is a bit unhappy with the patches since they add several untranslated strings when run outside GNOME or Ubuntu).

Changed in gnome-contacts (Ubuntu):
status: New → Incomplete
importance: Undecided → Wishlist
Jeremy Bicha (jbicha) wrote :

I recently helped get the baobab patch pushed upstream (for 3.28): it only uses the "traditional" titlebar on Unity.

Daniel Fore (danrabbit) wrote :

Mainly the issue for us is that it appears quite broken. It would be preferable to use the upstream version of the application's UI.

Jeremy Bicha (jbicha) wrote :

Daniel, could you attach some screenshots to show the brokenness?

The patches could probably be updated to not change the UI on Elementary.

What's the output of

echo $XDG_CURRENT_DESKTOP

Daniel Fore (danrabbit) wrote :

Hey Jeremy, "Pantheon" reports as itself ;)

I've attached here a screenshot of how it looks.

Jeremy Bicha (jbicha) wrote :

I agree. There isn't much point in not using CSD for Epiphany since the visual difference is really minor and Firefox will be getting CSD soon too.

Changed in epiphany-browser (Ubuntu):
status: New → Fix Committed
Jeremy Bicha (jbicha) on 2017-09-30
Changed in file-roller (Ubuntu):
status: Incomplete → Fix Committed
Changed in gnome-contacts (Ubuntu):
status: Incomplete → Fix Committed
Jeremy Bicha (jbicha) wrote :

The GNOME Contacts patches were broken: it wasn't possible to use the app menu on Budgie or Xfce. Also, the patches no longer applied against

The headerbar patches look bad in Xfce (waste of vertical space) and they are inconsistent. Most GNOME apps use headerbars so trying to avoid them in a few apps isn't very helpful. Xfce doesn't include Epiphany, GNOME Contacts, or file-roller by default anyway.

file-roller still uses a traditional menu bar on Unity.

There is one issue: it makes LP: #1720555 a bit worse.

Jeremy Bicha (jbicha) wrote :

*the gnome-contacts patches no longer applied against 3.26

Jeremy Bicha (jbicha) on 2017-09-30
Changed in eog (Ubuntu):
status: New → Incomplete
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.26.0-0ubuntu2

---------------
file-roller (3.26.0-0ubuntu2) artful; urgency=medium

  * Drop bz_unity_header.patch: No longer needed for Unity (LP: #1719322)

 -- Jeremy Bicha <email address hidden> Sat, 30 Sep 2017 11:43:39 -0400

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package epiphany-browser - 3.26.1-1ubuntu1

---------------
epiphany-browser (3.26.1-1ubuntu1) artful; urgency=medium

  * Sync with Debian. Remaining change:
    - Modify 07_bookmarks.patch:
      + Add Ubuntu-specific default bookmarks, borrowed from Firefox
  * Drop ubuntu_titlebars.patch (LP: #1719322)
    + Use traditional titlebars for non-GNOME sessions

epiphany-browser (3.26.1-1) unstable; urgency=medium

  * New upstream release
  * Drop git_fix-url-bar-lag.patch: Applied in new release
  * Bump Standards-Version to 4.1.1

 -- Jeremy Bicha <email address hidden> Sat, 30 Sep 2017 10:20:38 -0400

Changed in epiphany-browser (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-09-30
Changed in gnome-contacts (Ubuntu):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

those changes modify the look of the softwares on some desktops right? they require at least a UIFe...

Jeremy Bicha (jbicha) wrote :

Daniel, how important do you think this issue is? Can it wait until 18.04 LTS?

Jeremy Bicha (jbicha) wrote :

gnome-contacts and epiphany-browser are not included in any Ubuntu flavors and I'd like to keep this change for artful for those packages (for reasons I mentioned briefly earlier on this bug). I am willing to revert the file-roller change for 17.10 and postpone eog and evince to 18.04 if we think that's better because of how late in the cycle we are.

Daniel Fore (danrabbit) wrote :

Thanks for your work on this Jeremy! We only release on LTS, so we're totally fine with waiting for 18.04 for the change. Just wanted to make sure we filed the issue before then :)

Jeremy Bicha (jbicha) wrote :

I am reverting the file-roller change for Ubuntu 17.10 because of User Interface Freeze.

Changed in file-roller (Ubuntu):
status: Fix Released → Triaged
Changed in evince (Ubuntu):
status: Incomplete → Triaged
Changed in eog (Ubuntu):
status: Incomplete → Triaged
Khurshid Alam (khurshid-alam) wrote :

I am against this.

These patches are needed for Unity. These patches are designed in two ways:

1) It will use title-bar only under Unity & headerbar under all non-unity sessions.

2) It will use header-bar only for Gnome session.

2 is the problem. What we need to do is convert 2 into 1. It should be fairly simple to do that.

My point is that we shouldn't break app-menu completely in Unity. File-roller and eog are default apps. If there is a feasible way to make them work as intended for all sessions then we should adopt that.

I will check patches for contact, eog and file-roller so that I can convert 2 into 1.

@Daniel, @Jeremy Are you ok with this?

Khurshid Alam (khurshid-alam) wrote :

Hi Jeremy,

I converted file-roller patch from 2 to 1. See my above comment for details.

Now, it will use titlebar only under Unity. All other sessions will use headerbar including pantheon.

Jeremy Bicha (jbicha) wrote :

Khurshid, are you aware that there are apps in the default Ubuntu install that never got these headerbar patches, like gnome-calendar and gnome-sudoku?

And there are a rather large number of GNOME apps that aren't in the default install.

Even Firefox is switching to headerbars, maybe by early next year.

It feels like a huge undertaking if you really want to not have headerbars in Unity, and I'm not sure it's worth all that work.

The attachment "bz_unity_headerbar.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Khurshid Alam (khurshid-alam) wrote :

@Jeremy

Some apps do not need those, as they get all functions from header-bar buttons and gear menu like Gnome-Calendar.

But for some header-bar apps as you know, preference is not under gear menu. If a user enables LIM in Unity (which is a very popular feature) they won't have access to preference or any other app-menus.

Solutions"

a) Make gtk-shell-show-app-menu = true, but that can't be done from Unity. One has to login to shell to use that particular feature of the tweak-tool.

b) Patch calendar and sudoku not to use headerbar in Unity.

About (b):

I don't think maintenance would that difficult compared to other things that Unity patches. Gnome simply uses

    gtk_window_set_titlebar (GTK_WINDOW (window), window->priv->headerbar);

which is well documented, supported feature of gtk-3 api. If we disable that part it will fall back decorating windows server side.

Since gtk-3 api declared stable the patch will keep working as long as they are compiled against gtk-3.

I can patch those default apps.But atm, I am waiting to reach a conformation. I have no problem going with (a).

Khurshid Alam (khurshid-alam) wrote :

Eog: converted from 2 to 1

Khurshid Alam (khurshid-alam) wrote :

Eog: Converted from 2 to 1

Khurshid Alam (khurshid-alam) wrote :

Evince: Converted from 2 to 1

Khurshid Alam (khurshid-alam) wrote :

Evince: converted from 2 to 1

Unit 193 (unit193) wrote :

By "Xfce doesn't include..." I'll presume you mean Xubuntu, which in fact does include file-roller. I'd be very disappointed if the headerbars came back or were restricted to Unity.

Changed in totem (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
importance: Undecided → Low
Khurshid Alam (khurshid-alam) wrote :

Totem:

Menubar patches depends on if gnome-shell shows app-menu or not which is configurable in dconf.

Jeremy Bicha (jbicha) on 2018-01-24
Changed in evince (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2018-01-24
Changed in file-roller (Ubuntu):
status: Triaged → Fix Committed
Changed in eog (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2018-01-24
Changed in gedit (Ubuntu):
status: New → Fix Committed
description: updated
Changed in gnome-calculator (Ubuntu):
status: New → In Progress
Changed in gnome-screenshot (Ubuntu):
status: New → Triaged
Jeremy Bicha (jbicha) on 2018-01-24
Changed in totem (Ubuntu):
status: In Progress → Fix Committed
Changed in gnome-calculator (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.26.2-3ubuntu1

---------------
file-roller (3.26.2-3ubuntu1) bionic; urgency=medium

  * Sync with Debian. Remaining change:
   - debian/rules:
       + Make a compatibility desktop file for upgraders
  * Drop bz_unity_header.patch: No longer needed for Unity (LP: #1719322)
    If you don't like headerbars, consider installing engrampa from MATE

file-roller (3.26.2-3) unstable; urgency=medium

  * Update Vcs fields for migration to https://salsa.debian.org/
  * Bump debhelper compat to 11
  * Build Nautilus extension again since it was re-enabled upstream
    in 3.26
  * On Ubuntu, depend on zip & unzip instead of p7zip-full because
    p7zip-full is in universe

file-roller (3.26.2-2) unstable; urgency=medium

  * Update Vcs fields for conversion to git
  * Add debian/gbp.conf
  * Bump Standards-Version to 4.1.2

file-roller (3.26.2-1) unstable; urgency=medium

  * New upstream release
  * Refresh patches

file-roller (3.26.1-1) unstable; urgency=medium

  * New upstream release
  * Add squashfs.patch from Ubuntu:
    - Support opening squashfs file systems and .snap files
  * debian/control.in:
    - Add squashfs-tools to Suggests, needed for above feature to work
  * Bump Standards-Version to 4.1.1

 -- Jeremy Bicha <email address hidden> Wed, 24 Jan 2018 15:23:57 -0500

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package eog - 3.26.2-3

---------------
eog (3.26.2-3) unstable; urgency=medium

  * Update Vcs fields for migration to https://salsa.debian.org/
  * Bump debhelper compat to 11
  * Drop obsolete patches (Closes: #881463)
    - 0001-Add-a-traditional-menu-bar.patch
    - 0002-Show-traditional-title-bar-in-unity.patch

 -- Jeremy Bicha <email address hidden> Wed, 24 Jan 2018 11:35:49 -0500

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
Changed in evince (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package evince - 3.26.0-3

---------------
evince (3.26.0-3) unstable; urgency=medium

  * Update Vcs fields for migration to https://salsa.debian.org/
  * Bump debhelper compat to 11
  * Drop obsolete patches (Closes: #876993, #886937)
    - traditional_menu_bar.patch
    - unity_normal_titlebar.patch

 -- Jeremy Bicha <email address hidden> Wed, 24 Jan 2018 11:40:25 -0500

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gedit - 3.22.1-3ubuntu1

---------------
gedit (3.22.1-3ubuntu1) bionic; urgency=medium

  * Sync with Debian. Remaining change:
   - debian/rules:
       + Make a compatibility desktop file for upgraders
  * Drop unity_no_csd.patch: No longer needed. (LP: #1719322)
    If you don't like headerbars, consider installing pluma from MATE
  * Drop 05_menu_label.patch: No longer needed

gedit (3.22.1-3) unstable; urgency=medium

  * Update Vcs fields for migration to https://salsa.debian.org/
  * Bump debhelper compat to 11
  * Bump minimum GTK+ to 3.21.3 per configure.ac
  * Cherry-pick 0004-Allow-close-button-in-the-left-corner.patch:
    - Fix window buttons when they are set to the left and side panel
      is enabled

gedit (3.22.1-2) unstable; urgency=medium

  * Update Vcs fields for conversion to git
  * Add debian/gbp.conf
  * Bump Standards-Version to 4.1.2
  * Explicitly build without -Bsymbolic-functions to fix plugin issues

 -- Jeremy Bicha <email address hidden> Wed, 24 Jan 2018 16:35:14 -0500

Changed in gedit (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package totem - 3.26.0-0ubuntu3

---------------
totem (3.26.0-0ubuntu3) bionic; urgency=medium

  * Drop patches that provided old-style decorations and menus for Unity7.
    This conveniently also fixes LP: #1502476. LP: #1719322

 -- Daniel van Vugt <email address hidden> Thu, 25 Jan 2018 05:42:51 +0800

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2018-01-25
Changed in gnome-screenshot (Ubuntu):
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-calculator - 1:3.26.0-3ubuntu1

---------------
gnome-calculator (1:3.26.0-3ubuntu1) bionic; urgency=medium

  * Sync with Debian (LP: #1719322). Remaining change:
    - Add epoch

gnome-calculator (3.26.0-3) unstable; urgency=medium

  [ Jeremy Bicha ]
  * Add git_fix_calculator_additional_parameter.patch:
    - Fix additional operand giving invalid expression for French users
      (LP: #785107, Closes: #875880)

gnome-calculator (3.26.0-2) unstable; urgency=medium

  * Update Vcs fields for conversion to git
  * Add debian/gbp.conf
  * Bump Standards-Version to 4.1.2

 -- Jeremy Bicha <email address hidden> Wed, 24 Jan 2018 16:50:25 -0500

Changed in gnome-calculator (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments