file roller overwrites files without asking when you extract selected files in file-roller

Bug #152303 reported by Nukeador on 2007-10-13
118
This bug affects 15 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
High
One Hundred Papercuts
High
Unassigned
Baltix
Undecided
Unassigned
file-roller (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: file-roller

When you drag and drop files from a compressed file to a folder containing files with the same name, it overwrites them without asking the user if he wants to do that.

Reported using file-roller version 2.20.0-ubuntu1
also affects to 2.24.1-0ubuntu2

pascalc (pascal-chevrel) wrote :

I can confirm that, same fileroller version

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That's known upstream, you can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=405626

Changed in file-roller:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in fileroller:
status: Unknown → New
electron++ (electronplusplus) wrote :

I'm using version 2.22.3 and it has the same bug.

Nukeador (nukeador) on 2009-01-15
description: updated
Chris Coulson (chrisccoulson) wrote :

Adding papercut task from the duplicate

Martin Albisetti (beuno) on 2009-06-30
Changed in hundredpapercuts:
status: New → Confirmed
Jakob Unterwurzacher (jakobunt) wrote :

This bug is about overwriting files when extracting, gnome bug 405626 is about overwriting when compressing.
I submitted gnome bug 590609 that is about overwriting when extracting.

Changed in file-roller:
status: New → Unknown
Changed in file-roller:
status: Unknown → New
Changed in file-roller (Ubuntu):
importance: Low → Medium
summary: - file roller overwrites files without asking when you drag & drop
- existing files
+ file roller overwrites files without asking when you extract via drag &
+ drop
Changed in file-roller:
importance: Unknown → High

Is there any progress being made on this bug? Has the cause of this issue been identified yet?

Hi,

No I didn't notice any change. Still overvriting. I'm using ubuntu 10.10

Regards,
Daniel

2011/1/26 Chris Wilson <email address hidden>

> Is there any progress being made on this bug? Has the cause of this
> issue been identified yet?
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (488343).
> https://bugs.launchpad.net/bugs/152303
>
> Title:
> file roller overwrites files without asking when you extract via drag
> & drop
>
> Status in File Roller:
> New
> Status in One Hundred Paper Cuts:
> Confirmed
> Status in “file-roller” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: file-roller
>
> When you drag and drop files from a compressed file to a folder
> containing files with the same name, it overwrites them without asking
> the user if he wants to do that.
>
> Reported using file-roller version 2.20.0-ubuntu1
> also affects to 2.24.1-0ubuntu2
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/file-roller/+bug/152303/+subscribe
>
>

Changed in hundredpapercuts:
status: Confirmed → Triaged
importance: Undecided → Medium
summary: - file roller overwrites files without asking when you extract via drag &
- drop
+ file roller overwrites files without asking when you extract selected
+ files in file-roller
Mantas Kriaučiūnas (mantas) wrote :

I lost important files when extracting older files from archive. I simply pressed "Extract" button in File-Roller toolbar and chose folder to extract. Unfortunately that folder contained newer files with the same name. I'm using latest Ubuntu version - 11.04 (Natty).
Please increase importance of this bug to High, as dataloss can occur!

tags: added: dataloss

Same here. Oneiric ocelot and file-roller 3.2.1-0ubuntu1

Changed in hundredpapercuts:
importance: Medium → High
Ayan George (ayan) on 2012-01-24
Changed in hundredpapercuts:
assignee: nobody → Ayan George (ayan)
status: Triaged → In Progress
Ayan George (ayan) wrote :

Sent attached small patch to the upstream bug for feedback.

Jens (jens.timmerman) wrote :

Would it be possible to implement the behaviour of nautilus?

So, if a folder is about to be overwritten, ask for a merge (and have a checkbox for applying this to recursively for each folder in the folder)

Ayan George (ayan) wrote :

I will work on preventing overwriting files in the archive today.

Changed in file-roller (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody

The attachment "0001-Added-fr_window_overwrite_files_dialog-which-checks-.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Ayan George (ayan) wrote :

This bug was fixed upstream in version 3.4.0.

Changed in file-roller (Ubuntu):
status: Triaged → Fix Committed
Changed in file-roller:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

file-roller (3.3.90-0ubuntu1) precise; urgency=low

  * New upstream release.
  * debian/patches/git_mime_type.patch: Dropped, applied upstream

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Ayan George (ayan) on 2012-03-05
Changed in hundredpapercuts:
assignee: Ayan George (ayan) → nobody
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.