Fails to pass PATH to sub-processes

Bug #14991 reported by Crispin Flowerday on 2005-04-05
18
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

I noticed this as my emacs needs to find the "p4" binary in the path, otherwise
it asks where it is, obviously if I double click on a file it is very annoying
to then have to type in the full path to the p4 binary.

To observe that the PATH isn't getting passed, do the following:

1) Find a tar file that contains a text file
2) Open the tar file in file-roller
3) Select "Open File..." from the context menu of the file, and use
"x-terminal-emulator -e less" as the command
4) Find the x-termainal-emulator instance pid and run the following command:
sudo cat /proc/<pid>/environ | xargs -0 -n1 echo | grep \^PATH=

Observe there is no PATH in the environment.

http://bugzilla.gnome.org/show_bug.cgi?id=303014: http://bugzilla.gnome.org/show_bug.cgi?id=303014

Matt Zimmerman (mdz) wrote :

*** Bug 16368 has been marked as a duplicate of this bug. ***

Sebastien Bacher (seb128) wrote :

right, I've opened a bug upstream about this:
http://bugzilla.gnome.org/show_bug.cgi?id=303014

Vassilis Pandis (pandisv) wrote :

I cannot reproduce this on dapper with 2.14.2-0ubuntu2. Taking a look at the sources (src/fr-process.c) , one can see that g_spawn_async_with_pipes() is called with a NULL envp parameter, which means that the spawned process should inherit the parent's PATH. IMHO this should be closed.

Sebastien Bacher (seb128) wrote :

That seems to work fine on dapper for me. Do you still have that issue?

Changed in file-roller:
assignee: seb128 → desktop-bugs
status: Unconfirmed → Needs Info

No, last time I checked (a couple of updates later), it worked fine.
I didn't react further on this bug because I thought it was a duplicate
of another and would be closed shortly.

Sebastien Bacher (seb128) wrote :

Closing as fixed then

Changed in file-roller:
status: Needs Info → Fix Released
Changed in file-roller:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.