Extraction of compressed folder located on NTFS file system does't work always

Bug #145607 reported by chaos.entalpico on 2007-09-27
6
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to decompress an archive on NTFS file system, I can only decompress single files. If I try to decompress the entire folder, nothing happens.

How to reproduce:
1 put a compressed file on a NTFS file system (any format, even .zip or .rar)
2 double click on the archive to open it
3 extract a single file any way you want, it works fine.
4 Extract an entire folder, the status bar says: "Extracting archive right now". Even the CPU reaches the 100% of usage. When the process is over, the uncompressed folder doesn't appear.
5 The only way to extract a folder on NTFS partition seems to be this: right click on compressed file and choose "extract here". Then put the new folder wherever you want.

Sometimes (but not always), the extracted folder appears after a reboot.

I use ubuntu feisty fawn with latest updates, Gnome interface 2.18.1 and kernel 2.6.20-16-generic.
Gcc version 4.1.2 (i486-linux-gnu)
Xorg version 7.2.0 (04 April 2007 - standard with feisty fawn) with an unsupported video card (Sapphire Ati Radeon 9250 AGP 8X). Right now I'm working with default drivers and I have no problem. Even compiz works fine.
Maybe it could be useful to know that NTFS partition is mounted on the same hard disk where the swap and ext3 partition are.

Right now I'm a new Linux user, and I don't know what package may cause this little trouble. I suppose it's "file roller", but I'm not sure about it.
This is not a critical bug, so take it easy, there's no need to hurry.

ProblemType: Bug
Architecture: i386
Date: Thu Sep 27 13:27:19 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/file-roller
Package: file-roller 2.18.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: file-roller /media/hdb5/Incoming/Mekong\ Delta\ -\ Pictures\ At\ An\ Exhibition\ -\ Released\ By\ Thrall.rar
ProcCwd: /home/gerardo
ProcEnviron:
 LANGUAGE=it_IT:it:en_GB:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
SourcePackage: file-roller
Uname: Linux Durlindana4 2.6.20-16-generic #2 SMP Sun Sep 23 19:50:39 UTC 2007 i686 GNU/Linux

Adam Niedling (krychek) wrote :

Has this been fixed by now?

Well, it's been a while. In these days I've upgraded to Hardy Heron and the bug seems vanished. I'm very sorry, I totally forget to refresh this page.

Adam Niedling (krychek) on 2008-05-12
Changed in file-roller:
status: Incomplete → Fix Released
str0g (buskol-waw-pl) wrote :

I have this bug too

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers