Disconnecting a server during a transfer causes nautilus to crash when reconnecting to that server

Bug #1333606 reported by Christopher M. Penalver on 2014-06-24
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Medium
Robert Ancell
Trusty
Medium
Robert Ancell

Bug Description

[Impact]
Disconnecting a server during a transfer causes nautilus to crash when reconnecting to that server. This is due to a bug in the file-roller plugin.

[Test Case]
1. Open a nautilus window
2. In sidebar, click "Connect to Network"
3. Enter network address "ftp://ftp.debian.org/"
4. Click connect in both dialogs
5. Start a file transfer
6. While the transfer is occurring press eject button beside ftp.debian.org entry that appears in sidebar
7. In sidebar, click "Connect to Network"
8. Enter network address "ftp://ftp.debian.org/"
9. Click connect in both dialogs

Expected result:
Transfer starts, then is cancelled and at step 9 you are reconnected to the server and can browse files.

Observed result:
Transfer starts, then is cancelled and at step 9 nautilus crashes.

[Regression Potential]
The fix is adding a missing unref call in the code which is a simple memory leak bug and is unlikely to have negative consequences. Could expose any existing unref bug that may be hidden by this leak.

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
description: updated
tags: added: utopic

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
information type: Private → Public
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Robert Ancell (robert-ancell) wrote :

This seems similar to bug 1202159 where it would crash on reconnecting even if you hadn't started a transfer.

description: updated
Changed in nautilus (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

This is one of the top 14.04 LTS crashers.

Robert Ancell (robert-ancell) wrote :

This does not occur on the gnome-3-10 branch on GNOME git so is caused by one of our patches or a commit we're not using.

Robert Ancell (robert-ancell) wrote :

Have narrowed it down the to the fileroller plugin - can crash GNOME git version if using file roller plugin.

affects: nautilus → file-roller
affects: nautilus (Ubuntu) → file-roller (Ubuntu)
summary: - nautilus crashed with SIGABRT in g_assertion_message()
+ Disconnecting a server during a transfer causes nautilus to crash when
+ reconnecting to that server
description: updated
description: updated
Changed in file-roller (Ubuntu):
status: Triaged → Fix Committed
Changed in file-roller (Ubuntu Trusty):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in file-roller (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
status: Fix Committed → In Progress
Changed in file-roller (Ubuntu Trusty):
status: Triaged → Fix Committed
Changed in file-roller (Ubuntu):
status: In Progress → Fix Committed
Changed in file-roller (Ubuntu Trusty):
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.10.2.1-0ubuntu5

---------------
file-roller (3.10.2.1-0ubuntu5) utopic; urgency=medium

  * debian/patches/git_nautilus_extension_unref.patch:
    - Stop nautilus crashing due to a missing unref in the file roller
      extension (LP: #1333606)
 -- Robert Ancell <email address hidden> Fri, 11 Jul 2014 19:35:17 +1200

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Changed in file-roller:
status: New → Confirmed
Changed in file-roller:
status: Confirmed → Fix Released

Hello Christopher, or anyone else affected,

Accepted file-roller into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/file-roller/3.10.2.1-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in file-roller (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Sami Jaktholm (sjakthol) wrote :

The version in trusty-proposed doesn't cause a crash.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for file-roller has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.10.2.1-0ubuntu4.1

---------------
file-roller (3.10.2.1-0ubuntu4.1) trusty-proposed; urgency=medium

  * debian/patches/git_nautilus_extension_unref.patch:
    - Stop nautilus crashing due to a missing unref in the file roller
      extension (LP: #1333606)
 -- Robert Ancell <email address hidden> Fri, 11 Jul 2014 19:44:25 +1200

Changed in file-roller (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.