file-roller chrashes when canceling "search for command"

Bug #1296402 reported by forteller on 2014-03-23
This bug report is a duplicate of:  Bug #1101096: file-roller crashed with SIGSEGV. Edit Remove
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
Undecided
Unassigned

Bug Description

I tried opening a .rar file without having support for it. File-roller asked me to "search for a command to open the file" and I did. When the list of packages to install came up (it was not highlighted, btw, which was confusing since it then looked like it was unresponsive/unusable) I clicked cancel. That's when the file-roller crashed.

I've replicated this with the same result once. The third time I tried it file-roller quit without a crash.

I'm on Ubuntu Gnome 14.04

ProblemType: Crash
DistroRelease: Ubuntu 14.04
Package: file-roller 3.10.2.1-0ubuntu4
ProcVersionSignature: Ubuntu 3.13.0-19.39-generic 3.13.6
Uname: Linux 3.13.0-19-generic x86_64
ApportVersion: 2.13.3-0ubuntu1
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Mar 23 21:36:35 2014
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/file-roller
InstallationDate: Installed on 2014-03-21 (1 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20140226)
ProcCmdline: file-roller /tmp/deskcon-desktop-master.zip
SegvAnalysis:
 Segfault happened at: 0x420bb0: mov 0x18(%rdi),%rax
 PC (0x00420bb0) ok
 source "0x18(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: file-roller
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: file-roller crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

forteller (forteller) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #1101096, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

information type: Private → Public
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers