'Extract Here' will work on first file but not a second

Bug #1262062 reported by Phil Wyett on 2013-12-18
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
Ubuntu GNOME
Medium
Unassigned
file-roller (Ubuntu)
High
Unassigned

Bug Description

Ubuntu Gnome - 14.04 dev release - 20131217.

Have two '.tar.gz' files in my home folder for extraction.

Right click on one and use 'Extract Here' and all is fine. Right after I go to the second file and peform the same action of 'Extract Here', the file will not extract. If you then attempt it again, it will extract.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: nautilus 1:3.8.2-0ubuntu4
ProcVersionSignature: Ubuntu 3.12.0-7.15-generic 3.12.4
Uname: Linux 3.12.0-7-generic x86_64
ApportVersion: 2.12.7-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Wed Dec 18 05:35:37 2013
GsettingsChanges:

InstallationDate: Installed on 2013-12-18 (0 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20131217)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Phil Wyett (aura-yoda) wrote :
tags: added: gnome3
Doug McMahon (mc3man) wrote :

Seen here more often than not, when it occurs shows this in gnome-session.log
GDBus.Error:org.freedesktop.DBus.Error.NotSupported: Application does not handle command line arguments

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

affects: nautilus (Ubuntu) → file-roller (Ubuntu)
Changed in file-roller (Ubuntu):
importance: Undecided → Low
Changed in file-roller:
importance: Unknown → Medium
status: Unknown → New
Changed in file-roller (Ubuntu):
status: Confirmed → Triaged
Tim Lunn (darkxst) on 2014-01-09
Changed in ubuntu-gnome:
importance: Undecided → Medium
amjjawad  (amjjawad) wrote :

Hi and thanks for reporting :)

The Title says: "'Extract Here' will work on first file but not a second " while on the description, it says: "Right click on one and use 'Extract Here' and all is fine. Right after I go to the second file and peform the same action of 'Extract Here', the file will not extract. If you then attempt it again, it will extract."

So, I think you mean it will 'not' do anything on the 'second file' as the first attempt to extract but will work on the second 'attempt' to extract the second file?

amjjawad  (amjjawad) wrote :

By the way, I just tested File Roller 3.4.1 on Xubuntu Release 12.04 (precise) 64-bit - Kernel Linux 3.2.0-58-generic and it works like a charm from the very first attempt.

I will try to do the same on my Virtual Machine with the latest Ubuntu GNOME Trusty update and report back :)

Phil Wyett (aura-yoda) wrote :

Re: #4 and #5.

This bug has been reported against the 14.04 dev release only. Adding comments like these are only muddying the waters on the report. Please read carefully before commenting on others bug reports.

amjjawad  (amjjawad) wrote :

I have indeed read and 'your' bug or to be more accurate the tile of the bug and the description are not similar unless I am missing something. And, as I said, I will check that on Trusty and report bug. I don't need anyone to tell me to read carefully :)

amjjawad  (amjjawad) on 2014-01-15
Changed in ubuntu-gnome:
milestone: none → trusty
status: New → Triaged
Phil Wyett (aura-yoda) wrote :

Re: #7.

* The bug was reported in #1.
* The bug was confirmed in #2.
* The bug was put to be reported upstream in #3.
* The bug was reported upstream by myself.
* The bug was marked as triaged, awaiting upstream processing.

While I respect any valid input. All you are doing currently is spamming this bug report and going over old ground.

amjjawad  (amjjawad) wrote :

Ubuntu GNOME Trusty Tahr amd64 - 3.13.0-3-generic - fully updated - running on virtual machine. Here is what is happening:

1- Created 4 '.tar.gz' files : [1.tar.gz, 2.tar.gz, 3.tar.gz and 4.tar.gz].
2- Compress works perfectly without any problem.
3- I did a Right Click on 1.tar.gz File and chose 'Extract Here' and it worked perfectly.
4- I did a Right Click on 2.tar.gz File and chose 'Extract Here' and it did 'not' work.
5- Right Click on 3.tar.gz File and Chose 'Extract Here' and it worked perfectly.
6- Right Click on 4.tar.gz File and chose 'Extract Here' and it did 'not' work.
7- I did repeat the above steps from 1-6 and it gave me the exact same result.
8- Kindly see the attached screenshot.

@Tim
If you require anything else to include, kindly let me know :)

Thank you!

Sebastien Bacher (seb128) wrote :

Thanks but as said before, that bug has all the infos required, no need to keep commenting on it

Changed in file-roller (Ubuntu):
importance: Low → High
Changed in file-roller (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.10.2.1-0ubuntu4

---------------
file-roller (3.10.2.1-0ubuntu4) trusty; urgency=medium

  * debian/patches/git_handle_command_line.patch:
    - backport fix to allow several instances, it should fix issues where
      opening or extracting several archives doesn't work (lp: #1262062)
  * debian/patches/git_user_extract_iso.patch:
    - let users extract isos without hitting permission errors
      (lp: #1264337)
 -- Sebastien Bacher <email address hidden> Thu, 27 Feb 2014 17:18:23 +0100

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Changed in file-roller:
status: New → Invalid
Changed in file-roller:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in file-roller:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in ubuntu-gnome:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.