file-roller crashed with SIGSEGV in on_bus_acquired_for_archive_manager()

Bug #1060506 reported by GonzO on 2012-10-02
90
This bug affects 12 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Medium
Unassigned

Bug Description

Tried to open a zip file. Got this.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: file-roller 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-16.25-generic 3.5.4
Uname: Linux 3.5.0-16-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Tue Oct 2 17:46:43 2012
ExecutablePath: /usr/bin/file-roller
ProcCmdline: file-roller /home/username/Downloads/hackedbellini-Gnome-Shell-Notifications-Alert-233b3f5\ (1).tar.gz
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x809d3f2: mov 0x8(%eax),%eax
 PC (0x0809d3f2) ok
 source "0x8(%eax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: file-roller
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 g_simple_async_result_complete () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: file-roller crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

GonzO (gonzo) wrote :

This crash has the same stack trace characteristics as bug #1051990. However, the latter was already fixed in an earlier package version than the one in this report. This might be a regression or because the problem is in a dependent package.

tags: added: regression-retracer

StacktraceTop:
 on_bus_acquired_for_archive_manager (connection=0x8dfd048, name=0x8e8e8e0 "org.gnome.ArchiveManager1", user_data=0x8dba000) at main.c:575
 connection_get_cb (source_object=0x0, res=0x8e8c8f0, user_data=0x8e8fa90) at /build/buildd/glib2.0-2.34.0/./gio/gdbusnameowning.c:480
 g_simple_async_result_complete (simple=simple@entry=0x8e8c8f0) at /build/buildd/glib2.0-2.34.0/./gio/gsimpleasyncresult.c:775
 complete_in_idle_cb (data=data@entry=0x8e8c8f0) at /build/buildd/glib2.0-2.34.0/./gio/gsimpleasyncresult.c:787
 g_idle_dispatch (source=source@entry=0x8e053f8, callback=0xb6f10420 <complete_in_idle_cb>, user_data=0x8e8c8f0) at /build/buildd/glib2.0-2.34.0/./glib/gmain.c:4806

Changed in file-roller (Ubuntu):
importance: Undecided → Medium
summary: - file-roller crashed with SIGSEGV in g_simple_async_result_complete()
+ file-roller crashed with SIGSEGV in
+ on_bus_acquired_for_archive_manager()
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

visibility: private → public
Changed in file-roller (Ubuntu):
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :
Changed in file-roller:
importance: Unknown → Critical
status: Unknown → New
Changed in file-roller:
status: New → Invalid
dmiranda (dmiranda) on 2012-10-26
Changed in file-roller:
importance: Critical → Unknown
status: Invalid → Unknown
Changed in file-roller:
importance: Unknown → Medium
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

the issue should be fixed in the current version

Changed in file-roller (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.