Adding file to archive, file-roller doesn't load location correctly and then crash

Bug #1056261 reported by OKANO Takayoshi
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
Low
Unassigned

Bug Description

how to reproduce:
1. open an archive file (e.g. hoge.tgz) with file-roller
2. Hit "Add files" button
3. It appears the file selection dialog box, and "Could not load the location" error dialog
4. close "Could not load the location" dialog
5. select a place on left pain of the file selection dialog, it causes crash (segmentation fault)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: file-roller 3.5.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
ApportVersion: 2.5.2-0ubuntu4
Architecture: i386
Date: Tue Sep 25 23:36:35 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
SourcePackage: file-roller
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
OKANO Takayoshi (kano) wrote :
Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

Please exec followings on problem occurs environment:
$ gsetting get org.gnome.FileRoller.Dialogs.Add current-folder

Revision history for this message
OKANO Takayoshi (kano) wrote :

> Please exec followings on problem occurs environment:

$ gsettings get org.gnome.FileRoller.Dialogs.Add current-folder
''
$

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

Reproduced it.

Reason:
If current-folder is ''(emty string, not NULL), will call g_file_new_for_uri('') in src/dlg-add.c
and its return vallue(GFile object) is passed to first argument of g_directory_foreach_child(directory, ...).
In the result, will occure "Could not load the location" error.

Workaround:
1. Close "Could not load the location" dialogue.
2. Select any folder in file selection dialogue.
3. No error message any more.

Solution:
Plan A) Change default schema from '' to any other valid path for current-folder in data/org.gnome.FileRoller.gschema.xml.in.

Plan B) If base_dir is '' in dlg_add_folder_load_last_options(), set any other valid path.

Please file this bug to upstream.

Revision history for this message
OKANO Takayoshi (kano) wrote :

> Please file this bug to upstream.

reported at GNOME Bugzilla: https://bugzilla.gnome.org/show_bug.cgi?id=684830

thank you.

Changed in file-roller (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

Fixed "could not load dialog" problem at master of upstream.

But "crash" is occured by other reason.
This crash always occure on i386 system. There is no workaround.

Filed bug with stacktrace.
https://bugs.launchpad.net/ubuntu/+source/file-roller/+bug/1058475

Changed in file-roller:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue is fixed in the current quantal version

Changed in file-roller (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.