gnome-settings-daemon crashed with signal 5 in g_object_newv()

Bug #1037646 reported by Daniel Holbach on 2012-08-16
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
High
Unassigned
gnome-settings-daemon (Ubuntu)
High
Unassigned

Bug Description

No idea what happened.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: gnome-settings-daemon 3.4.2-0ubuntu7
ProcVersionSignature: Ubuntu 3.5.0-10.10-generic 3.5.1
Uname: Linux 3.5.0-10-generic x86_64
ApportVersion: 2.4-0ubuntu8
Architecture: amd64
CheckboxSubmission: 2f383a1679e8525d7196eb2518a1921f
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Thu Aug 16 17:58:51 2012
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110817)
ProcCmdline: gnome-settings-daemon
Signal: 5
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-settings-daemon crashed with signal 5 in g_object_newv()
UpgradeStatus: Upgraded to quantal on 2012-06-27 (50 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

Daniel Holbach (dholbach) wrote :

Thank you for taking the time to report this crash and helping to make this software better. This particular crash has already been reported and is a duplicate of bug #903483, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-amd64-retrace
Changed in file-roller (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in gnome-settings-daemon (Ubuntu):
status: New → In Progress
Changed in file-roller (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.5.4-0ubuntu5

---------------
file-roller (3.5.4-0ubuntu5) quantal; urgency=low

  * debian/patches/git_src_update.patch:
    - update .convert as well for the schemas change (lp: #1037646)
 -- Sebastien Bacher <email address hidden> Thu, 16 Aug 2012 18:35:49 +0200

Changed in file-roller (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.4.2-0ubuntu8

---------------
gnome-settings-daemon (3.4.2-0ubuntu8) quantal; urgency=low

  * debian/gnome-settings-daemon.gsettings-override:
    - don't enable the deprecated gconf bridge
  * debian/patches/revert_git_dropping_gconf_wrapper.patch:
    - drop the hackish gsettings to gconf copy mechanism, it shouldn't be
      required after the lts, the code is also make gsd sensible to .convert
      issues as showed recently by a file-roller update (lp: #1037646)
  * debian/rules:
    - don't use deprecated --enable-gconf-bridge
 -- Sebastien Bacher <email address hidden> Mon, 20 Aug 2012 17:53:45 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers