file-roller crashed with SIGSEGV in dlg_package_installer()

Bug #1035912 reported by gogo on 2012-08-12
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
Medium
Unassigned

Bug Description

I have this crash just after the startup!

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: file-roller 3.5.4-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-9.9-generic 3.5.0
Uname: Linux 3.5.0-9-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Sun Aug 12 19:22:03 2012
ExecutablePath: /usr/bin/file-roller
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120810.2)
ProcCmdline: file-roller /home/username/Mac_OSX_Snow_Leopard_10_6_6_Intel_AMD_Vmware_Image.rar
ProcEnviron:
 PATH=(custom, no user)
 LANG=hr_HR.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x41b293: mov 0x20(%rax),%rdi
 PC (0x0041b293) ok
 source "0x20(%rax)" (0x00000020) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: file-roller
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: file-roller crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

gogo (trebelnik-stefina) wrote :
visibility: private → public

StacktraceTop:
 dlg_package_installer (window=0x1265040, archive=0x0, action=FR_ACTION_LOADING_ARCHIVE) at dlg-package-installer.c:265
 _handle_archive_operation_error (window=0x1265040, archive=0x0, action=<optimized out>, error=0x140f920, continue_batch=<optimized out>, opens_dialog=0x7fffaea4c94c) at fr-window.c:2973
 _archive_operation_completed (window=window@entry=0x1265040, action=action@entry=FR_ACTION_LOADING_ARCHIVE, error=0x140f920) at fr-window.c:3108
 archive_open_ready_cb (source_object=0x13f5560, result=<optimized out>, user_data=user_data@entry=0x1265040) at fr-window.c:6194
 g_simple_async_result_complete (simple=0x152ea30) at /build/buildd/glib2.0-2.33.8/./gio/gsimpleasyncresult.c:775

Changed in file-roller (Ubuntu):
importance: Undecided → Medium
summary: - file-roller crashed with SIGSEGV in g_simple_async_result_complete()
+ file-roller crashed with SIGSEGV in dlg_package_installer()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.5.4-0ubuntu3

---------------
file-roller (3.5.4-0ubuntu3) quantal; urgency=low

  * debian/control.in: build-depends on dh-autoreconf
  * debian/rules: use autoreconf.mk rule
  * debian/patches/git_src_update.patch:
    - update the src to the current git version, that will be easier to
      deal with the segfaults of the new code than trying to backport the
      stack of recent commits, replace previous backports (lp: #1035912)
      (lp: #1034531)
 -- Sebastien Bacher <email address hidden> Mon, 13 Aug 2012 17:23:45 +0200

Changed in file-roller (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers