file-roller segfaults in fr_command_handle_process_error()

Bug #1034531 reported by Ramiro Queso on 2012-08-08
44
This bug affects 6 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Medium
file-roller (Ubuntu)
High
Unassigned

Bug Description

Al iniciar una session de usuario

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: file-roller 3.5.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Wed Aug 8 14:06:41 2012
Disassembly: => 0x0: No se puede acceder a la memoria en la dirección 0x0
ExecutablePath: /usr/bin/file-roller
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120627)
ProcCmdline: file-roller /home/username/Descargas/Oracle_VM_VirtualBox_Extension_Pack-4.1.18-78361.vbox-extpack
ProcEnviron:
 LANGUAGE=es_BO:es
 PATH=(custom, no user)
 LANG=es_BO.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x0: No se puede acceder a la memoria en la dirección 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
 source "0x0" (0x00000000) not located in a known VMA region (needed readable region)!
SegvReason:
 executing NULL VMA
 reading NULL VMA
Signal: 11
SourcePackage: file-roller
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: file-roller crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
XsessionErrors: (compiz:1874): GConf-CRITICAL **: gconf_client_add_dir: assertion `gconf_valid_key (dirname, NULL)' failed

Ramiro Queso (rqueso) wrote :

StacktraceTop:
 ?? ()
 fr_command_handle_process_error (self=0x130f010, result=result@entry=0x1315960, error=error@entry=0x7fff85ad0778) at fr-command.c:438
 load_local_archive_list_ready_cb (source_object=<optimized out>, result=0x1315960, user_data=user_data@entry=0xf9af70) at fr-command.c:721
 g_simple_async_result_complete (simple=0x1315960) at /build/buildd/glib2.0-2.33.8/./gio/gsimpleasyncresult.c:775
 complete_in_idle_cb (data=0x1315960) at /build/buildd/glib2.0-2.33.8/./gio/gsimpleasyncresult.c:787

Changed in file-roller (Ubuntu):
importance: Undecided → Medium
summary: - file-roller crashed with SIGSEGV in g_simple_async_result_complete()
+ file-roller crashed with SIGSEGV in fr_command_handle_process_error()
tags: removed: need-amd64-retrace
summary: - file-roller crashed with SIGSEGV in fr_command_handle_process_error()
+ file-roller segfaults in fr_command_handle_process_error()
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

thank you for your bug report, what do you do to get the issue? is that still a problem with 3.5.4-0ubuntu2?

visibility: private → public
Changed in file-roller (Ubuntu):
status: Confirmed → Incomplete
Doug McMahon (mc3man) wrote :

One way this crash will happen if you try to open .deb archive, whether to examine in file-roller or extract
This continues to occur with the latest package, 3.5.4-0ubuntu2 & happens whether done from the file manager or directly in file-roller window

Felix Möller (felix-derklecks) wrote :
Changed in file-roller (Ubuntu):
status: Incomplete → Confirmed
Doug McMahon (mc3man) wrote :

To follow up on what Felix points out -
create a .gz
file-roller will then crash trying open or extract
So here it crashes on .gz & .deb at the very least

tags: added: rls-q-incoming
tags: added: qa-manual-testing
Changed in file-roller (Ubuntu):
importance: Medium → High
Changed in file-roller:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.5.4-0ubuntu3

---------------
file-roller (3.5.4-0ubuntu3) quantal; urgency=low

  * debian/control.in: build-depends on dh-autoreconf
  * debian/rules: use autoreconf.mk rule
  * debian/patches/git_src_update.patch:
    - update the src to the current git version, that will be easier to
      deal with the segfaults of the new code than trying to backport the
      stack of recent commits, replace previous backports (lp: #1035912)
      (lp: #1034531)
 -- Sebastien Bacher <email address hidden> Mon, 13 Aug 2012 17:23:45 +0200

Changed in file-roller (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.