file-roller segfaults in archive_is_encrypted()

Bug #1034398 reported by Siddhanathan Shanmugam on 2012-08-08
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
File Roller
Fix Released
Critical
file-roller (Ubuntu)
Medium
Unassigned

Bug Description

Tried to extract a rar file.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: file-roller 3.5.4-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Wed Aug 8 19:27:17 2012
ExecutablePath: /usr/bin/file-roller
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
ProcCmdline: file-roller --extract-here file:///home/username/Downloads/-=Xploitz=-%20Master%20Password%20Collection/Xploitz%20Master%20Password%20Collection.rar
SegvAnalysis:
 Segfault happened at: 0x43a044: mov 0x28(%rax),%rcx
 PC (0x0043a044) ok
 source "0x28(%rax)" (0x00000028) not located in a known VMA region (needed readable region)!
 destination "%rcx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: file-roller
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: file-roller crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: Upgraded to quantal on 2012-07-24 (14 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

visibility: private → public

StacktraceTop:
 archive_is_encrypted (window=window@entry=0x1f53030, file_list=file_list@entry=0x0) at fr-window.c:6855
 fr_window_archive_extract_here (window=0x1f53030, skip_older=0, overwrite=1, junk_paths=0) at fr-window.c:7002
 _archive_operation_completed (window=window@entry=0x1f53030, action=action@entry=FR_ACTION_LOADING_ARCHIVE, error=<optimized out>) at fr-window.c:3237
 archive_open_ready_cb (source_object=0x1ffd760, result=<optimized out>, user_data=0x1f53030) at fr-window.c:6188
 g_socket_class_init (klass=<optimized out>) at /build/buildd/glib2.0-2.33.8/./gio/gsocket.c:798

Changed in file-roller (Ubuntu):
importance: Undecided → Medium
summary: - file-roller crashed with SIGSEGV in g_simple_async_result_complete()
+ file-roller crashed with SIGSEGV in archive_is_encrypted()
tags: removed: need-amd64-retrace

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
summary: - file-roller crashed with SIGSEGV in archive_is_encrypted()
+ file-roller segfaults in archive_is_encrypted()
Changed in file-roller (Ubuntu):
status: Confirmed → Triaged
Changed in file-roller:
importance: Unknown → Critical
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package file-roller - 3.5.4-0ubuntu2

---------------
file-roller (3.5.4-0ubuntu2) quantal; urgency=low

  * Backport some git fixes
  * debian/patches/git_invalid_free_use.patch:
    - "fixed crash when extracting from the extract dialog"
  * debian/patches/git_nautilus_extract.patch:
    - "fixed crash when extracting an archive from the nautilus context menu"
      (lp: #1034398)
  * debian/patches/git_default_format.patch:
    - "new archive dialog: use the tar.gz format if no extension if specified"
 -- Sebastien Bacher <email address hidden> Thu, 09 Aug 2012 19:16:55 +0200

Changed in file-roller (Ubuntu):
status: Triaged → Fix Released
Changed in file-roller:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.