file-roller crashed with SIGSEGV in fr_window_progress_cb()

Bug #1022057 reported by joey.blacksmith on 2012-07-07
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
file-roller (Ubuntu)
Medium
Unassigned

Bug Description

This bug occurs when you try to extract any files from the computer you are remotely logged into. That means, you log in through 'connect to server' in nautilus and then 'extract here' file.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: file-roller 3.5.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-3.3-generic 3.5.0-rc5
Uname: Linux 3.5.0-3-generic x86_64
ApportVersion: 2.2.5-0ubuntu2
Architecture: amd64
Date: Sat Jul 7 14:06:20 2012
ExecutablePath: /usr/bin/file-roller
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120627)
ProcCmdline: file-roller --extract-here sftp://username@10.0.0.2/var/www/wp_vkh/wp-content/plugins/nextgen-gallery.zip
SegvAnalysis:
 Segfault happened at: 0x43633f: mov 0x78(%rax),%esi
 PC (0x0043633f) ok
 source "0x78(%rax)" (0x00000078) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: file-roller
StacktraceTop:
 ?? ()
 g_cclosure_marshal_VOID__DOUBLEv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: file-roller crashed with SIGSEGV in g_cclosure_marshal_VOID__DOUBLEv()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 fr_window_progress_cb (archive=0xafb6a0, fraction=0.0761887046897161, window=0xb14020) at fr-window.c:2600
 g_cclosure_marshal_VOID__DOUBLEv (closure=<optimized out>, return_value=<optimized out>, instance=<optimized out>, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0xa413a0) at /build/buildd/glib2.0-2.33.3/./gobject/gmarshal.c:928
 _g_closure_invoke_va (closure=0xb240c0, return_value=0x0, instance=0xafb6a0, args=0x7fff77c23da8, n_params=1, param_types=0xa413a0) at /build/buildd/glib2.0-2.33.3/./gobject/gclosure.c:840
 g_signal_emit_valist (instance=0xafb6a0, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7fff77c23da8) at /build/buildd/glib2.0-2.33.3/./gobject/gsignal.c:3211
 g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>) at /build/buildd/glib2.0-2.33.3/./gobject/gsignal.c:3356

Changed in file-roller (Ubuntu):
importance: Undecided → Medium
summary: - file-roller crashed with SIGSEGV in g_cclosure_marshal_VOID__DOUBLEv()
+ file-roller crashed with SIGSEGV in fr_window_progress_cb()
tags: removed: need-amd64-retrace
tags: added: running-unity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in file-roller (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you try if that's still an issue with 3.5.4-0ubuntu2?

visibility: private → public
Changed in file-roller (Ubuntu):
status: Confirmed → Incomplete

Hello,

There is no problem anymore with version 3.5.4-0ubuntu2. Thank you for your effort.

I will close this bug report, if it occurs to anyone else of you guys, feel free to reopen it.

Cheers,

Changed in file-roller (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers